add expat package
SVN-Revision: 1656
This commit is contained in:
parent
da32248a24
commit
fd742beb74
6 changed files with 157 additions and 0 deletions
|
@ -113,6 +113,7 @@ source "package/libart/Config.in"
|
|||
source "package/libdb/Config.in"
|
||||
source "package/libelf/Config.in"
|
||||
source "package/libevent/Config.in"
|
||||
source "package/expat/Config.in" # libexpat
|
||||
source "package/freetype/Config.in" # libfreetype
|
||||
source "package/libgcrypt/Config.in"
|
||||
source "package/libgd/Config.in"
|
||||
|
|
|
@ -29,6 +29,7 @@ package-$(BR2_PACKAGE_DSNIFF) += dsniff
|
|||
package-$(BR2_PACKAGE_E2FSPROGS) += e2fsprogs
|
||||
package-$(BR2_PACKAGE_EBTABLES) += ebtables
|
||||
package-$(BR2_PACKAGE_ETHER_WAKE) += ether-wake
|
||||
package-$(BR2_COMPILE_EXPAT) += expat
|
||||
package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
|
||||
package-$(BR2_PACKAGE_FPING) += fping
|
||||
package-$(BR2_PACKAGE_FPROBE) += fprobe
|
||||
|
|
16
openwrt/package/expat/Config.in
Normal file
16
openwrt/package/expat/Config.in
Normal file
|
@ -0,0 +1,16 @@
|
|||
config BR2_COMPILE_EXPAT
|
||||
bool
|
||||
default n
|
||||
depends BR2_PACKAGE_LIBEXPAT
|
||||
|
||||
config BR2_PACKAGE_LIBEXPAT
|
||||
tristate "libexpat - a fast, non-validating, stream-oriented XML parsing library"
|
||||
# default m if CONFIG_DEVEL
|
||||
default n
|
||||
select BR2_COMPILE_EXPAT
|
||||
help
|
||||
A fast, non-validating, stream-oriented XML parsing library
|
||||
|
||||
http://expat.sourceforge.net/
|
||||
|
||||
|
89
openwrt/package/expat/Makefile
Normal file
89
openwrt/package/expat/Makefile
Normal file
|
@ -0,0 +1,89 @@
|
|||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=expat
|
||||
PKG_VERSION:=1.95.8
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=aff487543845a82fe262e6e2922b4c8e
|
||||
|
||||
PKG_SOURCE_URL:=@SF/expat
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,LIBEXPAT,libexpat,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||
(cd $(PKG_BUILD_DIR) ; rm -rf config.{cache,status} ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
);
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
touch $@
|
||||
|
||||
$(IPKG_LIBEXPAT):
|
||||
install -m0755 -d $(IDIR_LIBEXPAT)/usr/lib
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(IDIR_LIBEXPAT)/usr/lib/
|
||||
$(RSTRIP) $(IDIR_LIBEXPAT)
|
||||
$(IPKG_BUILD) $(IDIR_LIBEXPAT) $(PACKAGE_DIR)
|
||||
|
||||
$(STAGING_DIR)/usr/lib/libexpat.so: $(PKG_BUILD_DIR)/.built
|
||||
mkdir -p $(STAGING_DIR)/usr/bin
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/xmlwf $(STAGING_DIR)/usr/bin/
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/include/expat*.h $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libexpat.{a,so*} $(STAGING_DIR)/usr/lib/
|
||||
touch $@
|
||||
|
||||
install-dev: $(STAGING_DIR)/usr/lib/libexpat.so
|
||||
|
||||
uninstall-dev:
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/bin/xmlwf \
|
||||
$(STAGING_DIR)/usr/include/expat*.h \
|
||||
$(STAGING_DIR)/usr/lib/libexpat.{a,so*} \
|
||||
|
||||
compile: install-dev
|
||||
clean: uninstall-dev
|
||||
|
||||
mostlyclean:
|
||||
make -C $(PKG_BUILD_DIR) clean
|
||||
rm $(PKG_BUILD_DIR)/.built
|
||||
|
6
openwrt/package/expat/ipkg/libexpat.control
Normal file
6
openwrt/package/expat/ipkg/libexpat.control
Normal file
|
@ -0,0 +1,6 @@
|
|||
Package: libexpat
|
||||
Priority: optional
|
||||
Section: net
|
||||
Maintainer: OpenWrt Developers Team <bugs@openwrt.org>
|
||||
Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/expat/
|
||||
Description: a fast, non-validating, stream-oriented XML parsing library
|
44
openwrt/package/expat/patches/001-destdir.patch
Normal file
44
openwrt/package/expat/patches/001-destdir.patch
Normal file
|
@ -0,0 +1,44 @@
|
|||
diff -ruN expat-1.95.8-orig/Makefile.in expat-1.95.8-1/Makefile.in
|
||||
--- expat-1.95.8-orig/Makefile.in 2004-05-07 22:00:48.000000000 +0200
|
||||
+++ expat-1.95.8-1/Makefile.in 2005-04-04 22:53:09.000000000 +0200
|
||||
@@ -34,6 +34,8 @@
|
||||
|
||||
top_builddir = .
|
||||
|
||||
+DESTDIR =
|
||||
+
|
||||
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
@@ -73,22 +75,22 @@
|
||||
tests/runtests
|
||||
|
||||
install: xmlwf/xmlwf installlib
|
||||
- $(mkinstalldirs) $(bindir) $(man1dir)
|
||||
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(bindir)/xmlwf
|
||||
- $(INSTALL_DATA) $(MANFILE) $(man1dir)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(DESTDIR)$(bindir)/xmlwf
|
||||
+ $(INSTALL_DATA) $(MANFILE) $(DESTDIR)$(man1dir)
|
||||
|
||||
installlib: $(LIBRARY) $(APIHEADER)
|
||||
- $(mkinstalldirs) $(libdir) $(includedir)
|
||||
- $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(libdir)/$(LIBRARY)
|
||||
- $(INSTALL_DATA) $(APIHEADER) $(includedir)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(DESTDIR)$(libdir)/$(LIBRARY)
|
||||
+ $(INSTALL_DATA) $(APIHEADER) $(DESTDIR)$(includedir)
|
||||
|
||||
uninstall: uninstalllib
|
||||
- $(LIBTOOL) --mode=uninstall rm -f $(bindir)/xmlwf
|
||||
+ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(bindir)/xmlwf
|
||||
rm -f $(man1dir)/xmlwf.1
|
||||
|
||||
uninstalllib:
|
||||
- $(LIBTOOL) --mode=uninstall rm -f $(libdir)/$(LIBRARY)
|
||||
- rm -f $(includedir)/$(APIHEADER)
|
||||
+ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(libdir)/$(LIBRARY)
|
||||
+ rm -f $(DESTDIR)$(includedir)/$(APIHEADER)
|
||||
|
||||
# for VPATH builds (invoked by configure)
|
||||
mkdir-init:
|
Loading…
Reference in a new issue