upgrade to dnsmasq 2.25
SVN-Revision: 2986
This commit is contained in:
parent
7b8ae750ab
commit
fd4279b8ed
2 changed files with 2 additions and 51 deletions
|
@ -3,9 +3,9 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dnsmasq
|
||||
PKG_VERSION:=2.24
|
||||
PKG_VERSION:=2.25
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=d269531be1f130ab642c71c593138d31
|
||||
PKG_MD5SUM:=a5a387aed551acf91990567a5e8e4fa4
|
||||
|
||||
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
|
|
@ -1,49 +0,0 @@
|
|||
diff -ur dnsmasq-2.15.orig/src/config.h dnsmasq-2.15/src/config.h
|
||||
--- dnsmasq-2.15.orig/src/config.h 2004-10-08 11:41:34.757371880 -0400
|
||||
+++ dnsmasq-2.15/src/config.h 2004-10-08 11:43:49.074952504 -0400
|
||||
@@ -78,6 +78,11 @@
|
||||
/* We assume that systems which don't have IPv6
|
||||
headers don't have ntop and pton either */
|
||||
|
||||
+#if defined(__UCLIBC__) && !defined(__UCLIBC_HAS_IPV6__)
|
||||
+# undef NO_IPV6
|
||||
+# define NO_IPV6
|
||||
+#endif
|
||||
+
|
||||
#if defined(INET6_ADDRSTRLEN) && defined(IPV6_V6ONLY) && !defined(NO_IPV6)
|
||||
# define HAVE_IPV6
|
||||
# define ADDRSTRLEN INET6_ADDRSTRLEN
|
||||
@@ -194,7 +199,7 @@
|
||||
/* platform dependent options. */
|
||||
|
||||
/* Must preceed __linux__ since uClinux defines __linux__ too. */
|
||||
-#if defined(__uClinux__) || defined(__UCLIBC__)
|
||||
+#if defined(__uClinux__)
|
||||
#undef HAVE_LINUX_IPV6_PROC
|
||||
#define HAVE_GETOPT_LONG
|
||||
#undef HAVE_ARC4RANDOM
|
||||
@@ -208,6 +213,24 @@
|
||||
# define NO_FORK
|
||||
#endif
|
||||
|
||||
+#elif defined(__linux__) && defined(__UCLIBC__)
|
||||
+# define HAVE_LINUX_IPV6_PROC
|
||||
+# if defined(__UCLIBC_HAS_GNU_GETOPT__) || \
|
||||
+ ((__UCLIBC_MAJOR__==0) && (__UCLIBC_MINOR__==9) && (__UCLIBC_SUBLEVEL__<21))
|
||||
+# define HAVE_GETOPT_LONG
|
||||
+# else
|
||||
+# undef HAVE_GETOPT_LONG
|
||||
+# endif
|
||||
+#undef HAVE_ARC4RANDOM
|
||||
+#define HAVE_RANDOM
|
||||
+#define HAVE_DEV_URANDOM
|
||||
+#define HAVE_DEV_RANDOM
|
||||
+#undef HAVE_SOCKADDR_SA_LEN
|
||||
+#undef HAVE_PSELECT
|
||||
+#if !defined(__ARCH_HAS_MMU__)
|
||||
+# define NO_FORK
|
||||
+#endif
|
||||
+
|
||||
/* libc5 - must precede __linux__ too */
|
||||
/* Note to build a libc5 binary on a modern Debian system:
|
||||
install the packages altgcc libc5 and libc5-altdev
|
Loading…
Reference in a new issue