ramips: irq handlers do not get irq in 4.3 kernel, update patches

This resolves compilation warnings like this:
drivers/gpio/gpio-mt7621.c: In function 'mediatek_gpio_probe':
drivers/gpio/gpio-mt7621.c:328:46: warning: passing argument 2 of 'irq_set_chained_handler' from incompatible pointer type [-Wincompatible-pointer-types]
   irq_set_chained_handler(mediatek_gpio_irq, mediatek_gpio_irq_handler);

Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>

SVN-Revision: 47841
This commit is contained in:
John Crispin 2015-12-11 15:03:16 +00:00
parent 4076d12f41
commit fbc1624d6a
2 changed files with 4 additions and 29 deletions

View file

@ -18,9 +18,6 @@ Cc: linux-gpio@vger.kernel.org
create mode 100644 arch/mips/include/asm/mach-ralink/gpio.h
create mode 100644 drivers/gpio/gpio-ralink.c
diff --git a/arch/mips/include/asm/mach-ralink/gpio.h b/arch/mips/include/asm/mach-ralink/gpio.h
new file mode 100644
index 0000000..f68ee16
--- /dev/null
+++ b/arch/mips/include/asm/mach-ralink/gpio.h
@@ -0,0 +1,24 @@
@ -48,8 +45,6 @@ index 0000000..f68ee16
+#define gpio_to_irq __gpio_to_irq
+
+#endif /* __ASM_MACH_RALINK_GPIO_H */
diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
index 8949b3f..4a3e7df 100644
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -404,6 +404,12 @@ config GPIO_SCH311X
@ -65,11 +60,9 @@ index 8949b3f..4a3e7df 100644
config GPIO_SPEAR_SPICS
bool "ST SPEAr13xx SPI Chip Select as GPIO support"
depends on PLAT_SPEAR
diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile
index f79a7c4..13448d78 100644
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
@@ -75,6 +75,7 @@ obj-$(CONFIG_GPIO_PCF857X) += gpio-pcf857x.o
@@ -75,6 +75,7 @@ obj-$(CONFIG_GPIO_PCF857X) += gpio-pcf85
obj-$(CONFIG_GPIO_PCH) += gpio-pch.o
obj-$(CONFIG_GPIO_PL061) += gpio-pl061.o
obj-$(CONFIG_GPIO_PXA) += gpio-pxa.o
@ -77,9 +70,6 @@ index f79a7c4..13448d78 100644
obj-$(CONFIG_GPIO_RC5T583) += gpio-rc5t583.o
obj-$(CONFIG_GPIO_RDC321X) += gpio-rdc321x.o
obj-$(CONFIG_GPIO_RCAR) += gpio-rcar.o
diff --git a/drivers/gpio/gpio-ralink.c b/drivers/gpio/gpio-ralink.c
new file mode 100644
index 0000000..2be9b8a
--- /dev/null
+++ b/drivers/gpio/gpio-ralink.c
@@ -0,0 +1,355 @@
@ -208,7 +198,7 @@ index 0000000..2be9b8a
+ return irq_create_mapping(rg->domain, pin);
+}
+
+static void ralink_gpio_irq_handler(unsigned int irq, struct irq_desc *desc)
+static void ralink_gpio_irq_handler(struct irq_desc *desc)
+{
+ int i;
+
@ -438,6 +428,3 @@ index 0000000..2be9b8a
+}
+
+subsys_initcall(ralink_gpio_init);
--
1.7.10.4

View file

@ -12,8 +12,6 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
4 files changed, 364 insertions(+)
create mode 100644 drivers/gpio/gpio-mt7621.c
diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
index 0098bff..94ea345 100644
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -559,6 +559,9 @@ config RALINK
@ -26,8 +24,6 @@ index 0098bff..94ea345 100644
config SGI_IP22
bool "SGI IP22 (Indy/Indigo2)"
diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
index 4a3e7df..13f860c 100644
--- a/drivers/gpio/Kconfig
+++ b/drivers/gpio/Kconfig
@@ -269,6 +269,12 @@ config GPIO_MB86S7X
@ -43,18 +39,13 @@ index 4a3e7df..13f860c 100644
config GPIO_MM_LANTIQ
bool "Lantiq Memory mapped GPIOs"
depends on LANTIQ && SOC_XWAY
diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile
index 13448d78..5563d6e 100644
--- a/drivers/gpio/Makefile
+++ b/drivers/gpio/Makefile
@@ -119,3 +119,4 @@ obj-$(CONFIG_GPIO_XTENSA) += gpio-xtensa.o
@@ -119,3 +119,4 @@ obj-$(CONFIG_GPIO_XTENSA) += gpio-xtensa
obj-$(CONFIG_GPIO_ZEVIO) += gpio-zevio.o
obj-$(CONFIG_GPIO_ZYNQ) += gpio-zynq.o
obj-$(CONFIG_GPIO_ZX) += gpio-zx.o
+obj-$(CONFIG_GPIO_MT7621) += gpio-mt7621.o
diff --git a/drivers/gpio/gpio-mt7621.c b/drivers/gpio/gpio-mt7621.c
new file mode 100644
index 0000000..7a98b94
--- /dev/null
+++ b/drivers/gpio/gpio-mt7621.c
@@ -0,0 +1,354 @@
@ -243,7 +234,7 @@ index 0000000..7a98b94
+}
+
+static void
+mediatek_gpio_irq_handler(unsigned int irq, struct irq_desc *desc)
+mediatek_gpio_irq_handler(struct irq_desc *desc)
+{
+ int i;
+
@ -412,6 +403,3 @@ index 0000000..7a98b94
+}
+
+subsys_initcall(mediatek_gpio_init);
--
1.7.10.4