parent
13c862a0d5
commit
f506ac7d81
4 changed files with 9 additions and 26 deletions
|
@ -9,12 +9,12 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=dnsmasq
|
PKG_NAME:=dnsmasq
|
||||||
PKG_VERSION:=2.38
|
PKG_VERSION:=2.39
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
|
||||||
PKG_MD5SUM:=ab066a97c226066485ad20e5ad5ce424
|
PKG_MD5SUM:=1ffccc1f0d9b8a08f2b99e03ba9cc08b
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
Index: dnsmasq-2.38/src/config.h
|
Index: dnsmasq-2.39/src/config.h
|
||||||
===================================================================
|
===================================================================
|
||||||
--- dnsmasq-2.38.orig/src/config.h 2007-06-04 13:22:23.553274640 +0200
|
--- dnsmasq-2.39.orig/src/config.h 2007-06-26 19:16:31.000000000 +0200
|
||||||
+++ dnsmasq-2.38/src/config.h 2007-06-04 13:22:23.626263544 +0200
|
+++ dnsmasq-2.39/src/config.h 2007-06-26 19:16:31.000000000 +0200
|
||||||
@@ -280,8 +280,9 @@
|
@@ -281,8 +281,9 @@
|
||||||
/* We assume that systems which don't have IPv6
|
/* We assume that systems which don't have IPv6
|
||||||
headers don't have ntop and pton either */
|
headers don't have ntop and pton either */
|
||||||
|
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
Index: dnsmasq-2.38/src/netlink.c
|
Index: dnsmasq-2.39/src/netlink.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- dnsmasq-2.38.orig/src/netlink.c 2007-06-04 13:22:23.531277984 +0200
|
--- dnsmasq-2.39.orig/src/netlink.c 2007-06-26 19:16:31.000000000 +0200
|
||||||
+++ dnsmasq-2.38/src/netlink.c 2007-06-04 13:22:23.814234968 +0200
|
+++ dnsmasq-2.39/src/netlink.c 2007-06-26 19:16:31.000000000 +0200
|
||||||
@@ -17,6 +17,10 @@
|
@@ -17,6 +17,10 @@
|
||||||
#include <linux/types.h>
|
#include <linux/types.h>
|
||||||
#include <linux/netlink.h>
|
#include <linux/netlink.h>
|
||||||
|
|
|
@ -1,17 +0,0 @@
|
||||||
Index: dnsmasq-2.38/src/cache.c
|
|
||||||
===================================================================
|
|
||||||
--- dnsmasq-2.38.orig/src/cache.c 2007-06-04 13:22:23.510281176 +0200
|
|
||||||
+++ dnsmasq-2.38/src/cache.c 2007-06-04 13:22:24.014204568 +0200
|
|
||||||
@@ -749,10 +749,11 @@
|
|
||||||
while ((token = strtok(NULL, " \t\n\r")) && (*token != '#'))
|
|
||||||
{
|
|
||||||
struct crec *cache;
|
|
||||||
+ int fqdn = !!strchr(token, '.');
|
|
||||||
if (canonicalise(token))
|
|
||||||
{
|
|
||||||
/* If set, add a version of the name with a default domain appended */
|
|
||||||
- if ((opts & OPT_EXPAND) && domain_suffix && !strchr(token, '.') &&
|
|
||||||
+ if ((opts & OPT_EXPAND) && domain_suffix && !fqdn &&
|
|
||||||
(cache = malloc(sizeof(struct crec) +
|
|
||||||
strlen(token)+2+strlen(domain_suffix)-SMALLDNAME)))
|
|
||||||
{
|
|
Loading…
Reference in a new issue