kernel: bump 4.14 to 4.14.52
Refreshed all patches Compile-tested on: cns3xxx, imx6, x86_64 Runtime-tested on: cns3xxx, imx6, x86_64 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
8e622aae58
commit
f4ac88b509
10 changed files with 30 additions and 58 deletions
|
@ -4,13 +4,13 @@ LINUX_RELEASE?=1
|
||||||
|
|
||||||
LINUX_VERSION-3.18 = .71
|
LINUX_VERSION-3.18 = .71
|
||||||
LINUX_VERSION-4.4 = .121
|
LINUX_VERSION-4.4 = .121
|
||||||
LINUX_VERSION-4.14 = .51
|
|
||||||
LINUX_VERSION-4.9 = .110
|
LINUX_VERSION-4.9 = .110
|
||||||
|
LINUX_VERSION-4.14 = .52
|
||||||
|
|
||||||
LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
|
LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
|
||||||
LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
|
LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
|
||||||
LINUX_KERNEL_HASH-4.14.51 = dab2402baa2444348f9b3c354e8f65382a466d1766942a57441209f9a2df972b
|
|
||||||
LINUX_KERNEL_HASH-4.9.110 = 379a143a70a79f0eea6c9f6638942b65e6043abdde17ad23264c0abd93c4ea7a
|
LINUX_KERNEL_HASH-4.9.110 = 379a143a70a79f0eea6c9f6638942b65e6043abdde17ad23264c0abd93c4ea7a
|
||||||
|
LINUX_KERNEL_HASH-4.14.52 = a5d226c7b2fd1eb0f01d56e4e2c6a0100784b68df907cc7317f32bde34f88810
|
||||||
|
|
||||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||||
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
|
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
|
||||||
|
|
|
@ -37,11 +37,9 @@ Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
|
||||||
net/netfilter/xt_FLOWOFFLOAD.c | 32 ++++++++++++++++++++++++++++++++
|
net/netfilter/xt_FLOWOFFLOAD.c | 32 ++++++++++++++++++++++++++++++++
|
||||||
1 file changed, 32 insertions(+)
|
1 file changed, 32 insertions(+)
|
||||||
|
|
||||||
diff --git a/net/netfilter/xt_FLOWOFFLOAD.c b/net/netfilter/xt_FLOWOFFLOAD.c
|
|
||||||
index ab6259e..3bea08e 100644
|
|
||||||
--- a/net/netfilter/xt_FLOWOFFLOAD.c
|
--- a/net/netfilter/xt_FLOWOFFLOAD.c
|
||||||
+++ b/net/netfilter/xt_FLOWOFFLOAD.c
|
+++ b/net/netfilter/xt_FLOWOFFLOAD.c
|
||||||
@@ -337,10 +337,41 @@ static void xt_flowoffload_table_cleanup(struct nf_flowtable *table)
|
@@ -340,10 +340,41 @@ static void xt_flowoffload_table_cleanup
|
||||||
nf_flow_table_free(table);
|
nf_flow_table_free(table);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -83,7 +81,7 @@ index ab6259e..3bea08e 100644
|
||||||
INIT_DELAYED_WORK(&hook_work, xt_flowoffload_hook_work);
|
INIT_DELAYED_WORK(&hook_work, xt_flowoffload_hook_work);
|
||||||
|
|
||||||
ret = xt_flowoffload_table_init(&nf_flowtable);
|
ret = xt_flowoffload_table_init(&nf_flowtable);
|
||||||
@@ -358,6 +389,7 @@ static void __exit xt_flowoffload_tg_exit(void)
|
@@ -361,6 +392,7 @@ static void __exit xt_flowoffload_tg_exi
|
||||||
{
|
{
|
||||||
xt_unregister_target(&offload_tg_reg);
|
xt_unregister_target(&offload_tg_reg);
|
||||||
xt_flowoffload_table_cleanup(&nf_flowtable);
|
xt_flowoffload_table_cleanup(&nf_flowtable);
|
||||||
|
@ -91,6 +89,3 @@ index ab6259e..3bea08e 100644
|
||||||
}
|
}
|
||||||
|
|
||||||
MODULE_LICENSE("GPL");
|
MODULE_LICENSE("GPL");
|
||||||
--
|
|
||||||
2.17.0
|
|
||||||
|
|
||||||
|
|
|
@ -71,7 +71,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
|
||||||
|
|
||||||
--- a/mm/page_alloc.c
|
--- a/mm/page_alloc.c
|
||||||
+++ b/mm/page_alloc.c
|
+++ b/mm/page_alloc.c
|
||||||
@@ -6147,7 +6147,7 @@ static void __ref alloc_node_mem_map(str
|
@@ -6146,7 +6146,7 @@ static void __ref alloc_node_mem_map(str
|
||||||
mem_map = NODE_DATA(0)->node_mem_map;
|
mem_map = NODE_DATA(0)->node_mem_map;
|
||||||
#if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
|
#if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
|
||||||
if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
|
if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
|
||||||
|
|
|
@ -141,7 +141,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
static const struct rt6_info ip6_blk_hole_entry_template = {
|
static const struct rt6_info ip6_blk_hole_entry_template = {
|
||||||
.dst = {
|
.dst = {
|
||||||
.__refcnt = ATOMIC_INIT(1),
|
.__refcnt = ATOMIC_INIT(1),
|
||||||
@@ -2046,6 +2063,11 @@ static struct rt6_info *ip6_route_info_c
|
@@ -2043,6 +2060,11 @@ static struct rt6_info *ip6_route_info_c
|
||||||
rt->dst.output = ip6_pkt_prohibit_out;
|
rt->dst.output = ip6_pkt_prohibit_out;
|
||||||
rt->dst.input = ip6_pkt_prohibit;
|
rt->dst.input = ip6_pkt_prohibit;
|
||||||
break;
|
break;
|
||||||
|
@ -153,7 +153,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
case RTN_THROW:
|
case RTN_THROW:
|
||||||
case RTN_UNREACHABLE:
|
case RTN_UNREACHABLE:
|
||||||
default:
|
default:
|
||||||
@@ -2771,6 +2793,17 @@ static int ip6_pkt_prohibit_out(struct n
|
@@ -2768,6 +2790,17 @@ static int ip6_pkt_prohibit_out(struct n
|
||||||
return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
|
return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -171,7 +171,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
/*
|
/*
|
||||||
* Allocate a dst for local (unicast / anycast) address.
|
* Allocate a dst for local (unicast / anycast) address.
|
||||||
*/
|
*/
|
||||||
@@ -3007,7 +3040,8 @@ static int rtm_to_fib6_config(struct sk_
|
@@ -3004,7 +3037,8 @@ static int rtm_to_fib6_config(struct sk_
|
||||||
if (rtm->rtm_type == RTN_UNREACHABLE ||
|
if (rtm->rtm_type == RTN_UNREACHABLE ||
|
||||||
rtm->rtm_type == RTN_BLACKHOLE ||
|
rtm->rtm_type == RTN_BLACKHOLE ||
|
||||||
rtm->rtm_type == RTN_PROHIBIT ||
|
rtm->rtm_type == RTN_PROHIBIT ||
|
||||||
|
@ -181,7 +181,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
cfg->fc_flags |= RTF_REJECT;
|
cfg->fc_flags |= RTF_REJECT;
|
||||||
|
|
||||||
if (rtm->rtm_type == RTN_LOCAL)
|
if (rtm->rtm_type == RTN_LOCAL)
|
||||||
@@ -3497,6 +3531,9 @@ static int rt6_fill_node(struct net *net
|
@@ -3494,6 +3528,9 @@ static int rt6_fill_node(struct net *net
|
||||||
case -EACCES:
|
case -EACCES:
|
||||||
rtm->rtm_type = RTN_PROHIBIT;
|
rtm->rtm_type = RTN_PROHIBIT;
|
||||||
break;
|
break;
|
||||||
|
@ -191,7 +191,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
case -EAGAIN:
|
case -EAGAIN:
|
||||||
rtm->rtm_type = RTN_THROW;
|
rtm->rtm_type = RTN_THROW;
|
||||||
break;
|
break;
|
||||||
@@ -3815,6 +3852,8 @@ static int ip6_route_dev_notify(struct n
|
@@ -3812,6 +3849,8 @@ static int ip6_route_dev_notify(struct n
|
||||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||||
net->ipv6.ip6_prohibit_entry->dst.dev = dev;
|
net->ipv6.ip6_prohibit_entry->dst.dev = dev;
|
||||||
net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
|
net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
|
||||||
|
@ -200,7 +200,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
|
net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
|
||||||
net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
|
net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
|
||||||
#endif
|
#endif
|
||||||
@@ -3826,6 +3865,7 @@ static int ip6_route_dev_notify(struct n
|
@@ -3823,6 +3862,7 @@ static int ip6_route_dev_notify(struct n
|
||||||
in6_dev_put_clear(&net->ipv6.ip6_null_entry->rt6i_idev);
|
in6_dev_put_clear(&net->ipv6.ip6_null_entry->rt6i_idev);
|
||||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||||
in6_dev_put_clear(&net->ipv6.ip6_prohibit_entry->rt6i_idev);
|
in6_dev_put_clear(&net->ipv6.ip6_prohibit_entry->rt6i_idev);
|
||||||
|
@ -208,7 +208,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
in6_dev_put_clear(&net->ipv6.ip6_blk_hole_entry->rt6i_idev);
|
in6_dev_put_clear(&net->ipv6.ip6_blk_hole_entry->rt6i_idev);
|
||||||
#endif
|
#endif
|
||||||
}
|
}
|
||||||
@@ -4042,6 +4082,17 @@ static int __net_init ip6_route_net_init
|
@@ -4039,6 +4079,17 @@ static int __net_init ip6_route_net_init
|
||||||
net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
|
net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
|
||||||
dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
|
dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
|
||||||
ip6_template_metrics, true);
|
ip6_template_metrics, true);
|
||||||
|
@ -226,7 +226,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
net->ipv6.sysctl.flush_delay = 0;
|
net->ipv6.sysctl.flush_delay = 0;
|
||||||
@@ -4060,6 +4111,8 @@ out:
|
@@ -4057,6 +4108,8 @@ out:
|
||||||
return ret;
|
return ret;
|
||||||
|
|
||||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||||
|
@ -235,7 +235,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
out_ip6_prohibit_entry:
|
out_ip6_prohibit_entry:
|
||||||
kfree(net->ipv6.ip6_prohibit_entry);
|
kfree(net->ipv6.ip6_prohibit_entry);
|
||||||
out_ip6_null_entry:
|
out_ip6_null_entry:
|
||||||
@@ -4077,6 +4130,7 @@ static void __net_exit ip6_route_net_exi
|
@@ -4074,6 +4127,7 @@ static void __net_exit ip6_route_net_exi
|
||||||
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
#ifdef CONFIG_IPV6_MULTIPLE_TABLES
|
||||||
kfree(net->ipv6.ip6_prohibit_entry);
|
kfree(net->ipv6.ip6_prohibit_entry);
|
||||||
kfree(net->ipv6.ip6_blk_hole_entry);
|
kfree(net->ipv6.ip6_blk_hole_entry);
|
||||||
|
@ -243,7 +243,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
|
||||||
#endif
|
#endif
|
||||||
dst_entries_destroy(&net->ipv6.ip6_dst_ops);
|
dst_entries_destroy(&net->ipv6.ip6_dst_ops);
|
||||||
}
|
}
|
||||||
@@ -4150,6 +4204,9 @@ void __init ip6_route_init_special_entri
|
@@ -4147,6 +4201,9 @@ void __init ip6_route_init_special_entri
|
||||||
init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
|
init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
|
||||||
init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
|
init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
|
||||||
init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
|
init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
|
||||||
|
|
|
@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
||||||
/**
|
/**
|
||||||
* ata_build_rw_tf - Build ATA taskfile for given read/write request
|
* ata_build_rw_tf - Build ATA taskfile for given read/write request
|
||||||
* @tf: Target ATA taskfile
|
* @tf: Target ATA taskfile
|
||||||
@@ -5120,6 +5133,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
@@ -5117,6 +5130,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
||||||
if (tag < 0)
|
if (tag < 0)
|
||||||
return NULL;
|
return NULL;
|
||||||
}
|
}
|
||||||
|
@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
||||||
|
|
||||||
qc = __ata_qc_from_tag(ap, tag);
|
qc = __ata_qc_from_tag(ap, tag);
|
||||||
qc->tag = tag;
|
qc->tag = tag;
|
||||||
@@ -6021,6 +6037,9 @@ struct ata_port *ata_port_alloc(struct a
|
@@ -6018,6 +6034,9 @@ struct ata_port *ata_port_alloc(struct a
|
||||||
ap->stats.unhandled_irq = 1;
|
ap->stats.unhandled_irq = 1;
|
||||||
ap->stats.idle_irq = 1;
|
ap->stats.idle_irq = 1;
|
||||||
#endif
|
#endif
|
||||||
|
@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
||||||
ata_sff_port_init(ap);
|
ata_sff_port_init(ap);
|
||||||
|
|
||||||
return ap;
|
return ap;
|
||||||
@@ -6042,6 +6061,12 @@ static void ata_host_release(struct devi
|
@@ -6039,6 +6058,12 @@ static void ata_host_release(struct devi
|
||||||
|
|
||||||
kfree(ap->pmp_link);
|
kfree(ap->pmp_link);
|
||||||
kfree(ap->slave_link);
|
kfree(ap->slave_link);
|
||||||
|
@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
||||||
kfree(ap);
|
kfree(ap);
|
||||||
host->ports[i] = NULL;
|
host->ports[i] = NULL;
|
||||||
}
|
}
|
||||||
@@ -6488,7 +6513,23 @@ int ata_host_register(struct ata_host *h
|
@@ -6485,7 +6510,23 @@ int ata_host_register(struct ata_host *h
|
||||||
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
|
host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
|
||||||
host->ports[i]->local_port_no = i + 1;
|
host->ports[i]->local_port_no = i + 1;
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,7 +1,5 @@
|
||||||
Index: linux-4.14.50/drivers/mtd/spi-nor/spi-nor.c
|
--- a/drivers/mtd/spi-nor/spi-nor.c
|
||||||
===================================================================
|
+++ b/drivers/mtd/spi-nor/spi-nor.c
|
||||||
--- linux-4.14.50.orig/drivers/mtd/spi-nor/spi-nor.c
|
|
||||||
+++ linux-4.14.50/drivers/mtd/spi-nor/spi-nor.c
|
|
||||||
@@ -1025,6 +1025,7 @@ static const struct flash_info spi_nor_i
|
@@ -1025,6 +1025,7 @@ static const struct flash_info spi_nor_i
|
||||||
{ "mx25l12805d", INFO(0xc22018, 0, 64 * 1024, 256, 0) },
|
{ "mx25l12805d", INFO(0xc22018, 0, 64 * 1024, 256, 0) },
|
||||||
{ "mx25l12855e", INFO(0xc22618, 0, 64 * 1024, 256, 0) },
|
{ "mx25l12855e", INFO(0xc22618, 0, 64 * 1024, 256, 0) },
|
||||||
|
|
|
@ -7,11 +7,9 @@ Subject: [PATCH] arm: dts: Add missing mt7623 pcie nodes
|
||||||
arch/arm/boot/dts/mt7623.dtsi | 105 ++++++++++++++++++++++++++++++++++++++++++
|
arch/arm/boot/dts/mt7623.dtsi | 105 ++++++++++++++++++++++++++++++++++++++++++
|
||||||
1 file changed, 105 insertions(+)
|
1 file changed, 105 insertions(+)
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/mt7623.dtsi b/arch/arm/boot/dts/mt7623.dtsi
|
|
||||||
index 36983a7d7..714245365 100644
|
|
||||||
--- a/arch/arm/boot/dts/mt7623.dtsi
|
--- a/arch/arm/boot/dts/mt7623.dtsi
|
||||||
+++ b/arch/arm/boot/dts/mt7623.dtsi
|
+++ b/arch/arm/boot/dts/mt7623.dtsi
|
||||||
@@ -669,6 +669,111 @@
|
@@ -670,6 +670,111 @@
|
||||||
#reset-cells = <1>;
|
#reset-cells = <1>;
|
||||||
};
|
};
|
||||||
|
|
||||||
|
@ -123,6 +121,3 @@ index 36983a7d7..714245365 100644
|
||||||
usb1: usb@1a1c0000 {
|
usb1: usb@1a1c0000 {
|
||||||
compatible = "mediatek,mt7623-xhci",
|
compatible = "mediatek,mt7623-xhci",
|
||||||
"mediatek,mt8173-xhci";
|
"mediatek,mt8173-xhci";
|
||||||
--
|
|
||||||
2.14.1
|
|
||||||
|
|
||||||
|
|
|
@ -7,12 +7,10 @@ Subject: [PATCH] phy: phy-mtk-tphy: Add hifsys-support
|
||||||
drivers/phy/mediatek/phy-mtk-tphy.c | 20 ++++++++++++++++++++
|
drivers/phy/mediatek/phy-mtk-tphy.c | 20 ++++++++++++++++++++
|
||||||
1 file changed, 20 insertions(+)
|
1 file changed, 20 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/phy/mediatek/phy-mtk-tphy.c b/drivers/phy/mediatek/phy-mtk-tphy.c
|
|
||||||
index 721a2a1c9..0cb1cea53 100644
|
|
||||||
--- a/drivers/phy/mediatek/phy-mtk-tphy.c
|
--- a/drivers/phy/mediatek/phy-mtk-tphy.c
|
||||||
+++ b/drivers/phy/mediatek/phy-mtk-tphy.c
|
+++ b/drivers/phy/mediatek/phy-mtk-tphy.c
|
||||||
@@ -22,6 +22,8 @@
|
@@ -23,6 +23,8 @@
|
||||||
#include <linux/of_address.h>
|
#include <linux/of_device.h>
|
||||||
#include <linux/phy/phy.h>
|
#include <linux/phy/phy.h>
|
||||||
#include <linux/platform_device.h>
|
#include <linux/platform_device.h>
|
||||||
+#include <linux/mfd/syscon.h>
|
+#include <linux/mfd/syscon.h>
|
||||||
|
@ -20,7 +18,7 @@ index 721a2a1c9..0cb1cea53 100644
|
||||||
|
|
||||||
/* version V1 sub-banks offset base address */
|
/* version V1 sub-banks offset base address */
|
||||||
/* banks shared by multiple phys */
|
/* banks shared by multiple phys */
|
||||||
@@ -259,6 +261,9 @@
|
@@ -262,6 +264,9 @@
|
||||||
#define RG_CDR_BIRLTD0_GEN3_MSK GENMASK(4, 0)
|
#define RG_CDR_BIRLTD0_GEN3_MSK GENMASK(4, 0)
|
||||||
#define RG_CDR_BIRLTD0_GEN3_VAL(x) (0x1f & (x))
|
#define RG_CDR_BIRLTD0_GEN3_VAL(x) (0x1f & (x))
|
||||||
|
|
||||||
|
@ -30,7 +28,7 @@ index 721a2a1c9..0cb1cea53 100644
|
||||||
enum mtk_phy_version {
|
enum mtk_phy_version {
|
||||||
MTK_PHY_V1 = 1,
|
MTK_PHY_V1 = 1,
|
||||||
MTK_PHY_V2,
|
MTK_PHY_V2,
|
||||||
@@ -302,6 +307,7 @@ struct mtk_tphy {
|
@@ -305,6 +310,7 @@ struct mtk_tphy {
|
||||||
struct clk *u3phya_ref; /* reference clock of usb3 anolog phy */
|
struct clk *u3phya_ref; /* reference clock of usb3 anolog phy */
|
||||||
const struct mtk_phy_pdata *pdata;
|
const struct mtk_phy_pdata *pdata;
|
||||||
struct mtk_phy_instance **phys;
|
struct mtk_phy_instance **phys;
|
||||||
|
@ -38,7 +36,7 @@ index 721a2a1c9..0cb1cea53 100644
|
||||||
int nphys;
|
int nphys;
|
||||||
};
|
};
|
||||||
|
|
||||||
@@ -594,6 +600,10 @@ static void pcie_phy_instance_init(struct mtk_tphy *tphy,
|
@@ -617,6 +623,10 @@ static void pcie_phy_instance_init(struc
|
||||||
if (tphy->pdata->version != MTK_PHY_V1)
|
if (tphy->pdata->version != MTK_PHY_V1)
|
||||||
return;
|
return;
|
||||||
|
|
||||||
|
@ -49,7 +47,7 @@ index 721a2a1c9..0cb1cea53 100644
|
||||||
tmp = readl(u3_banks->phya + U3P_U3_PHYA_DA_REG0);
|
tmp = readl(u3_banks->phya + U3P_U3_PHYA_DA_REG0);
|
||||||
tmp &= ~(P3A_RG_XTAL_EXT_PE1H | P3A_RG_XTAL_EXT_PE2H);
|
tmp &= ~(P3A_RG_XTAL_EXT_PE1H | P3A_RG_XTAL_EXT_PE2H);
|
||||||
tmp |= P3A_RG_XTAL_EXT_PE1H_VAL(0x2) | P3A_RG_XTAL_EXT_PE2H_VAL(0x2);
|
tmp |= P3A_RG_XTAL_EXT_PE1H_VAL(0x2) | P3A_RG_XTAL_EXT_PE2H_VAL(0x2);
|
||||||
@@ -1008,6 +1018,16 @@ static int mtk_tphy_probe(struct platform_device *pdev)
|
@@ -1042,6 +1052,16 @@ static int mtk_tphy_probe(struct platfor
|
||||||
tphy->u3phya_ref = NULL;
|
tphy->u3phya_ref = NULL;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -66,6 +64,3 @@ index 721a2a1c9..0cb1cea53 100644
|
||||||
port = 0;
|
port = 0;
|
||||||
for_each_child_of_node(np, child_np) {
|
for_each_child_of_node(np, child_np) {
|
||||||
struct mtk_phy_instance *instance;
|
struct mtk_phy_instance *instance;
|
||||||
--
|
|
||||||
2.14.1
|
|
||||||
|
|
||||||
|
|
|
@ -11,8 +11,6 @@ Subject: [PATCH] arm: dts: Add Unielec U7623 DTS
|
||||||
create mode 100644 arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts
|
create mode 100644 arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts
|
||||||
create mode 100644 arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi
|
create mode 100644 arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi
|
||||||
|
|
||||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
||||||
index 3fec84fa0..e685ce9a4 100644
|
|
||||||
--- a/arch/arm/boot/dts/Makefile
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
+++ b/arch/arm/boot/dts/Makefile
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
@@ -1062,6 +1062,7 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += \
|
@@ -1062,6 +1062,7 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += \
|
||||||
|
@ -23,9 +21,6 @@ index 3fec84fa0..e685ce9a4 100644
|
||||||
mt7623n-rfb-nand.dtb \
|
mt7623n-rfb-nand.dtb \
|
||||||
mt7623n-bananapi-bpi-r2.dtb \
|
mt7623n-bananapi-bpi-r2.dtb \
|
||||||
mt8127-moose.dtb \
|
mt8127-moose.dtb \
|
||||||
diff --git a/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts
|
|
||||||
new file mode 100644
|
|
||||||
index 000000000..3b14eccd3
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts
|
+++ b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc-512M.dts
|
||||||
@@ -0,0 +1,17 @@
|
@@ -0,0 +1,17 @@
|
||||||
|
@ -46,9 +41,6 @@ index 000000000..3b14eccd3
|
||||||
+ reg = <0 0x80000000 0 0x20000000>;
|
+ reg = <0 0x80000000 0 0x20000000>;
|
||||||
+ };
|
+ };
|
||||||
+};
|
+};
|
||||||
diff --git a/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi
|
|
||||||
new file mode 100644
|
|
||||||
index 000000000..4fc8ce8a9
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi
|
+++ b/arch/arm/boot/dts/mt7623a-unielec-u7623-02-emmc.dtsi
|
||||||
@@ -0,0 +1,374 @@
|
@@ -0,0 +1,374 @@
|
||||||
|
@ -426,6 +418,3 @@ index 000000000..4fc8ce8a9
|
||||||
+ status = "okay";
|
+ status = "okay";
|
||||||
+};
|
+};
|
||||||
+
|
+
|
||||||
--
|
|
||||||
2.14.1
|
|
||||||
|
|
||||||
|
|
|
@ -15,7 +15,7 @@
|
||||||
/* initialize internal qc */
|
/* initialize internal qc */
|
||||||
|
|
||||||
/* XXX: Tag 0 is used for drivers with legacy EH as some
|
/* XXX: Tag 0 is used for drivers with legacy EH as some
|
||||||
@@ -5127,6 +5135,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
@@ -5124,6 +5132,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
|
||||||
if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
|
if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
|
||||||
return NULL;
|
return NULL;
|
||||||
|
|
||||||
|
@ -25,7 +25,7 @@
|
||||||
/* libsas case */
|
/* libsas case */
|
||||||
if (ap->flags & ATA_FLAG_SAS_HOST) {
|
if (ap->flags & ATA_FLAG_SAS_HOST) {
|
||||||
tag = ata_sas_allocate_tag(ap);
|
tag = ata_sas_allocate_tag(ap);
|
||||||
@@ -5172,6 +5183,8 @@ void ata_qc_free(struct ata_queued_cmd *
|
@@ -5169,6 +5180,8 @@ void ata_qc_free(struct ata_queued_cmd *
|
||||||
qc->tag = ATA_TAG_POISON;
|
qc->tag = ATA_TAG_POISON;
|
||||||
if (ap->flags & ATA_FLAG_SAS_HOST)
|
if (ap->flags & ATA_FLAG_SAS_HOST)
|
||||||
ata_sas_free_tag(tag, ap);
|
ata_sas_free_tag(tag, ap);
|
||||||
|
|
Loading…
Reference in a new issue