remove more packages
SVN-Revision: 3642
This commit is contained in:
parent
e6164b615a
commit
f3ad971463
8 changed files with 0 additions and 149 deletions
|
@ -1,11 +0,0 @@
|
||||||
config BR2_PACKAGE_VNSTAT
|
|
||||||
prompt "vnstat............................ Console-based network traffic monitor"
|
|
||||||
tristate
|
|
||||||
default m if CONFIG_DEVEL
|
|
||||||
help
|
|
||||||
vnStat is a network traffic monitor for Linux that keeps a log of daily
|
|
||||||
network traffic for the selected interface(s). vnStat isn't a packet
|
|
||||||
sniffer. The traffic information is analyzed from the /proc -filesystem,
|
|
||||||
so vnStat can be used without root permissions.
|
|
||||||
.
|
|
||||||
http://humdi.net/vnstat/
|
|
|
@ -1,33 +0,0 @@
|
||||||
# $Id$
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=vnstat
|
|
||||||
PKG_VERSION:=1.4
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
PKG_MD5SUM:=9184f79b5e60499bc059f670032291e5
|
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://humdi.net/vnstat
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_CAT:=zcat
|
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
|
||||||
|
|
||||||
include $(TOPDIR)/package/rules.mk
|
|
||||||
|
|
||||||
$(eval $(call PKG_template,VNSTAT,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.configured:
|
|
||||||
touch $@
|
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.built:
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
|
||||||
$(TARGET_CONFIGURE_OPTS)
|
|
||||||
touch $@
|
|
||||||
|
|
||||||
$(IPKG_VNSTAT):
|
|
||||||
install -d -m0755 $(IDIR_VNSTAT)/usr/bin
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/src/vnstat $(IDIR_VNSTAT)/usr/bin/
|
|
||||||
$(STRIP) $(IDIR_VNSTAT)/usr/bin/*
|
|
||||||
$(IPKG_BUILD) $(IDIR_VNSTAT) $(PACKAGE_DIR)
|
|
|
@ -1,4 +0,0 @@
|
||||||
Package: vnstat
|
|
||||||
Priority: optional
|
|
||||||
Section: net
|
|
||||||
Description: Console-based network traffic monitor
|
|
|
@ -1,9 +0,0 @@
|
||||||
config BR2_PACKAGE_VPNC
|
|
||||||
prompt "vpnc.............................. VPN client for Cisco 3000"
|
|
||||||
tristate
|
|
||||||
default m if CONFIG_DEVEL
|
|
||||||
select BR2_PACKAGE_KMOD_TUN
|
|
||||||
select BR2_PACKAGE_LIBGPG_ERROR
|
|
||||||
select BR2_PACKAGE_LIBGCRYPT
|
|
||||||
help
|
|
||||||
Client for cisco3000 VPN Concentrator.
|
|
|
@ -1,40 +0,0 @@
|
||||||
# $Id$
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=vpnc
|
|
||||||
PKG_VERSION:=0.3.3
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_MD5SUM:=e7518cff21326fe7eb9795b60c25ae6a
|
|
||||||
PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_CAT:=zcat
|
|
||||||
|
|
||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
|
||||||
|
|
||||||
include $(TOPDIR)/package/rules.mk
|
|
||||||
|
|
||||||
$(eval $(call PKG_template,VPNC,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.configured:
|
|
||||||
touch $@
|
|
||||||
|
|
||||||
$(PKG_BUILD_DIR)/.built:
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
|
||||||
CC=$(TARGET_CC) \
|
|
||||||
OFLAGS="$(TARGET_CFLAGS)" \
|
|
||||||
OS="Linux" \
|
|
||||||
STAGING_DIR=$(STAGING_DIR) \
|
|
||||||
DESTDIR=$(PKG_INSTALL_DIR) \
|
|
||||||
PREFIX=/usr \
|
|
||||||
all install
|
|
||||||
touch $@
|
|
||||||
|
|
||||||
$(IPKG_VPNC):
|
|
||||||
install -d -m0755 $(IDIR_VPNC)
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/* $(IDIR_VPNC)/
|
|
||||||
$(RSTRIP) $(IDIR_VPNC)
|
|
||||||
$(IPKG_BUILD) $(IDIR_VPNC) $(PACKAGE_DIR)
|
|
|
@ -1,2 +0,0 @@
|
||||||
/etc/vpnc/vpnc.conf
|
|
||||||
/etc/vpnc/vpnc-script
|
|
|
@ -1,6 +0,0 @@
|
||||||
Package: vpnc
|
|
||||||
Section: net
|
|
||||||
Architecture: mipsel
|
|
||||||
Priority: optional
|
|
||||||
Description: client for cisco3000 VPN Concentrator.
|
|
||||||
Depends: libgpg-error libgcrypt kmod-tun
|
|
|
@ -1,44 +0,0 @@
|
||||||
diff -Nur vpnc-0.3.3/Makefile vpnc-0.3.3.patched/Makefile
|
|
||||||
--- vpnc-0.3.3/Makefile 2005-05-01 22:30:35.000000000 +0200
|
|
||||||
+++ vpnc-0.3.3.patched/Makefile 2005-12-23 23:43:55.222055250 +0100
|
|
||||||
@@ -17,31 +17,32 @@
|
|
||||||
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
|
|
||||||
|
|
||||||
DESTDIR=
|
|
||||||
-PREFIX=/usr/local
|
|
||||||
+PREFIX=/usr
|
|
||||||
ETCDIR=/etc/vpnc
|
|
||||||
SBINDIR=$(PREFIX)/sbin
|
|
||||||
MANDIR=$(PREFIX)/share/man
|
|
||||||
|
|
||||||
CC=gcc
|
|
||||||
-CFLAGS=-W -Wall -O -g '-DVERSION="$(shell cat VERSION)"' $(shell libgcrypt-config --cflags)
|
|
||||||
-LDFLAGS=-g $(shell libgcrypt-config --libs)
|
|
||||||
+CFLAGS=-W -Wall -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include $(OFLAGS) '-DVERSION="$(shell cat VERSION)"'
|
|
||||||
+LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lgcrypt -lgpg-error
|
|
||||||
|
|
||||||
-ifeq ($(shell uname -s), Linux)
|
|
||||||
+OS=$(shell uname -s)
|
|
||||||
+ifeq ($(OS), Linux)
|
|
||||||
SYSDEP=sysdep-linux.o
|
|
||||||
endif
|
|
||||||
-ifeq ($(shell uname -s), FreeBSD)
|
|
||||||
+ifeq ($(OS), FreeBSD)
|
|
||||||
CFLAGS += -DSOCKADDR_IN_SIN_LEN -DHAVE_SA_LEN
|
|
||||||
SYSDEP=sysdep-bsd.o
|
|
||||||
endif
|
|
||||||
-ifeq ($(shell uname -s), NetBSD)
|
|
||||||
+ifeq ($(OS), NetBSD)
|
|
||||||
CFLAGS += -DSOCKADDR_IN_SIN_LEN -DHAVE_SA_LEN
|
|
||||||
SYSDEP=sysdep-bsd.o
|
|
||||||
endif
|
|
||||||
-ifeq ($(shell uname -s), OpenBSD)
|
|
||||||
+ifeq ($(OS), OpenBSD)
|
|
||||||
CFLAGS += -DSOCKADDR_IN_SIN_LEN -DHAVE_SA_LEN -DNEED_IPLEN_FIX -DNEW_TUN
|
|
||||||
SYSDEP=sysdep-bsd.o
|
|
||||||
endif
|
|
||||||
-ifeq ($(shell uname -s), SunOS)
|
|
||||||
+ifeq ($(OS), SunOS)
|
|
||||||
CFLAGS += -DNEED_IPLEN_FIX
|
|
||||||
LDFLAGS += -lnsl -lresolv -lsocket
|
|
||||||
SYSDEP=sysdep-svr4.o
|
|
Loading…
Reference in a new issue