Move aodv-uu to trunk/
SVN-Revision: 6335
This commit is contained in:
parent
b37101053a
commit
f393bed10e
6 changed files with 251 additions and 0 deletions
102
package/aodv-uu/Makefile
Normal file
102
package/aodv-uu/Makefile
Normal file
|
@ -0,0 +1,102 @@
|
|||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=aodv-uu
|
||||
PKG_VERSION:=0.9.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://core.it.uu.se/core/files/
|
||||
PKG_MD5SUM:=05460543054449cb4b170252a7168c65
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/aodv-uu/Default
|
||||
TITLE:=Ad-hoc On-demand Distance Vector Routing
|
||||
DESCRIPTION:=\
|
||||
AODV is the Ad-hoc On-demand Distance Vector routing protocol \\\
|
||||
implementation created at Uppsala University.
|
||||
URL:=http://core.it.uu.se/core/index.php/AODV-UU
|
||||
endef
|
||||
|
||||
define Package/aodv-uu
|
||||
$(call Package/aodv-uu/Default)
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE+= (daemon)
|
||||
DESCRIPTION+=\\\
|
||||
\\\
|
||||
This package contains the AODV userland daemon.
|
||||
endef
|
||||
|
||||
define KernelPackage/aodv-uu
|
||||
$(call Package/aodv-uu/Default)
|
||||
TITLE+= (kernel module)
|
||||
DESCRIPTION+=\\\
|
||||
\\\
|
||||
This package contains the AODV kernel module.
|
||||
FILES:=$(PKG_BUILD_DIR)/lnx/kaodv.$(LINUX_KMOD_SUFFIX)
|
||||
SUBMENU:=Network Support
|
||||
AUTOLOAD:=$(call AutoLoad,80,$(shell cat ./files/aodv-uu.modules))
|
||||
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
|
||||
endef
|
||||
|
||||
ifeq ($(CONFIG_LINUX_2_6),y)
|
||||
define Build/Compile/linux26
|
||||
$(MAKE) -C $(LINUX_DIR) \
|
||||
ARCH="$(LINUX_KARCH)" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
PATCHLEVEL="$(LINUX_VERSION)" \
|
||||
KERNDIR="$(LINUX_DIR)" \
|
||||
SUBDIRS="$(PKG_BUILD_DIR)/lnx" \
|
||||
modules
|
||||
endef
|
||||
else
|
||||
# We assume 2.4 builds are only for brcm-2.4 yet
|
||||
define Build/Compile/linux24-brcm
|
||||
$(call Build/Compile/Default,\
|
||||
KERNEL_DIR="$(LINUX_DIR)" \
|
||||
KCC="$(TARGET_CC)" \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
kaodv-mips \
|
||||
)
|
||||
cp $(PKG_BUILD_DIR)/lnx/kaodv-mips.$(LINUX_KMOD_SUFFIX) $(PKG_BUILD_DIR)/lnx/kaodv.$(LINUX_KMOD_SUFFIX)
|
||||
endef
|
||||
endif
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/linux26)
|
||||
$(call Build/Compile/linux24-brcm)
|
||||
$(call Build/Compile/Default,\
|
||||
KERNEL_DIR="$(LINUX_DIR)" \
|
||||
KCC="$(TARGET_CC)" \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
aodvd \
|
||||
)
|
||||
endef
|
||||
|
||||
define Package/aodv-uu/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/aodvd $(1)/usr/sbin
|
||||
endef
|
||||
|
||||
define Package/kmod-aodv-uu/install
|
||||
$(INSTALL_DIR) $(1)/etc/modules.d
|
||||
$(INSTALL_DATA) ./files/aodv-uu.modules $(1)/etc/modules.d/80-aodv-uu
|
||||
$(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
|
||||
$(CP) $(PKG_BUILD_DIR)/lnx/kaodv.$(LINUX_KMOD_SUFFIX) $(1)/lib/modules/$(LINUX_VERSION)/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,aodv-uu))
|
||||
$(eval $(call KernelPackage,aodv-uu))
|
1
package/aodv-uu/files/aodv-uu.modules
Normal file
1
package/aodv-uu/files/aodv-uu.modules
Normal file
|
@ -0,0 +1 @@
|
|||
kaodv
|
62
package/aodv-uu/patches/001-normalize.patch
Normal file
62
package/aodv-uu/patches/001-normalize.patch
Normal file
|
@ -0,0 +1,62 @@
|
|||
diff -urN aodv-uu-0.9.1/lnx/Makefile aodv-uu-0.9.1.new/lnx/Makefile
|
||||
--- aodv-uu-0.9.1/lnx/Makefile 2005-03-17 22:37:59.000000000 +0100
|
||||
+++ aodv-uu-0.9.1.new/lnx/Makefile 2006-07-25 15:46:02.000000000 +0200
|
||||
@@ -30,7 +30,7 @@
|
||||
KCFLAGS=-Wall -Wno-strict-aliasing -O2 $(KDEFS) $(KINC) $(XDEFS)
|
||||
KCFLAGS_ARM=-Wall -O2 -D__KERNEL__ -DMODULE -nostdinc $(shell $(ARM_CC) -print-search-dirs | sed -ne 's/install: \(.*\)/-I \1include/gp') -I$(KERNEL_INC)
|
||||
KCFLAGS_MIPS=-Wall -mips2 -O2 -fno-pic -mno-abicalls -mlong-calls -G0 -msoft-float -D__KERNEL__ -DMODULE -nostdinc $(shell $(MIPS_CC) -print-search-dirs | sed -ne 's/install: \(.*\)/-I \1include/gp') -I$(KERNEL_INC) $(XDEFS)
|
||||
-
|
||||
+endif
|
||||
.PHONY: clean clean-2.4 clean-2.6 indent default
|
||||
|
||||
# Check for kernel version
|
||||
@@ -87,5 +87,3 @@
|
||||
|
||||
indent:
|
||||
indent -kr -i8 -ts8 -sob -l80 -ss -ncs *.c *.h
|
||||
-endif
|
||||
-
|
||||
diff -urN aodv-uu-0.9.1/Makefile aodv-uu-0.9.1.new/Makefile
|
||||
--- aodv-uu-0.9.1/Makefile 2006-07-25 15:03:49.000000000 +0200
|
||||
+++ aodv-uu-0.9.1.new/Makefile 2006-07-25 15:03:59.000000000 +0200
|
||||
@@ -87,7 +87,7 @@
|
||||
mips: aodvd-mips kaodv-mips
|
||||
|
||||
endian.h:
|
||||
- $(CC) $(CFLAGS) -o endian endian.c
|
||||
+ gcc -o endian endian.c
|
||||
./endian > endian.h
|
||||
|
||||
$(OBJS): %.o: %.c Makefile
|
||||
@@ -138,19 +138,18 @@
|
||||
@makedepend -Y./ -- $(DEFS) -- $(SRC) &>/dev/null
|
||||
@makedepend -a -Y./ -- $(KDEFS) kaodv.c &>/dev/null
|
||||
|
||||
-install: default
|
||||
- install -s -m 755 aodvd /usr/sbin/aodvd
|
||||
- @if [ ! -d /lib/modules/$(KERNEL)/aodv ]; then \
|
||||
- mkdir /lib/modules/$(KERNEL)/aodv; \
|
||||
- fi
|
||||
-
|
||||
- @echo "Installing kernel module in /lib/modules/$(KERNEL)/aodv/";
|
||||
- @if [ -f ./kaodv.ko ]; then \
|
||||
- install -m 644 kaodv.ko /lib/modules/$(KERNEL)/aodv/kaodv.ko; \
|
||||
- else \
|
||||
- install -m 644 kaodv.o /lib/modules/$(KERNEL)/aodv/kaodv.o; \
|
||||
- fi
|
||||
- /sbin/depmod -a
|
||||
+install: install-aodvd install-kaodv
|
||||
+
|
||||
+install-aodvd:
|
||||
+ @echo "Installing aodv in $(DESTDIR)/usr/sbin";
|
||||
+ install -d -m0755 $(DESTDIR)/usr/sbin/
|
||||
+ install -m0755 aodvd $(DESTDIR)/usr/sbin/aodvd
|
||||
+
|
||||
+install-kaodv:
|
||||
+ @echo "Installing kernel module in $(DESTDIR)/lib/modules/$(KERNEL)/";
|
||||
+ install -d -m0644 $(DESTDIR)/lib/modules/$(KERNEL)/
|
||||
+ install -m 644 lnx/kaodv.$(KMOD_SUFFIX) $(DESTDIR)/lib/modules/$(KERNEL)/kaodv.$(KMOD_SUFFIX);
|
||||
+
|
||||
uninstall:
|
||||
rm -f /usr/sbin/aodvd
|
||||
rm -rf /lib/modules/$(KERNEL)/aodv
|
|
@ -0,0 +1,47 @@
|
|||
diff -ruN aodv-uu-0.9.3-old/lnx/kaodv-mod.c aodv-uu-0.9.3-new/lnx/kaodv-mod.c
|
||||
--- aodv-uu-0.9.3-old/lnx/kaodv-mod.c 2006-09-20 19:58:38.000000000 +0200
|
||||
+++ aodv-uu-0.9.3-new/lnx/kaodv-mod.c 2006-12-16 22:08:01.000000000 +0100
|
||||
@@ -19,7 +19,7 @@
|
||||
* Author: Erik Nordström, <erik.nordstrom@it.uu.se>
|
||||
*
|
||||
*****************************************************************************/
|
||||
-#include <linux/config.h>
|
||||
+#include <linux/autoconf.h>
|
||||
#include <linux/version.h>
|
||||
|
||||
#ifdef KERNEL26
|
||||
@@ -258,7 +258,11 @@
|
||||
if (!(*skb))
|
||||
return NF_STOLEN;
|
||||
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
|
||||
+ ip_route_me_harder(skb, RTN_UNSPEC);
|
||||
+#else
|
||||
ip_route_me_harder(skb);
|
||||
+#endif
|
||||
}
|
||||
break;
|
||||
case NF_IP_POST_ROUTING:
|
||||
diff -ruN aodv-uu-0.9.3-old/lnx/kaodv-queue.c aodv-uu-0.9.3-new/lnx/kaodv-queue.c
|
||||
--- aodv-uu-0.9.3-old/lnx/kaodv-queue.c 2006-09-20 19:58:38.000000000 +0200
|
||||
+++ aodv-uu-0.9.3-new/lnx/kaodv-queue.c 2006-12-16 22:17:16.000000000 +0100
|
||||
@@ -29,6 +29,7 @@
|
||||
#include <linux/spinlock.h>
|
||||
#include <linux/sysctl.h>
|
||||
#include <linux/proc_fs.h>
|
||||
+#include <linux/version.h>
|
||||
#include <net/sock.h>
|
||||
#include <net/route.h>
|
||||
#include <net/icmp.h>
|
||||
@@ -246,7 +247,11 @@
|
||||
if (!entry->skb)
|
||||
goto next;
|
||||
}
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
|
||||
+ ip_route_me_harder(&entry->skb, RTN_UNSPEC);
|
||||
+#else
|
||||
ip_route_me_harder(&entry->skb);
|
||||
+#endif
|
||||
|
||||
pkts++;
|
||||
|
|
@ -0,0 +1,15 @@
|
|||
diff -ruN aodv-uu-0.9.3-old/lnx/kaodv-netlink.c aodv-uu-0.9.3-new/lnx/kaodv-netlink.c
|
||||
--- aodv-uu-0.9.3-old/lnx/kaodv-netlink.c 2006-09-20 19:58:38.000000000 +0200
|
||||
+++ aodv-uu-0.9.3-new/lnx/kaodv-netlink.c 2006-12-16 22:14:14.000000000 +0100
|
||||
@@ -284,7 +284,11 @@
|
||||
/* RCV_SKB_FAIL(-EINVAL); */
|
||||
|
||||
#ifdef KERNEL26
|
||||
+# if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
|
||||
+ if (security_netlink_recv(skb, CAP_NET_ADMIN))
|
||||
+# else
|
||||
if (security_netlink_recv(skb))
|
||||
+# endif
|
||||
RCV_SKB_FAIL(-EPERM);
|
||||
#endif
|
||||
//write_lock_bh(&queue_lock);
|
24
package/aodv-uu/patches/004-linux_2.6.19_includes.patch
Normal file
24
package/aodv-uu/patches/004-linux_2.6.19_includes.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- aodv-uu-0.9.3-old/main.c 2006-09-20 19:58:38.000000000 +0200
|
||||
+++ aodv-uu-0.9.3/main.c 2006-12-16 22:27:36.000000000 +0100
|
||||
@@ -26,6 +26,8 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <linux/types.h>
|
||||
+#include <linux/if.h>
|
||||
#include <linux/sockios.h>
|
||||
#include <linux/wireless.h>
|
||||
#include <getopt.h>
|
||||
--- aodv-uu-0.9.3-old/nl.c 2006-09-20 19:58:38.000000000 +0200
|
||||
+++ aodv-uu-0.9.3/nl.c 2006-12-16 22:29:55.000000000 +0100
|
||||
@@ -33,6 +33,10 @@
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <linux/rtnetlink.h>
|
||||
+#include <linux/version.h>
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
|
||||
+#include <linux/if_addr.h>
|
||||
+#endif
|
||||
|
||||
#include "defs.h"
|
||||
#include "lnx/kaodv-netlink.h"
|
Loading…
Reference in a new issue