tools/e2fsprogs: Update to 1.43.6
Update e2fsprogs to 1.43.6 * Remove FreeBSD patch as it's not needed, FreeBSD 9.1 is EoL and this is compiling on FreeBSD 11.1. * Remove libmagic patch, RHEL 5 is EoL (End of Production Phase) since March 31, 2017. Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
This commit is contained in:
parent
b0f26243fe
commit
ed617fd8f2
4 changed files with 2 additions and 39 deletions
|
@ -8,8 +8,8 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=e2fsprogs
|
PKG_NAME:=e2fsprogs
|
||||||
PKG_VERSION:=1.43.5
|
PKG_VERSION:=1.43.6
|
||||||
PKG_HASH:=261f3d9ade383fbf032a19140c9c25e998cc0f71a1ae686614fb3ae0eb955a17
|
PKG_HASH:=c9b226234ee878a8d89951f3b155cec7416dd0ec09c932c855f1b1df8ad93402
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
|
|
|
@ -1,12 +0,0 @@
|
||||||
--- a/lib/ext2fs/tdb.c
|
|
||||||
+++ b/lib/ext2fs/tdb.c
|
|
||||||
@@ -58,7 +58,9 @@ Last Changed Date: 2007-06-22 13:36:10 -
|
|
||||||
#include <utime.h>
|
|
||||||
#endif
|
|
||||||
#include <sys/stat.h>
|
|
||||||
+#ifndef __FreeBSD__
|
|
||||||
#include <sys/file.h>
|
|
||||||
+#endif
|
|
||||||
#include <fcntl.h>
|
|
||||||
|
|
||||||
#ifdef HAVE_SYS_MMAN_H
|
|
|
@ -1,25 +0,0 @@
|
||||||
From b482eb7af94885b6bbad9329e40702c958d5b448 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Hauke Mehrtens <hauke@hauke-m.de>
|
|
||||||
Date: Thu, 30 Jun 2016 19:53:03 +0200
|
|
||||||
Subject: [PATCH] fix build problem with very old libmagic
|
|
||||||
|
|
||||||
The libmagic shipped with RedHat 5 does not define
|
|
||||||
MAGIC_NO_CHECK_ELF and MAGIC_NO_CHECK_COMPRESS. e2fsprogs should
|
|
||||||
check for that otherwise the build will fail.
|
|
||||||
|
|
||||||
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
|
|
||||||
---
|
|
||||||
lib/support/plausible.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/lib/support/plausible.c
|
|
||||||
+++ b/lib/support/plausible.c
|
|
||||||
@@ -258,7 +258,7 @@ int check_plausibility(const char *devic
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
-#ifdef HAVE_MAGIC_H
|
|
||||||
+#if defined(HAVE_MAGIC_H) && defined(MAGIC_NO_CHECK_ELF) && defined(MAGIC_NO_CHECK_COMPRESS)
|
|
||||||
if ((flags & CHECK_FS_EXIST) &&
|
|
||||||
!getenv("E2FSPROGS_LIBMAGIC_SUPPRESS") &&
|
|
||||||
magic_library_available()) {
|
|
Loading…
Reference in a new issue