kernel: update linux 3.8-rcX to 3.8

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 35672
This commit is contained in:
Gabor Juhos 2013-02-19 09:17:38 +00:00
parent 48bc2fbff3
commit ed0f43f1e2
10 changed files with 15 additions and 11 deletions

View file

@ -11,6 +11,9 @@ endif
ifeq ($(LINUX_VERSION),3.7.9) ifeq ($(LINUX_VERSION),3.7.9)
LINUX_KERNEL_MD5SUM:=c19426374acfccfa7391fc90640240cb LINUX_KERNEL_MD5SUM:=c19426374acfccfa7391fc90640240cb
endif endif
ifeq ($(LINUX_VERSION),3.8)
LINUX_KERNEL_MD5SUM:=1c738edfc54e7c65faeb90c436104e2f
endif
# disable the md5sum check for unknown kernel versions # disable the md5sum check for unknown kernel versions
LINUX_KERNEL_MD5SUM?=x LINUX_KERNEL_MD5SUM?=x

View file

@ -2299,6 +2299,7 @@ CONFIG_PCI_SYSCALL=y
# CONFIG_PID_IN_CONTEXTIDR is not set # CONFIG_PID_IN_CONTEXTIDR is not set
# CONFIG_PID_NS is not set # CONFIG_PID_NS is not set
# CONFIG_PINCTRL is not set # CONFIG_PINCTRL is not set
# CONFIG_PINCTRL_EXYNOS is not set
# CONFIG_PINCTRL_EXYNOS5440 is not set # CONFIG_PINCTRL_EXYNOS5440 is not set
# CONFIG_PLAT_SPEAR is not set # CONFIG_PLAT_SPEAR is not set
# CONFIG_PLIP is not set # CONFIG_PLIP is not set

View file

@ -3175,7 +3175,7 @@
int flags, const char *name, int flags, const char *name,
--- a/MAINTAINERS --- a/MAINTAINERS
+++ b/MAINTAINERS +++ b/MAINTAINERS
@@ -5667,6 +5667,13 @@ F: drivers/scsi/osd/ @@ -5666,6 +5666,13 @@ F: drivers/scsi/osd/
F: include/scsi/osd_* F: include/scsi/osd_*
F: fs/exofs/ F: fs/exofs/

View file

@ -40,7 +40,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
mask = PORT_CSC | PORT_PEC | PORT_OCC; mask = PORT_CSC | PORT_PEC | PORT_OCC;
else else
mask = PORT_CSC | PORT_PEC; mask = PORT_CSC | PORT_PEC;
@@ -825,7 +825,7 @@ static int ehci_hub_control ( @@ -829,7 +829,7 @@ static int ehci_hub_control (
if (temp & PORT_PEC) if (temp & PORT_PEC)
status |= USB_PORT_STAT_C_ENABLE << 16; status |= USB_PORT_STAT_C_ENABLE << 16;

View file

@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk))) if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop; goto drop;
@@ -2537,6 +2539,7 @@ static int packet_create(struct net *net @@ -2539,6 +2541,7 @@ static int packet_create(struct net *net
spin_lock_init(&po->bind_lock); spin_lock_init(&po->bind_lock);
mutex_init(&po->pg_vec_lock); mutex_init(&po->pg_vec_lock);
po->prot_hook.func = packet_rcv; po->prot_hook.func = packet_rcv;
@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (sock->type == SOCK_PACKET) if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt; po->prot_hook.func = packet_rcv_spkt;
@@ -3150,6 +3153,16 @@ packet_setsockopt(struct socket *sock, i @@ -3152,6 +3155,16 @@ packet_setsockopt(struct socket *sock, i
po->tp_tx_has_off = !!val; po->tp_tx_has_off = !!val;
return 0; return 0;
} }
@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
default: default:
return -ENOPROTOOPT; return -ENOPROTOOPT;
} }
@@ -3204,6 +3217,13 @@ static int packet_getsockopt(struct sock @@ -3206,6 +3219,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR: case PACKET_VNET_HDR:
val = po->has_vnet_hdr; val = po->has_vnet_hdr;
break; break;

View file

@ -49,7 +49,7 @@
int ipv6_get_lladdr(struct net_device *dev, struct in6_addr *addr, int ipv6_get_lladdr(struct net_device *dev, struct in6_addr *addr,
unsigned char banned_flags) unsigned char banned_flags)
@@ -4946,6 +4945,9 @@ int __init addrconf_init(void) @@ -4947,6 +4946,9 @@ int __init addrconf_init(void)
ipv6_addr_label_rtnl_register(); ipv6_addr_label_rtnl_register();
@ -59,7 +59,7 @@
return 0; return 0;
errout: errout:
rtnl_af_unregister(&inet6_ops); rtnl_af_unregister(&inet6_ops);
@@ -4964,6 +4966,9 @@ void addrconf_cleanup(void) @@ -4965,6 +4967,9 @@ void addrconf_cleanup(void)
struct net_device *dev; struct net_device *dev;
int i; int i;

View file

@ -119,7 +119,7 @@
extern struct net_bridge_port *br_get_port(struct net_bridge *br, extern struct net_bridge_port *br_get_port(struct net_bridge *br,
--- a/net/bridge/br_stp_bpdu.c --- a/net/bridge/br_stp_bpdu.c
+++ b/net/bridge/br_stp_bpdu.c +++ b/net/bridge/br_stp_bpdu.c
@@ -52,7 +52,7 @@ static void br_send_bpdu(struct net_brid @@ -54,7 +54,7 @@ static void br_send_bpdu(struct net_brid
skb_reset_mac_header(skb); skb_reset_mac_header(skb);

View file

@ -39,7 +39,7 @@
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask) static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
{ {
u16 cmd; u16 cmd;
@@ -973,3 +988,4 @@ static void quirk_usb_early_handoff(stru @@ -974,3 +989,4 @@ static void quirk_usb_early_handoff(stru
} }
DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID, DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff); PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);

View file

@ -74,7 +74,7 @@
* @dev: device the buffer will be used with * @dev: device the buffer will be used with
--- a/include/linux/usb.h --- a/include/linux/usb.h
+++ b/include/linux/usb.h +++ b/include/linux/usb.h
@@ -675,6 +675,7 @@ static inline bool usb_device_supports_l @@ -677,6 +677,7 @@ static inline bool usb_device_supports_l
return udev->bos->ss_cap->bmAttributes & USB_LTM_SUPPORT; return udev->bos->ss_cap->bmAttributes & USB_LTM_SUPPORT;
} }

View file

@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
MAINTAINER:=Florian Fainelli <florian@openwrt.org> MAINTAINER:=Florian Fainelli <florian@openwrt.org>
LINUX_VERSION:=3.8-rc6 LINUX_VERSION:=3.8
include $(INCLUDE_DIR)/target.mk include $(INCLUDE_DIR)/target.mk