Update to 2.6.38
SVN-Revision: 26246
This commit is contained in:
parent
4c85b8562d
commit
eb4fc36bfe
3 changed files with 10 additions and 77 deletions
|
@ -14,7 +14,7 @@ FEATURES:=squashfs jffs2 targz
|
|||
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
|
||||
SUBTARGETS:=netus tqma9263
|
||||
|
||||
LINUX_VERSION:=2.6.35.11
|
||||
LINUX_VERSION:=2.6.38
|
||||
DEVICE_TYPE=
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
Index: linux-2.6.35.9/drivers/misc/Kconfig
|
||||
Index: linux-2.6.38/drivers/misc/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.35.9.orig/drivers/misc/Kconfig 2010-12-20 19:06:11.185139238 +0100
|
||||
+++ linux-2.6.35.9/drivers/misc/Kconfig 2010-12-20 19:07:31.000000000 +0100
|
||||
@@ -95,6 +95,10 @@
|
||||
--- linux-2.6.38.orig/drivers/misc/Kconfig 2011-03-15 02:20:32.000000000 +0100
|
||||
+++ linux-2.6.38/drivers/misc/Kconfig 2011-03-20 22:54:33.114794033 +0100
|
||||
@@ -104,6 +104,10 @@
|
||||
TC can be used for other purposes, such as PWM generation and
|
||||
interval timing.
|
||||
|
||||
|
@ -13,15 +13,16 @@ Index: linux-2.6.35.9/drivers/misc/Kconfig
|
|||
config IBM_ASM
|
||||
tristate "Device driver for IBM RSA service processor"
|
||||
depends on X86 && PCI && INPUT && EXPERIMENTAL
|
||||
Index: linux-2.6.35.9/drivers/misc/Makefile
|
||||
Index: linux-2.6.38/drivers/misc/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.35.9.orig/drivers/misc/Makefile 2010-12-20 19:04:59.494200153 +0100
|
||||
+++ linux-2.6.35.9/drivers/misc/Makefile 2010-12-20 19:06:04.000000000 +0100
|
||||
--- linux-2.6.38.orig/drivers/misc/Makefile 2011-03-15 02:20:32.000000000 +0100
|
||||
+++ linux-2.6.38/drivers/misc/Makefile 2011-03-20 22:55:18.000000000 +0100
|
||||
@@ -9,6 +9,7 @@
|
||||
obj-$(CONFIG_ATMEL_PWM) += atmel_pwm.o
|
||||
obj-$(CONFIG_ATMEL_SSC) += atmel-ssc.o
|
||||
obj-$(CONFIG_ATMEL_TCLIB) += atmel_tclib.o
|
||||
+obj-$(CONFIG_AT91_ADC) += at91-adc.o
|
||||
obj-$(CONFIG_BMP085) += bmp085.o
|
||||
obj-$(CONFIG_ICS932S401) += ics932s401.o
|
||||
obj-$(CONFIG_LKDTM) += lkdtm.o
|
||||
obj-$(CONFIG_TIFM_CORE) += tifm_core.o
|
||||
|
||||
|
|
|
@ -1,68 +0,0 @@
|
|||
--- a/arch/arm/mach-at91/Kconfig
|
||||
+++ b/arch/arm/mach-at91/Kconfig
|
||||
@@ -354,6 +354,13 @@ config MACH_CPU9G20
|
||||
Select this if you are using a Eukrea Electromatique's
|
||||
CPU9G20 Board <http://www.eukrea.com/>
|
||||
|
||||
+config MACH_NETUS_FOXBOARD
|
||||
+ bool "Acmesystems NetusG20 board"
|
||||
+ depends on ARCH_AT91SAM9G20
|
||||
+ help
|
||||
+ Select this if you are using a Acmesystems NetusG20
|
||||
+ board <http://netus.acmesystems.it/>
|
||||
+
|
||||
endif
|
||||
|
||||
# ----------------------------------------------------------
|
||||
@@ -444,6 +451,40 @@
|
||||
On AT91SAM926x boards both types of NAND flash can be present
|
||||
(8 and 16 bit data bus width).
|
||||
|
||||
+config NETUS_HEARTBEAT_LED
|
||||
+ bool "Use heartbeat trigger for led"
|
||||
+ depends on MACH_NETUS_FOXBOARD
|
||||
+ select LEDS_TRIGGER_HEARTBEAT
|
||||
+ help
|
||||
+ Select this option to enable default trigger heartbeart for
|
||||
+ FoxBoardG20 user led.
|
||||
+
|
||||
+config NETUS_SERIALS
|
||||
+ bool "Enable serials"
|
||||
+ depends on MACH_NETUS_FOXBOARD
|
||||
+ help
|
||||
+ Select this option to enable serials interface /dev/ttyS1,
|
||||
+ /dev/ttyS2 and /dev/ttyS5 (for oLed interface)
|
||||
+
|
||||
+config NETUS_USE_DATAFLASH
|
||||
+ bool "Enable the dataflash"
|
||||
+ select MTD_DATAFLASH
|
||||
+ select MTD_PARTITIONS
|
||||
+ select MTD_CMDLINE_PARTS
|
||||
+ select MTD_CHAR
|
||||
+ select MTD_BLOCK
|
||||
+ depends on MACH_NETUS_FOXBOARD
|
||||
+ help
|
||||
+ Select this option to use the dataflash.
|
||||
+
|
||||
+config NETUS_FOXGM
|
||||
+ bool "Enable support for FoxGM board"
|
||||
+ depends on MACH_NETUS_FOXBOARD
|
||||
+ select LEDS_TRIGGER_HEARTBEAT
|
||||
+ help
|
||||
+ Select this option to auto-configure leds and
|
||||
+ serial ports according to FOXGM board.
|
||||
+
|
||||
# ----------------------------------------------------------
|
||||
|
||||
comment "AT91 Feature Selections"
|
||||
--- linux-2.6.35.4.orig/arch/arm/mach-at91/Makefile 2010-09-18 13:29:33.000000000 +0200
|
||||
+++ linux-2.6.35.4/arch/arm/mach-at91/Makefile 2010-09-18 13:31:31.000000000 +0200
|
||||
@@ -65,6 +65,7 @@
|
||||
obj-$(CONFIG_MACH_CPU9G20) += board-cpu9krea.o
|
||||
obj-$(CONFIG_MACH_STAMP9G20) += board-stamp9g20.o
|
||||
obj-$(CONFIG_MACH_PORTUXG20) += board-stamp9g20.o
|
||||
+obj-$(CONFIG_MACH_NETUS_FOXBOARD) += board-netus-foxboard.o
|
||||
|
||||
# AT91SAM9G45 board-specific support
|
||||
obj-$(CONFIG_MACH_AT91SAM9G45EKES) += board-sam9m10g45ek.o
|
||||
|
Loading…
Reference in a new issue