bcm53xx: backport 3 BCM5301X patches from Hauke repo

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>

SVN-Revision: 44058
This commit is contained in:
Rafał Miłecki 2015-01-20 07:21:30 +00:00
parent 9758327d83
commit ea1fe45fae
16 changed files with 537 additions and 71 deletions

View file

@ -0,0 +1,97 @@
From 0da909663566b34e0294ab0ff1ea08908164811e Mon Sep 17 00:00:00 2001
From: Dan Haab <dhaab@luxul.com>
Date: Wed, 7 Jan 2015 14:34:50 -0700
Subject: [PATCH 52/54] ARM: BCM5301X: Add DT for Luxul XWC-1000
Luxul XWC-1000 is a controller device based on BCM4708 SoC. The only
unusual thing in its DTS file is "ubi" partition on NAND flash.
Signed-off-by: Dan Haab <dhaab@luxul.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
arch/arm/boot/dts/Makefile | 1 +
arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts | 60 ++++++++++++++++++++++++++++
2 files changed, 61 insertions(+)
create mode 100644 arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 91bd5bd..ff4a5ae 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -57,6 +57,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b-plus.dtb
dtb-$(CONFIG_ARCH_BCM_5301X) += \
bcm4708-buffalo-wzr-1750dhp.dtb \
+ bcm4708-luxul-xwc-1000.dtb \
bcm4708-netgear-r6250.dtb \
bcm4708-netgear-r6300-v2.dtb \
bcm47081-asus-rt-n18u.dtb \
diff --git a/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
new file mode 100644
index 0000000..946c728
--- /dev/null
+++ b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
@@ -0,0 +1,60 @@
+/*
+ * Broadcom BCM470X / BCM5301X ARM platform code.
+ * DTS for Luxul XWC-1000
+ *
+ * Copyright 2014 Luxul Inc.
+ *
+ * Licensed under the GNU/GPL. See COPYING for details.
+ */
+
+/dts-v1/;
+
+#include "bcm4708.dtsi"
+
+/ {
+ compatible = "luxul,xwc-1000", "brcm,bcm4708";
+ model = "Luxul XWC-1000 (BCM4708)";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ memory {
+ reg = <0x00000000 0x08000000>;
+ };
+
+ axi@18000000 {
+ nand@28000 {
+ reg = <0x00028000 0x1000>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "ubi";
+ reg = <0x00000000 0x08000000>;
+ };
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ status {
+ label = "bcm53xx:green:status";
+ gpios = <&chipcommon 0 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "timer";
+ };
+ };
+
+ gpio-keys {
+ compatible = "gpio-keys";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ restart {
+ label = "Reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
--
1.8.4.5

View file

@ -0,0 +1,84 @@
From b2c76541507c28fd93548c5639366d2149382b73 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
Date: Wed, 14 Jan 2015 08:20:48 +0100
Subject: [PATCH 53/54] ARM: BCM5301X: Drop unused poll-interval from gpio-keys
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
It was accidentally left (& copied & pasted all around) from our
experiments with gpio-keys-polled.
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts | 1 -
arch/arm/boot/dts/bcm4708-netgear-r6250.dts | 1 -
arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts | 1 -
arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts | 1 -
arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts | 1 -
5 files changed, 5 deletions(-)
diff --git a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
index 5fc0fae..13d51a9 100644
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -27,7 +27,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
restart {
label = "Reset";
diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
index 4ed7de1..f18c9d9 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -71,7 +71,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
wps {
label = "WPS";
diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
index 12fc2a01..3991042 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
@@ -61,7 +61,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
wps {
label = "WPS";
diff --git a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
index fb76378..0ee85ea 100644
--- a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
@@ -61,7 +61,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
restart {
label = "Reset";
diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
index bbb414f..e23dbbf 100644
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -27,7 +27,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
aoss {
label = "AOSS";
--
1.8.4.5

View file

@ -1,21 +1,24 @@
From af26d75225f8b1295d4dec74b9a6a703d582fa40 Mon Sep 17 00:00:00 2001
From 766f8b55ba3f38dffc25a7dc0dd58502fd710f0a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
Date: Thu, 11 Dec 2014 12:13:49 +0100
Subject: [PATCH] ARM: BCM5301X: Add LEDs for Buffalo devices
Date: Wed, 14 Jan 2015 08:20:49 +0100
Subject: [PATCH 54/54] ARM: BCM5301X: Add LEDs for Buffalo devices
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts | 67 ++++++++++++++++++++++
arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts | 67 ++++++++++++++++++++++
2 files changed, 134 insertions(+)
diff --git a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
index 13d51a9..b359c1e 100644
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -34,6 +34,73 @@
};
@@ -23,6 +23,73 @@
reg = <0x00000000 0x08000000>;
};
+ spi {
@ -86,12 +89,14 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ };
+
gpio-keys {
compatible = "gpio-keys-polled";
compatible = "gpio-keys";
#address-cells = <1>;
diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
index e23dbbf..db9131e 100644
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -34,6 +34,73 @@
};
@@ -23,6 +23,73 @@
reg = <0x00000000 0x08000000>;
};
+ spi {
@ -162,5 +167,8 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ };
+
gpio-keys {
compatible = "gpio-keys-polled";
compatible = "gpio-keys";
#address-cells = <1>;
--
1.8.4.5

View file

@ -26,7 +26,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ 0x88000000 0x18000000>;
};
gpio-keys {
spi {
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -20,7 +20,8 @@
@ -74,4 +74,4 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ 0x88000000 0x08000000>;
};
gpio-keys {
spi {

View file

@ -15,7 +15,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -55,7 +55,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
@@ -56,7 +56,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
bcm4708-netgear-r6250.dtb \
bcm4708-netgear-r6300-v2.dtb \
bcm47081-asus-rt-n18u.dtb \

View file

@ -62,7 +62,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+};
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -56,7 +56,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
@@ -57,7 +57,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
bcm4708-netgear-r6300-v2.dtb \
bcm47081-asus-rt-n18u.dtb \
bcm47081-buffalo-wzr-600dhp2.dtb \

View file

@ -19,7 +19,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -92,7 +92,7 @@
@@ -92,9 +92,10 @@
};
gpio-keys {
@ -27,10 +27,13 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
restart {
label = "Reset";
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -69,7 +69,7 @@
@@ -69,9 +69,10 @@
};
gpio-keys {
@ -38,10 +41,13 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
wps {
label = "WPS";
--- a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
@@ -59,7 +59,7 @@
@@ -59,9 +59,10 @@
};
gpio-keys {
@ -49,10 +55,13 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
wps {
label = "WPS";
--- a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
@@ -59,7 +59,7 @@
@@ -59,9 +59,10 @@
};
gpio-keys {
@ -60,10 +69,13 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
restart {
label = "Reset";
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -92,7 +92,7 @@
@@ -92,9 +92,10 @@
};
gpio-keys {
@ -71,4 +83,21 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
aoss {
label = "AOSS";
--- a/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
+++ b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
@@ -47,9 +47,10 @@
};
gpio-keys {
- compatible = "gpio-keys";
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
+ poll-interval = <200>;
restart {
label = "Reset";

View file

@ -73,8 +73,8 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -91,6 +91,16 @@
};
@@ -24,6 +24,16 @@
0x88000000 0x08000000>;
};
+ chipcommonA {
@ -87,6 +87,25 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ };
+ };
+
gpio-keys {
compatible = "gpio-keys-polled";
#address-cells = <1>;
spi {
compatible = "spi-gpio";
num-chipselects = <1>;
--- a/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
+++ b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
@@ -23,6 +23,16 @@
reg = <0x00000000 0x08000000>;
};
+ chipcommonA {
+ uart0: serial@0300 {
+ status = "okay";
+ };
+
+ uart1: serial@0400 {
+ status = "okay";
+ };
+ };
+
axi@18000000 {
nand@28000 {
reg = <0x00028000 0x1000>;

View file

@ -0,0 +1,97 @@
From 0da909663566b34e0294ab0ff1ea08908164811e Mon Sep 17 00:00:00 2001
From: Dan Haab <dhaab@luxul.com>
Date: Wed, 7 Jan 2015 14:34:50 -0700
Subject: [PATCH 52/54] ARM: BCM5301X: Add DT for Luxul XWC-1000
Luxul XWC-1000 is a controller device based on BCM4708 SoC. The only
unusual thing in its DTS file is "ubi" partition on NAND flash.
Signed-off-by: Dan Haab <dhaab@luxul.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
arch/arm/boot/dts/Makefile | 1 +
arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts | 60 ++++++++++++++++++++++++++++
2 files changed, 61 insertions(+)
create mode 100644 arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 91bd5bd..ff4a5ae 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -57,6 +57,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b-plus.dtb
dtb-$(CONFIG_ARCH_BCM_5301X) += \
bcm4708-buffalo-wzr-1750dhp.dtb \
+ bcm4708-luxul-xwc-1000.dtb \
bcm4708-netgear-r6250.dtb \
bcm4708-netgear-r6300-v2.dtb \
bcm47081-asus-rt-n18u.dtb \
diff --git a/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
new file mode 100644
index 0000000..946c728
--- /dev/null
+++ b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
@@ -0,0 +1,60 @@
+/*
+ * Broadcom BCM470X / BCM5301X ARM platform code.
+ * DTS for Luxul XWC-1000
+ *
+ * Copyright 2014 Luxul Inc.
+ *
+ * Licensed under the GNU/GPL. See COPYING for details.
+ */
+
+/dts-v1/;
+
+#include "bcm4708.dtsi"
+
+/ {
+ compatible = "luxul,xwc-1000", "brcm,bcm4708";
+ model = "Luxul XWC-1000 (BCM4708)";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ memory {
+ reg = <0x00000000 0x08000000>;
+ };
+
+ axi@18000000 {
+ nand@28000 {
+ reg = <0x00028000 0x1000>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "ubi";
+ reg = <0x00000000 0x08000000>;
+ };
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ status {
+ label = "bcm53xx:green:status";
+ gpios = <&chipcommon 0 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "timer";
+ };
+ };
+
+ gpio-keys {
+ compatible = "gpio-keys";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ restart {
+ label = "Reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
--
1.8.4.5

View file

@ -0,0 +1,84 @@
From b2c76541507c28fd93548c5639366d2149382b73 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
Date: Wed, 14 Jan 2015 08:20:48 +0100
Subject: [PATCH 53/54] ARM: BCM5301X: Drop unused poll-interval from gpio-keys
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
It was accidentally left (& copied & pasted all around) from our
experiments with gpio-keys-polled.
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts | 1 -
arch/arm/boot/dts/bcm4708-netgear-r6250.dts | 1 -
arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts | 1 -
arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts | 1 -
arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts | 1 -
5 files changed, 5 deletions(-)
diff --git a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
index 5fc0fae..13d51a9 100644
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -27,7 +27,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
restart {
label = "Reset";
diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
index 4ed7de1..f18c9d9 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -71,7 +71,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
wps {
label = "WPS";
diff --git a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
index 12fc2a01..3991042 100644
--- a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
@@ -61,7 +61,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
wps {
label = "WPS";
diff --git a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
index fb76378..0ee85ea 100644
--- a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
@@ -61,7 +61,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
restart {
label = "Reset";
diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
index bbb414f..e23dbbf 100644
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -27,7 +27,6 @@
compatible = "gpio-keys";
#address-cells = <1>;
#size-cells = <0>;
- poll-interval = <200>;
aoss {
label = "AOSS";
--
1.8.4.5

View file

@ -1,21 +1,24 @@
From af26d75225f8b1295d4dec74b9a6a703d582fa40 Mon Sep 17 00:00:00 2001
From 766f8b55ba3f38dffc25a7dc0dd58502fd710f0a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
Date: Thu, 11 Dec 2014 12:13:49 +0100
Subject: [PATCH] ARM: BCM5301X: Add LEDs for Buffalo devices
Date: Wed, 14 Jan 2015 08:20:49 +0100
Subject: [PATCH 54/54] ARM: BCM5301X: Add LEDs for Buffalo devices
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts | 67 ++++++++++++++++++++++
arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts | 67 ++++++++++++++++++++++
2 files changed, 134 insertions(+)
diff --git a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
index 13d51a9..b359c1e 100644
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -34,6 +34,73 @@
};
@@ -23,6 +23,73 @@
reg = <0x00000000 0x08000000>;
};
+ spi {
@ -86,12 +89,14 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ };
+
gpio-keys {
compatible = "gpio-keys-polled";
compatible = "gpio-keys";
#address-cells = <1>;
diff --git a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
index e23dbbf..db9131e 100644
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -34,6 +34,73 @@
};
@@ -23,6 +23,73 @@
reg = <0x00000000 0x08000000>;
};
+ spi {
@ -162,5 +167,8 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ };
+
gpio-keys {
compatible = "gpio-keys-polled";
compatible = "gpio-keys";
#address-cells = <1>;
--
1.8.4.5

View file

@ -26,7 +26,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ 0x88000000 0x18000000>;
};
gpio-keys {
spi {
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -20,7 +20,8 @@
@ -74,4 +74,4 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ 0x88000000 0x08000000>;
};
gpio-keys {
spi {

View file

@ -15,7 +15,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -59,7 +59,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
@@ -60,7 +60,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
bcm4708-netgear-r6250.dtb \
bcm4708-netgear-r6300-v2.dtb \
bcm47081-asus-rt-n18u.dtb \

View file

@ -13,11 +13,9 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
2 files changed, 46 insertions(+), 1 deletion(-)
create mode 100644 arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 0de664e..2db6459 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -62,7 +62,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
@@ -61,7 +61,8 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
bcm4708-netgear-r6300-v2.dtb \
bcm47081-asus-rt-n18u.dtb \
bcm47081-buffalo-wzr-600dhp2.dtb \
@ -25,11 +23,8 @@ index 0de664e..2db6459 100644
+ bcm47081-buffalo-wzr-900dhp.dtb \
+ bcm4709-asus-rt-ac87u.dtb
dtb-$(CONFIG_ARCH_BCM_63XX) += bcm963138dvt.dtb
dtb-$(CONFIG_ARCH_BCM_CYGNUS) += bcm911360_entphn.dtb \
bcm911360k.dtb \
diff --git a/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts b/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
new file mode 100644
index 0000000..c9e06e4
dtb-$(CONFIG_ARCH_BCM_MOBILE) += bcm28155-ap.dtb \
bcm21664-garnet.dtb
--- /dev/null
+++ b/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
@@ -0,0 +1,44 @@
@ -77,6 +72,3 @@ index 0000000..c9e06e4
+ };
+ };
+};
--
1.8.4.5

View file

@ -19,7 +19,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -92,7 +92,7 @@
@@ -92,9 +92,10 @@
};
gpio-keys {
@ -27,10 +27,13 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
restart {
label = "Reset";
--- a/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6250.dts
@@ -69,7 +69,7 @@
@@ -69,9 +69,10 @@
};
gpio-keys {
@ -38,10 +41,13 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
wps {
label = "WPS";
--- a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
@@ -59,7 +59,7 @@
@@ -59,9 +59,10 @@
};
gpio-keys {
@ -49,10 +55,13 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
wps {
label = "WPS";
--- a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
+++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
@@ -59,7 +59,7 @@
@@ -59,9 +59,10 @@
};
gpio-keys {
@ -60,10 +69,13 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
restart {
label = "Reset";
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -92,7 +92,7 @@
@@ -92,9 +92,10 @@
};
gpio-keys {
@ -71,4 +83,21 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <200>;
+ poll-interval = <200>;
aoss {
label = "AOSS";
--- a/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
+++ b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
@@ -47,9 +47,10 @@
};
gpio-keys {
- compatible = "gpio-keys";
+ compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
+ poll-interval = <200>;
restart {
label = "Reset";

View file

@ -16,8 +16,8 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
@@ -91,6 +91,16 @@
};
@@ -24,6 +24,16 @@
0x88000000 0x18000000>;
};
+ chipcommonA {
@ -30,9 +30,9 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ };
+ };
+
gpio-keys {
compatible = "gpio-keys-polled";
#address-cells = <1>;
spi {
compatible = "spi-gpio";
num-chipselects = <1>;
--- a/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
+++ b/arch/arm/boot/dts/bcm4708-netgear-r6300-v2.dts
@@ -24,6 +24,16 @@
@ -73,8 +73,8 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
--- a/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
+++ b/arch/arm/boot/dts/bcm47081-buffalo-wzr-600dhp2.dts
@@ -91,6 +91,16 @@
};
@@ -24,6 +24,16 @@
0x88000000 0x08000000>;
};
+ chipcommonA {
@ -87,6 +87,25 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
+ };
+ };
+
gpio-keys {
compatible = "gpio-keys-polled";
#address-cells = <1>;
spi {
compatible = "spi-gpio";
num-chipselects = <1>;
--- a/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
+++ b/arch/arm/boot/dts/bcm4708-luxul-xwc-1000.dts
@@ -23,6 +23,16 @@
reg = <0x00000000 0x08000000>;
};
+ chipcommonA {
+ uart0: serial@0300 {
+ status = "okay";
+ };
+
+ uart1: serial@0400 {
+ status = "okay";
+ };
+ };
+
axi@18000000 {
nand@28000 {
reg = <0x00028000 0x1000>;