sync lcd4linux with whiterussian
SVN-Revision: 3022
This commit is contained in:
parent
1a4f953582
commit
e9321ec04a
6 changed files with 30 additions and 123 deletions
|
@ -3,11 +3,11 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lcd4linux
|
||||
PKG_VERSION:=0.10.0-RC1
|
||||
PKG_VERSION:=0.10.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=bab64ac01ebdce7e46ab367351af839f
|
||||
PKG_MD5SUM:=b7fb1c24b940482cd730cf212d1b5062
|
||||
|
||||
PKG_SOURCE_URL:=@SF/lcd4linux/
|
||||
PKG_SOURCE_URL:=@SF/lcd4linux
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
|
|
12
openwrt/package/lcd4linux/patches/110-ucdelay.patch
Normal file
12
openwrt/package/lcd4linux/patches/110-ucdelay.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -urN lcd4linux.old/udelay.h lcd4linux.dev/udelay.h
|
||||
--- lcd4linux.old/udelay.h 2005-05-08 06:32:45.000000000 +0200
|
||||
+++ lcd4linux.dev/udelay.h 2006-01-20 03:50:36.806897500 +0100
|
||||
@@ -76,7 +76,7 @@
|
||||
/* REP NOP (PAUSE) is a good thing to insert into busy-wait loops. */
|
||||
static inline void rep_nop(void)
|
||||
{
|
||||
- __asm__ __volatile__("rep; nop");
|
||||
+ __asm__ __volatile__("nop");
|
||||
}
|
||||
|
||||
|
|
@ -0,0 +1,15 @@
|
|||
diff -urN lcd4linux.old/drv_generic_parport.c lcd4linux.dev/drv_generic_parport.c
|
||||
--- lcd4linux.old/drv_generic_parport.c 2006-01-20 03:52:18.426419500 +0100
|
||||
+++ lcd4linux.dev/drv_generic_parport.c 2006-01-20 03:57:59.205263500 +0100
|
||||
@@ -134,6 +134,11 @@
|
||||
#define PARPORT_STATUS_BUSY 0x80
|
||||
#endif
|
||||
|
||||
+#ifndef WITH_OUTB
|
||||
+#define inb(foo) 0
|
||||
+#define outb(foo,bar) 0
|
||||
+#endif
|
||||
+
|
||||
#if !defined(WITH_OUTB) && !defined(WITH_PPDEV)
|
||||
#error neither outb() nor ppdev() possible
|
||||
#error cannot compile parallel port driver
|
|
@ -1,109 +0,0 @@
|
|||
--- lcd4linux-0.10.0-RC1/drv_generic_parport.c 2005-01-06 17:54:54.000000000 +0100
|
||||
+++ lcd/drv_generic_parport.c 2005-03-20 01:20:48.052255953 +0100
|
||||
@@ -359,13 +359,12 @@
|
||||
#ifdef WITH_PPDEV
|
||||
if (PPdev) {
|
||||
ioctl (PPfd, PPDATADIR, &direction);
|
||||
- } else
|
||||
+ }
|
||||
+#else
|
||||
+ /* code stolen from linux/parport_pc.h */
|
||||
+ ctr = (ctr & ~0x20) ^ (direction?0x20:0x00);
|
||||
+ outb (ctr, Port+2);
|
||||
#endif
|
||||
- {
|
||||
- /* code stolen from linux/parport_pc.h */
|
||||
- ctr = (ctr & ~0x20) ^ (direction?0x20:0x00);
|
||||
- outb (ctr, Port+2);
|
||||
- }
|
||||
}
|
||||
|
||||
|
||||
@@ -383,11 +382,10 @@
|
||||
#ifdef WITH_PPDEV
|
||||
if (PPdev) {
|
||||
ioctl (PPfd, PPRSTATUS, &data);
|
||||
- } else
|
||||
+ }
|
||||
+#else
|
||||
+ data = inb (Port+1);
|
||||
#endif
|
||||
- {
|
||||
- data = inb (Port+1);
|
||||
- }
|
||||
|
||||
/* clear unused bits */
|
||||
data &= mask;
|
||||
@@ -413,13 +411,12 @@
|
||||
frob.mask=mask;
|
||||
frob.val=val;
|
||||
ioctl (PPfd, PPFCONTROL, &frob);
|
||||
- } else
|
||||
+ }
|
||||
+#else
|
||||
+ /* code stolen from linux/parport_pc.h */
|
||||
+ ctr = (ctr & ~mask) ^ val;
|
||||
+ outb (ctr, Port+2);
|
||||
#endif
|
||||
- {
|
||||
- /* code stolen from linux/parport_pc.h */
|
||||
- ctr = (ctr & ~mask) ^ val;
|
||||
- outb (ctr, Port+2);
|
||||
- }
|
||||
}
|
||||
|
||||
|
||||
@@ -456,9 +453,9 @@
|
||||
frob.val = value2;
|
||||
ioctl (PPfd, PPFCONTROL, &frob);
|
||||
|
||||
- } else
|
||||
-#endif
|
||||
- {
|
||||
+ }
|
||||
+#else
|
||||
+
|
||||
/* rise */
|
||||
ctr = (ctr & ~bits) ^ value1;
|
||||
outb (ctr, Port+2);
|
||||
@@ -469,7 +466,8 @@
|
||||
/* lower */
|
||||
ctr = (ctr & ~bits) ^ value2;
|
||||
outb (ctr, Port+2);
|
||||
- }
|
||||
+
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
||||
@@ -478,11 +476,11 @@
|
||||
#ifdef WITH_PPDEV
|
||||
if (PPdev) {
|
||||
ioctl(PPfd, PPWDATA, &data);
|
||||
- } else
|
||||
+ }
|
||||
+#else
|
||||
+ outb (data, Port);
|
||||
#endif
|
||||
- {
|
||||
- outb (data, Port);
|
||||
- }
|
||||
+
|
||||
}
|
||||
|
||||
unsigned char drv_generic_parport_read (void)
|
||||
@@ -492,11 +490,10 @@
|
||||
#ifdef WITH_PPDEV
|
||||
if (PPdev) {
|
||||
ioctl (PPfd, PPRDATA, &data);
|
||||
- } else
|
||||
+ }
|
||||
+#else
|
||||
+ data=inb (Port);
|
||||
#endif
|
||||
- {
|
||||
- data=inb (Port);
|
||||
- }
|
||||
return data;
|
||||
}
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- lcd4linux-0.10.0-RC1/udelay.h 2004-06-26 14:05:00.000000000 +0200
|
||||
+++ lcd-patched/udelay.h 2005-03-19 15:00:54.835892666 +0100
|
||||
@@ -69,7 +69,7 @@
|
||||
/* REP NOP (PAUSE) is a good thing to insert into busy-wait loops. */
|
||||
static inline void rep_nop (void)
|
||||
{
|
||||
- __asm__ __volatile__("rep; nop");
|
||||
+ __asm__ __volatile__("nop");
|
||||
}
|
||||
|
||||
|
Loading…
Reference in a new issue