Add an MTX-1 specific patch to avoid functions redefinition at compile-time. Build a full target
SVN-Revision: 3616
This commit is contained in:
parent
befba55ee3
commit
e8e55bc436
2 changed files with 62 additions and 0 deletions
|
@ -0,0 +1,26 @@
|
||||||
|
--- linux-2.6.16.2/drivers/usb/host/ohci-pci.c 2006-04-07 18:56:47.000000000 +0200
|
||||||
|
+++ linux-2.6.16.2.new/drivers/usb/host/ohci-pci.c 2006-04-11 14:20:33.000000000 +0200
|
||||||
|
@@ -215,7 +215,7 @@
|
||||||
|
#endif
|
||||||
|
};
|
||||||
|
|
||||||
|
-
|
||||||
|
+/*
|
||||||
|
static int __init ohci_hcd_pci_init (void)
|
||||||
|
{
|
||||||
|
printk (KERN_DEBUG "%s: " DRIVER_INFO " (PCI)\n", hcd_name);
|
||||||
|
@@ -227,11 +227,12 @@
|
||||||
|
return pci_register_driver (&ohci_pci_driver);
|
||||||
|
}
|
||||||
|
module_init (ohci_hcd_pci_init);
|
||||||
|
-
|
||||||
|
+*/
|
||||||
|
/*-------------------------------------------------------------------------*/
|
||||||
|
-
|
||||||
|
+/*
|
||||||
|
static void __exit ohci_hcd_pci_cleanup (void)
|
||||||
|
{
|
||||||
|
pci_unregister_driver (&ohci_pci_driver);
|
||||||
|
}
|
||||||
|
module_exit (ohci_hcd_pci_cleanup);
|
||||||
|
+*/
|
36
openwrt/target/linux/image/au1000/Makefile
Normal file
36
openwrt/target/linux/image/au1000/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
|
||||||
|
|
||||||
|
|
||||||
|
ifeq ($(FS),jffs2-8MB)
|
||||||
|
|
||||||
|
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img: $(KDIR)/root.$(FS)
|
||||||
|
$(CP) $^ $@
|
||||||
|
|
||||||
|
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
|
||||||
|
|
||||||
|
endif
|
||||||
|
|
||||||
|
|
||||||
|
ifeq ($(FS),tgz)
|
||||||
|
|
||||||
|
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/root.tar.gz
|
||||||
|
$(CP) $^ $@
|
||||||
|
|
||||||
|
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
|
||||||
|
|
||||||
|
endif
|
||||||
|
|
||||||
|
|
||||||
|
$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/vmlinux
|
||||||
|
$(CP) $^ $@
|
||||||
|
|
||||||
|
|
||||||
|
clean:
|
||||||
|
prepare:
|
||||||
|
compile:
|
||||||
|
install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
|
||||||
|
install-ib:
|
||||||
|
mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
|
||||||
|
$(CP) $(KDIR)/bzImage $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/
|
Loading…
Reference in a new issue