broadcom-wl: fix build after IRQF_SAMPLE_RANDOM flag removal (#12248)
SVN-Revision: 33617
This commit is contained in:
parent
c034fc2f40
commit
e5ca54aee9
2 changed files with 12 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
|
|||
|
||||
PKG_NAME:=broadcom-wl
|
||||
PKG_VERSION:=5.10.56.27.3
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
|
||||
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- a/driver/wl_linux.c 2012-09-26 20:51:48.099454971 -0400
|
||||
+++ b/driver/wl_linux.c 2012-09-26 20:53:24.115453441 -0400
|
||||
@@ -691,7 +691,7 @@
|
||||
if (wl->bustype != JTAG_BUS)
|
||||
#endif /* BCMJTAG */
|
||||
{
|
||||
- if (request_irq(irq, wl_isr, IRQF_SHARED|IRQF_SAMPLE_RANDOM, dev->name, wl)) {
|
||||
+ if (request_irq(irq, wl_isr, IRQF_SHARED, dev->name, wl)) {
|
||||
WL_ERROR(("wl%d: request_irq() failed\n", unit));
|
||||
goto fail;
|
||||
}
|
Loading…
Reference in a new issue