kernel: update to kernel 3.9.10 and refresh patches
SVN-Revision: 37274
This commit is contained in:
parent
9b9c6facfc
commit
e574f75d16
8 changed files with 31 additions and 28 deletions
|
@ -14,8 +14,8 @@ endif
|
||||||
ifeq ($(LINUX_VERSION),3.8.13)
|
ifeq ($(LINUX_VERSION),3.8.13)
|
||||||
LINUX_KERNEL_MD5SUM:=2af19d06cd47ec459519159cdd10542d
|
LINUX_KERNEL_MD5SUM:=2af19d06cd47ec459519159cdd10542d
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.9.8)
|
ifeq ($(LINUX_VERSION),3.9.10)
|
||||||
LINUX_KERNEL_MD5SUM:=04d74575ef1c484ad00be61f32bb4557
|
LINUX_KERNEL_MD5SUM:=2d69615f7074b952cfcb65f1356c0cc9
|
||||||
endif
|
endif
|
||||||
ifeq ($(LINUX_VERSION),3.10)
|
ifeq ($(LINUX_VERSION),3.10)
|
||||||
LINUX_KERNEL_MD5SUM:=4f25cd5bec5f8d5a7d935b3f2ccb8481
|
LINUX_KERNEL_MD5SUM:=4f25cd5bec5f8d5a7d935b3f2ccb8481
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs atm
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
SUBTARGETS:=generic ac49x
|
SUBTARGETS:=generic ac49x
|
||||||
|
|
||||||
LINUX_VERSION:=3.9.8
|
LINUX_VERSION:=3.9.10
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=brcm63xx
|
||||||
BOARDNAME:=Broadcom BCM63xx
|
BOARDNAME:=Broadcom BCM63xx
|
||||||
SUBTARGETS:=generic smp
|
SUBTARGETS:=generic smp
|
||||||
FEATURES:=squashfs usb atm pci pcmcia
|
FEATURES:=squashfs usb atm pci pcmcia
|
||||||
LINUX_VERSION:=3.9.8
|
LINUX_VERSION:=3.9.10
|
||||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs pci
|
||||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
|
||||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||||
|
|
||||||
LINUX_VERSION:=3.9.8
|
LINUX_VERSION:=3.9.10
|
||||||
|
|
||||||
KERNELNAME:="zImage"
|
KERNELNAME:="zImage"
|
||||||
|
|
||||||
|
|
|
@ -78,7 +78,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||||
#ifdef MODULE
|
#ifdef MODULE
|
||||||
#define __MODULE_INFO(tag, name, info) \
|
#define __MODULE_INFO(tag, name, info) \
|
||||||
static const char __UNIQUE_ID(name)[] \
|
static const char __UNIQUE_ID(name)[] \
|
||||||
@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
|
@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
|
||||||
= __stringify(tag) "=" info
|
= __stringify(tag) "=" info
|
||||||
#else /* !MODULE */
|
#else /* !MODULE */
|
||||||
/* This struct is here for syntactic coherency, it is not used */
|
/* This struct is here for syntactic coherency, it is not used */
|
||||||
|
@ -88,7 +88,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
|
||||||
#endif
|
#endif
|
||||||
#define __MODULE_PARM_TYPE(name, _type) \
|
#define __MODULE_PARM_TYPE(name, _type) \
|
||||||
__MODULE_INFO(parmtype, name##type, #name ":" _type)
|
__MODULE_INFO(parmtype, name##type, #name ":" _type)
|
||||||
@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
|
@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
|
||||||
/* One for each parameter, describing how to use it. Some files do
|
/* One for each parameter, describing how to use it. Some files do
|
||||||
multiple of these per line, so can't just use MODULE_INFO. */
|
multiple of these per line, so can't just use MODULE_INFO. */
|
||||||
#define MODULE_PARM_DESC(_parm, desc) \
|
#define MODULE_PARM_DESC(_parm, desc) \
|
||||||
|
|
|
@ -17,7 +17,7 @@
|
||||||
tristate "Userspace cryptographic algorithm configuration"
|
tristate "Userspace cryptographic algorithm configuration"
|
||||||
--- a/crypto/algboss.c
|
--- a/crypto/algboss.c
|
||||||
+++ b/crypto/algboss.c
|
+++ b/crypto/algboss.c
|
||||||
@@ -247,6 +247,9 @@ static int cryptomgr_schedule_test(struc
|
@@ -248,6 +248,9 @@ static int cryptomgr_schedule_test(struc
|
||||||
type = alg->cra_flags;
|
type = alg->cra_flags;
|
||||||
|
|
||||||
/* This piece of crap needs to disappear into per-type test hooks. */
|
/* This piece of crap needs to disappear into per-type test hooks. */
|
||||||
|
@ -27,7 +27,7 @@
|
||||||
if ((!((type ^ CRYPTO_ALG_TYPE_BLKCIPHER) &
|
if ((!((type ^ CRYPTO_ALG_TYPE_BLKCIPHER) &
|
||||||
CRYPTO_ALG_TYPE_BLKCIPHER_MASK) && !(type & CRYPTO_ALG_GENIV) &&
|
CRYPTO_ALG_TYPE_BLKCIPHER_MASK) && !(type & CRYPTO_ALG_GENIV) &&
|
||||||
((alg->cra_flags & CRYPTO_ALG_TYPE_MASK) ==
|
((alg->cra_flags & CRYPTO_ALG_TYPE_MASK) ==
|
||||||
@@ -255,6 +258,7 @@ static int cryptomgr_schedule_test(struc
|
@@ -256,6 +259,7 @@ static int cryptomgr_schedule_test(struc
|
||||||
(!((type ^ CRYPTO_ALG_TYPE_AEAD) & CRYPTO_ALG_TYPE_MASK) &&
|
(!((type ^ CRYPTO_ALG_TYPE_AEAD) & CRYPTO_ALG_TYPE_MASK) &&
|
||||||
alg->cra_type == &crypto_nivaead_type && alg->cra_aead.ivsize))
|
alg->cra_type == &crypto_nivaead_type && alg->cra_aead.ivsize))
|
||||||
type |= CRYPTO_ALG_TESTED;
|
type |= CRYPTO_ALG_TESTED;
|
||||||
|
|
|
@ -124,7 +124,7 @@
|
||||||
/* LzmaDecode
|
/* LzmaDecode
|
||||||
--- a/lib/lzma/LzmaDec.c
|
--- a/lib/lzma/LzmaDec.c
|
||||||
+++ b/lib/lzma/LzmaDec.c
|
+++ b/lib/lzma/LzmaDec.c
|
||||||
@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
|
@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
|
||||||
p->needFlush = 0;
|
p->needFlush = 0;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -219,26 +219,26 @@
|
||||||
{
|
{
|
||||||
UInt32 dicSize;
|
UInt32 dicSize;
|
||||||
Byte d;
|
Byte d;
|
||||||
@@ -935,33 +883,11 @@ static SRes LzmaDec_AllocateProbs2(CLzma
|
@@ -935,7 +883,7 @@ static SRes LzmaDec_AllocateProbs2(CLzma
|
||||||
return SZ_OK;
|
return SZ_OK;
|
||||||
}
|
}
|
||||||
|
|
||||||
-SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
-SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||||
-{
|
|
||||||
- CLzmaProps propNew;
|
|
||||||
- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
|
||||||
- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
|
|
||||||
- p->prop = propNew;
|
|
||||||
- return SZ_OK;
|
|
||||||
-}
|
|
||||||
-
|
|
||||||
-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
|
||||||
+static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
+static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||||
{
|
{
|
||||||
CLzmaProps propNew;
|
CLzmaProps propNew;
|
||||||
- SizeT dicBufSize;
|
|
||||||
RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
||||||
RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
|
@@ -943,28 +891,6 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
|
||||||
|
p->prop = propNew;
|
||||||
|
return SZ_OK;
|
||||||
|
}
|
||||||
|
-
|
||||||
|
-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
|
||||||
|
-{
|
||||||
|
- CLzmaProps propNew;
|
||||||
|
- SizeT dicBufSize;
|
||||||
|
- RINOK(LzmaProps_Decode(&propNew, props, propsSize));
|
||||||
|
- RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
|
||||||
- dicBufSize = propNew.dicSize;
|
- dicBufSize = propNew.dicSize;
|
||||||
- if (p->dic == 0 || dicBufSize != p->dicBufSize)
|
- if (p->dic == 0 || dicBufSize != p->dicBufSize)
|
||||||
- {
|
- {
|
||||||
|
@ -251,9 +251,12 @@
|
||||||
- }
|
- }
|
||||||
- }
|
- }
|
||||||
- p->dicBufSize = dicBufSize;
|
- p->dicBufSize = dicBufSize;
|
||||||
p->prop = propNew;
|
- p->prop = propNew;
|
||||||
return SZ_OK;
|
- return SZ_OK;
|
||||||
}
|
-}
|
||||||
|
|
||||||
|
SRes LzmaDecode(Byte *dest, SizeT *destLen, const Byte *src, SizeT *srcLen,
|
||||||
|
const Byte *propData, unsigned propSize, ELzmaFinishMode finishMode,
|
||||||
--- a/include/linux/lzma/LzmaEnc.h
|
--- a/include/linux/lzma/LzmaEnc.h
|
||||||
+++ b/include/linux/lzma/LzmaEnc.h
|
+++ b/include/linux/lzma/LzmaEnc.h
|
||||||
@@ -31,9 +31,6 @@ typedef struct _CLzmaEncProps
|
@@ -31,9 +31,6 @@ typedef struct _CLzmaEncProps
|
||||||
|
@ -597,7 +600,7 @@
|
||||||
void MatchFinder_Construct(CMatchFinder *p);
|
void MatchFinder_Construct(CMatchFinder *p);
|
||||||
|
|
||||||
/* Conditions:
|
/* Conditions:
|
||||||
@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
|
@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
|
||||||
UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
|
UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
|
||||||
ISzAlloc *alloc);
|
ISzAlloc *alloc);
|
||||||
void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
|
void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
|
||||||
|
@ -686,7 +689,7 @@
|
||||||
{
|
{
|
||||||
memmove(p->bufferBase,
|
memmove(p->bufferBase,
|
||||||
p->buffer - p->keepSizeBefore,
|
p->buffer - p->keepSizeBefore,
|
||||||
@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
|
@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
|
||||||
p->buffer = p->bufferBase + p->keepSizeBefore;
|
p->buffer = p->bufferBase + p->keepSizeBefore;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883 mt7620a
|
||||||
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
|
CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
|
||||||
FEATURES:=squashfs gpio
|
FEATURES:=squashfs gpio
|
||||||
|
|
||||||
LINUX_VERSION:=3.9.8
|
LINUX_VERSION:=3.9.10
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
DEFAULT_PACKAGES+=\
|
DEFAULT_PACKAGES+=\
|
||||||
|
|
Loading…
Reference in a new issue