mtd: fix compile warnings
This callback should have one parameter less, this parameter is not used so this was not a so big problem. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
5d3fbd5996
commit
e273860351
2 changed files with 4 additions and 4 deletions
|
@ -1,6 +1,6 @@
|
|||
--- a/include/common.h
|
||||
+++ b/include/common.h
|
||||
@@ -137,10 +137,12 @@ static inline bool prompt(const char *ms
|
||||
@@ -152,10 +152,12 @@ static inline bool prompt(const char *ms
|
||||
}
|
||||
|
||||
if (strcmp("\n", line) != 0) {
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
+++ b/Makefile
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
VERSION = 1.5.1
|
||||
VERSION = 1.5.2
|
||||
|
||||
-CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS)
|
||||
+CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS) -I./include/linux/lzma
|
||||
|
@ -122,7 +122,7 @@
|
|||
+}
|
||||
+
|
||||
+STATIC int jffs2_lzma_compress(unsigned char *data_in, unsigned char *cpage_out,
|
||||
+ uint32_t *sourcelen, uint32_t *dstlen, void *model)
|
||||
+ uint32_t *sourcelen, uint32_t *dstlen)
|
||||
+{
|
||||
+ SizeT compress_size = (SizeT)(*dstlen);
|
||||
+ int ret;
|
||||
|
@ -147,7 +147,7 @@
|
|||
+}
|
||||
+
|
||||
+STATIC int jffs2_lzma_decompress(unsigned char *data_in, unsigned char *cpage_out,
|
||||
+ uint32_t srclen, uint32_t destlen, void *model)
|
||||
+ uint32_t srclen, uint32_t destlen)
|
||||
+{
|
||||
+ int ret;
|
||||
+ SizeT dl = (SizeT)destlen;
|
||||
|
|
Loading…
Reference in a new issue