lantiq: fix 0008-MIPS-lantiq-backport-old-timer-code.patch for Amazon-SE
The patch 0008 removes the vanilla kernel gptu.c of lantiq. But the replacement file timer.c does not work Amazon-SE and is also protected therefore with an CONFIG_SOC_AMAZON_SE :-) This commit will re-activate the default vanilla kernel code in gptu.c for Amazon-SE. Signed-off-by: Tino Reichardt <milky-lede@mcmilk.de> [refresh patches and add same change for kernel 4.9] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
5ca2033d33
commit
e097eb27af
4 changed files with 18 additions and 6 deletions
|
@ -172,9 +172,15 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
|
||||
--- a/arch/mips/lantiq/xway/Makefile
|
||||
+++ b/arch/mips/lantiq/xway/Makefile
|
||||
@@ -1,4 +1,4 @@
|
||||
@@ -1,4 +1,10 @@
|
||||
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
|
||||
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
|
||||
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o dcdc.o
|
||||
+
|
||||
+ifdef CONFIG_SOC_AMAZON_SE
|
||||
+obj-y += gptu.o
|
||||
+else
|
||||
+obj-y += timer.o
|
||||
+endif
|
||||
|
||||
obj-y += vmmc.o
|
||||
|
||||
|
|
|
@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
#endif /* _LTQ_XWAY_H__ */
|
||||
--- a/arch/mips/lantiq/xway/Makefile
|
||||
+++ b/arch/mips/lantiq/xway/Makefile
|
||||
@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
|
||||
@@ -8,4 +8,7 @@ endif
|
||||
|
||||
obj-y += vmmc.o
|
||||
|
||||
|
|
|
@ -172,9 +172,15 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
|
||||
--- a/arch/mips/lantiq/xway/Makefile
|
||||
+++ b/arch/mips/lantiq/xway/Makefile
|
||||
@@ -1,4 +1,4 @@
|
||||
@@ -1,4 +1,10 @@
|
||||
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
|
||||
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
|
||||
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o dcdc.o
|
||||
+
|
||||
+ifdef CONFIG_SOC_AMAZON_SE
|
||||
+obj-y += gptu.o
|
||||
+else
|
||||
+obj-y += timer.o
|
||||
+endif
|
||||
|
||||
obj-y += vmmc.o
|
||||
|
||||
|
|
|
@ -27,7 +27,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
#endif /* _LTQ_XWAY_H__ */
|
||||
--- a/arch/mips/lantiq/xway/Makefile
|
||||
+++ b/arch/mips/lantiq/xway/Makefile
|
||||
@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
|
||||
@@ -8,4 +8,7 @@ endif
|
||||
|
||||
obj-y += vmmc.o
|
||||
|
||||
|
|
Loading…
Reference in a new issue