Update ipset to version 3.2
SVN-Revision: 17764
This commit is contained in:
parent
6b575bcb0e
commit
e014faf13f
10 changed files with 17578 additions and 17195 deletions
|
@ -203,11 +203,14 @@ $(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET, $(P_V4)ip_set))
|
|||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPHASH, $(P_V4)ip_set_iphash))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPMAP, $(P_V4)ip_set_ipmap))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPPORTHASH, $(P_V4)ip_set_ipporthash))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPPORTIPHASH, $(P_V4)ip_set_ipportiphash))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPPORTNETHASH, $(P_V4)ip_set_ipportnethash))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPTREE, $(P_V4)ip_set_iptree))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_IPTREEMAP, $(P_V4)ip_set_iptreemap))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_MACIPMAP, $(P_V4)ip_set_macipmap))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_NETHASH, $(P_V4)ip_set_nethash))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_PORTMAP, $(P_V4)ip_set_portmap))
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_SET_SETLIST, $(P_V4)ip_set_setlist))
|
||||
|
||||
$(eval $(call nf_add,IPT_IPSET,CONFIG_IP_NF_MATCH_SET, $(P_V4)ipt_set))
|
||||
|
||||
|
|
|
@ -6,14 +6,15 @@
|
|||
#
|
||||
#
|
||||
include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=ipset
|
||||
PKG_VERSION:=2.3.0
|
||||
PKG_VERSION:=3.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-20070828.tar.bz2
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://ipset.netfilter.org
|
||||
PKG_MD5SUM:=9e17798dfd8ed87c63a1f3498f9fe64d
|
||||
PKG_MD5SUM:=0fd83af3efae5f72f5e5b55d07582941
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -28,8 +29,11 @@ endef
|
|||
define Build/Compile
|
||||
$(call Build/Compile/Default, \
|
||||
COPT_FLAGS="$(TARGET_CFLAGS)" \
|
||||
LDFLAGS="-rdynamic -static-libgcc" \
|
||||
KERNEL_DIR="$(LINUX_DIR)" \
|
||||
PREFIX="/usr" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
binaries \
|
||||
)
|
||||
endef
|
||||
|
||||
|
@ -37,7 +41,7 @@ define Package/ipset/install
|
|||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(1)" \
|
||||
PREFIX="/usr" \
|
||||
install
|
||||
binaries_install
|
||||
rm -rf $(1)/usr/man
|
||||
endef
|
||||
|
||||
|
|
|
@ -316,11 +316,14 @@ define KernelPackage/ipt-ipset/description
|
|||
- ip_set_iphash
|
||||
- ip_set_ipmap
|
||||
- ip_set_ipporthash
|
||||
- ip_set_ipportiphash
|
||||
- ip_set_ipportnethash
|
||||
- ip_set_iptree
|
||||
- ip_set_iptreemap
|
||||
- ip_set_macipmap
|
||||
- ip_set_nethash
|
||||
- ip_set_portmap
|
||||
- ip_set_setlist
|
||||
- ipt_set
|
||||
- ipt_SET
|
||||
endef
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -538,7 +538,7 @@
|
|||
+module_exit(fini);
|
||||
--- a/net/ipv4/netfilter/Kconfig
|
||||
+++ b/net/ipv4/netfilter/Kconfig
|
||||
@@ -801,5 +801,22 @@ config IP_NF_TARGET_SET
|
||||
@@ -825,5 +825,22 @@ config IP_NF_TARGET_SET
|
||||
To compile it as a module, choose M here. If unsure, say N.
|
||||
|
||||
|
||||
|
|
File diff suppressed because it is too large
Load diff
File diff suppressed because it is too large
Load diff
File diff suppressed because it is too large
Load diff
File diff suppressed because it is too large
Load diff
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue