tools/mkimage: avoid picking up unrelated /usr/include headers with the same name as internal header files (e.g. image.h), fixes #12232
SVN-Revision: 33519
This commit is contained in:
parent
d406a5208f
commit
dcd3a74da0
2 changed files with 21 additions and 0 deletions
|
@ -18,6 +18,13 @@ HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
|
|||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
define Host/Prepare
|
||||
$(Host/Prepare/Default)
|
||||
rm -f \
|
||||
$(HOST_BUILD_DIR)/include/errno.h \
|
||||
$(HOST_BUILD_DIR)/include/malloc.h
|
||||
endef
|
||||
|
||||
define Host/Compile
|
||||
rm -f $(HOST_BUILD_DIR)/tools/.depend
|
||||
touch $(HOST_BUILD_DIR)/include/config.h
|
||||
|
|
14
tools/mkimage/patches/040-include_order.patch
Normal file
14
tools/mkimage/patches/040-include_order.patch
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -159,9 +159,9 @@ NOPEDOBJS := $(addprefix $(obj),$(NOPED_
|
||||
# Use native tools and options
|
||||
# Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
|
||||
#
|
||||
-HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \
|
||||
+HOSTCPPFLAGS = -I $(SRCTREE)/include \
|
||||
-idirafter $(OBJTREE)/include2 \
|
||||
- -idirafter $(OBJTREE)/include \
|
||||
+ -I $(OBJTREE)/include \
|
||||
-I $(SRCTREE)/lib/libfdt \
|
||||
-I $(SRCTREE)/tools \
|
||||
-DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \
|
Loading…
Reference in a new issue