kenrel: refresh patches

Signed-off-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 44678
This commit is contained in:
John Crispin 2015-03-11 17:08:46 +00:00
parent d5c250b91a
commit da3fd5dbf9
10 changed files with 270 additions and 270 deletions

View file

@ -1,6 +1,6 @@
--- a/fs/yaffs2/yaffs_vfs.c
+++ b/fs/yaffs2/yaffs_vfs.c
@@ -796,13 +796,13 @@
@@ -796,13 +796,13 @@ static int yaffs_sync_object(struct file
static const struct file_operations yaffs_file_operations = {
.read = do_sync_read,
.write = do_sync_write,
@ -17,7 +17,7 @@
.llseek = generic_file_llseek,
};
@@ -1050,7 +1050,7 @@
@@ -1050,7 +1050,7 @@ static int yaffs_readlink(struct dentry
if (!alias)
return -ENOMEM;

View file

@ -41,7 +41,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/arch/mips/lantiq/Kconfig
+++ b/arch/mips/lantiq/Kconfig
@@ -17,6 +17,7 @@
@@ -17,6 +17,7 @@ config SOC_XWAY
bool "XWAY"
select SOC_TYPE_XWAY
select HW_HAS_PCI
@ -49,7 +49,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
config SOC_FALCON
bool "FALCON"
@@ -37,6 +38,15 @@
@@ -37,6 +38,15 @@ config PCI_LANTIQ
bool "PCI Support"
depends on SOC_XWAY && PCI
@ -67,7 +67,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
depends on SOC_XWAY
--- a/arch/mips/lantiq/xway/sysctrl.c
+++ b/arch/mips/lantiq/xway/sysctrl.c
@@ -377,6 +377,8 @@
@@ -377,6 +377,8 @@ void __init ltq_soc_init(void)
PMU_PPE_EMA | PMU_PPE_TC | PMU_PPE_SLL01 |
PMU_PPE_QSB | PMU_PPE_TOP);
clkdev_add_pmu("1f203000.rcu", "gphy", 0, PMU_GPHY);
@ -78,7 +78,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
ltq_ar9_fpi_hz(), CLOCK_250M);
--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
@@ -43,6 +43,8 @@
@@ -43,6 +43,8 @@ obj-$(CONFIG_SNI_RM) += fixup-sni.o ops
obj-$(CONFIG_LANTIQ) += fixup-lantiq.o
obj-$(CONFIG_PCI_LANTIQ) += pci-lantiq.o ops-lantiq.o
obj-$(CONFIG_SOC_RT3883) += pci-rt3883.o
@ -188,7 +188,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
if (ltq_pci_plat_dev_init)
return ltq_pci_plat_dev_init(dev);
@@ -25,5 +26,7 @@
@@ -25,5 +26,7 @@ int pcibios_plat_dev_init(struct pci_dev
int __init pcibios_map_irq(const struct pci_dev *dev, u8 slot, u8 pin)
{
@ -4161,7 +4161,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+
--- a/arch/mips/pci/pci.c
+++ b/arch/mips/pci/pci.c
@@ -251,6 +251,31 @@
@@ -251,6 +251,31 @@ static int __init pcibios_init(void)
subsys_initcall(pcibios_init);
@ -5503,7 +5503,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+
--- a/drivers/pci/pcie/aer/Kconfig
+++ b/drivers/pci/pcie/aer/Kconfig
@@ -19,6 +19,7 @@
@@ -19,6 +19,7 @@ config PCIEAER
config PCIE_ECRC
bool "PCI Express ECRC settings control"
depends on PCIEAER
@ -5513,7 +5513,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
(transaction layer end-to-end CRC checking).
--- a/include/linux/pci.h
+++ b/include/linux/pci.h
@@ -1160,6 +1160,8 @@
@@ -1160,6 +1160,8 @@ void pci_walk_bus(struct pci_bus *top, i
void *userdata);
int pci_cfg_space_size(struct pci_dev *dev);
unsigned char pci_bus_max_busnr(struct pci_bus *bus);

View file

@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#include <linux/mtd/mtd.h>
#include <linux/mtd/partitions.h>
@@ -198,6 +199,10 @@
@@ -198,6 +199,10 @@ static int m25p_probe(struct spi_device
enum read_mode mode = SPI_NOR_NORMAL;
char *flash_name = NULL;
int ret;
@ -33,7 +33,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
data = dev_get_platdata(&spi->dev);
@@ -229,6 +234,8 @@
@@ -229,6 +234,8 @@ static int m25p_probe(struct spi_device
if (data && data->name)
flash->mtd.name = data->name;

View file

@ -30,7 +30,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+#endif /* _PCI_ATH_FIXUP */
--- a/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
+++ b/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
@@ -90,5 +90,8 @@
@@ -90,5 +90,8 @@ int xrx200_gphy_boot(struct device *dev,
extern void ltq_pmu_enable(unsigned int module);
extern void ltq_pmu_disable(unsigned int module);
@ -41,7 +41,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#endif /* _LTQ_XWAY_H__ */
--- a/arch/mips/lantiq/xway/Makefile
+++ b/arch/mips/lantiq/xway/Makefile
@@ -2,4 +2,7 @@
@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
obj-y += vmmc.o tffs.o
@ -590,7 +590,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+device_initcall(of_ralink_eeprom_init);
--- a/drivers/net/ethernet/lantiq_etop.c
+++ b/drivers/net/ethernet/lantiq_etop.c
@@ -161,7 +161,7 @@
@@ -161,7 +161,7 @@ struct ltq_etop_priv {
int tx_irq;
int rx_irq;
@ -599,7 +599,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
int mii_mode;
spinlock_t lock;
@@ -840,7 +840,11 @@
@@ -840,7 +840,11 @@ ltq_etop_init(struct net_device *dev)
if (err)
goto err_hw;

View file

@ -38,7 +38,7 @@
/* remapped base addr of the reset control unit */
static void __iomem *ltq_rcu_membase;
static struct device_node *ltq_rcu_np;
@@ -200,6 +231,45 @@
@@ -200,6 +231,45 @@ static void ltq_machine_power_off(void)
unreachable();
}
@ -84,7 +84,7 @@
static int __init mips_reboot_setup(void)
{
struct resource res;
@@ -223,6 +293,9 @@
@@ -223,6 +293,9 @@ static int __init mips_reboot_setup(void
if (!ltq_rcu_membase)
panic("Failed to remap core memory");

View file

@ -1,5 +1,5 @@
--- a/drivers/usb/dwc2/platform.c 2015-02-06 16:53:48.000000000 +0200
+++ b/drivers/usb/dwc2/platform.c 2015-02-09 19:22:41.974089626 +0200
--- a/drivers/usb/dwc2/platform.c
+++ b/drivers/usb/dwc2/platform.c
@@ -40,6 +40,7 @@
#include <linux/device.h>
#include <linux/dma-mapping.h>
@ -8,7 +8,7 @@
#include <linux/platform_device.h>
#include <linux/usb/of.h>
@@ -154,6 +155,7 @@
@@ -154,6 +155,7 @@ static int dwc2_driver_probe(struct plat
struct resource *res;
int retval;
int irq;
@ -16,7 +16,7 @@
if (usb_disabled())
return -ENODEV;
@@ -173,6 +175,16 @@
@@ -173,6 +175,16 @@ static int dwc2_driver_probe(struct plat
defparams.dma_desc_enable = 0;
}

View file

@ -1,6 +1,6 @@
--- a/drivers/usb/dwc2/platform.c 2015-02-09 19:37:34.553109992 +0200
+++ b/drivers/usb/dwc2/platform.c 2015-02-09 19:38:30.090111260 +0200
@@ -105,6 +105,34 @@
--- a/drivers/usb/dwc2/platform.c
+++ b/drivers/usb/dwc2/platform.c
@@ -106,6 +106,34 @@ static const struct dwc2_core_params par
.uframe_sched = -1,
};
@ -35,7 +35,7 @@
/**
* dwc2_driver_remove() - Called when the DWC_otg core is unregistered with the
* DWC_otg driver
@@ -128,6 +156,7 @@
@@ -129,6 +157,7 @@ static int dwc2_driver_remove(struct pla
static const struct of_device_id dwc2_of_match_table[] = {
{ .compatible = "brcm,bcm2835-usb", .data = &params_bcm2835 },
{ .compatible = "rockchip,rk3066-usb", .data = &params_rk3066 },

View file

@ -8,7 +8,7 @@
#include <linux/of.h>
#include <lantiq_soc.h>
@@ -38,10 +39,12 @@
@@ -38,10 +39,12 @@ enum {
LTQ_NOR_NORMAL
};
@ -24,7 +24,7 @@
};
static const char ltq_map_name[] = "ltq_nor";
@@ -109,12 +112,44 @@
@@ -109,12 +112,44 @@ ltq_copy_to(struct map_info *map, unsign
}
static int
@ -70,7 +70,7 @@
if (of_machine_is_compatible("lantiq,falcon") &&
(ltq_boot_select() != BS_FLASH)) {
@@ -128,76 +163,88 @@
@@ -128,76 +163,88 @@ ltq_mtd_probe(struct platform_device *pd
platform_set_drvdata(pdev, ltq_mtd);

View file

@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/cfi_cmdset_0001.c
+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
@@ -40,7 +40,7 @@
@@ -39,7 +39,7 @@
/* #define CMDSET0001_DISABLE_WRITE_SUSPEND */
// debugging, turns off buffer write mode if set to 1