use the mainline machname for the compex boards
SVN-Revision: 34083
This commit is contained in:
parent
a0dd47bbed
commit
d822ecfdf8
10 changed files with 63 additions and 81 deletions
|
@ -120,7 +120,7 @@ CONFIG_MACH_AP1000=y
|
|||
# CONFIG_MACH_ARCOM_VULCAN is not set
|
||||
CONFIG_MACH_AVILA=y
|
||||
CONFIG_MACH_CAMBRIA=y
|
||||
CONFIG_MACH_COMPEX=y
|
||||
CONFIG_MACH_COMPEXWP18=y
|
||||
# CONFIG_MACH_DEVIXP is not set
|
||||
CONFIG_MACH_DSMG600=y
|
||||
CONFIG_MACH_FSG=y
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/drivers/char/random.c
|
||||
+++ b/drivers/char/random.c
|
||||
@@ -271,9 +271,9 @@
|
||||
@@ -281,9 +281,9 @@
|
||||
/*
|
||||
* Configuration information
|
||||
*/
|
||||
|
|
|
@ -5,13 +5,6 @@ Subject: [PATCH] Add support for the Compex WP18 / NP18A boards
|
|||
|
||||
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
||||
---
|
||||
arch/arm/mach-ixp4xx/Kconfig | 8 ++
|
||||
arch/arm/mach-ixp4xx/Makefile | 2 +
|
||||
arch/arm/mach-ixp4xx/compex-setup.c | 136 +++++++++++++++++++++++++++++++++++
|
||||
arch/arm/mach-ixp4xx/ixdp425-pci.c | 3 +-
|
||||
arch/arm/tools/mach-types | 2 +-
|
||||
5 files changed, 149 insertions(+), 2 deletions(-)
|
||||
create mode 100644 arch/arm/mach-ixp4xx/compex-setup.c
|
||||
|
||||
--- a/arch/arm/mach-ixp4xx/Kconfig
|
||||
+++ b/arch/arm/mach-ixp4xx/Kconfig
|
||||
|
@ -19,7 +12,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
Engineering Sidewinder board. For more information on this
|
||||
platform, see http://www.adiengineering.com
|
||||
|
||||
+config MACH_COMPEX
|
||||
+config MACH_COMPEXWP18
|
||||
+ bool "Compex WP18 / NP18A"
|
||||
+ select PCI
|
||||
+ help
|
||||
|
@ -36,7 +29,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
obj-pci-$(CONFIG_MACH_ARCOM_VULCAN) += vulcan-pci.o
|
||||
obj-pci-$(CONFIG_MACH_PRONGHORN) += pronghorn-pci.o
|
||||
obj-pci-$(CONFIG_MACH_SIDEWINDER) += sidewinder-pci.o
|
||||
+obj-pci-$(CONFIG_MACH_COMPEX) += ixdp425-pci.o
|
||||
+obj-pci-$(CONFIG_MACH_COMPEXWP18) += ixdp425-pci.o
|
||||
|
||||
obj-y += common.o
|
||||
|
||||
|
@ -44,12 +37,12 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
obj-$(CONFIG_MACH_ARCOM_VULCAN) += vulcan-setup.o
|
||||
obj-$(CONFIG_MACH_PRONGHORN) += pronghorn-setup.o
|
||||
obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
|
||||
+obj-$(CONFIG_MACH_COMPEX) += compex-setup.o
|
||||
+obj-$(CONFIG_MACH_COMPEXWP18) += compex42x-setup.o
|
||||
|
||||
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
|
||||
obj-$(CONFIG_IXP4XX_QMGR) += ixp4xx_qmgr.o
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/mach-ixp4xx/compex-setup.c
|
||||
+++ b/arch/arm/mach-ixp4xx/compex42x-setup.c
|
||||
@@ -0,0 +1,138 @@
|
||||
+/*
|
||||
+ * arch/arm/mach-ixp4xx/compex-setup.c
|
||||
|
@ -77,21 +70,21 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
+ .width = 2,
|
||||
+};
|
||||
+
|
||||
+static struct resource compex_flash_resource = {
|
||||
+static struct resource compex42x_flash_resource = {
|
||||
+ .flags = IORESOURCE_MEM,
|
||||
+};
|
||||
+
|
||||
+static struct platform_device compex_flash = {
|
||||
+static struct platform_device compex42x_flash = {
|
||||
+ .name = "IXP4XX-Flash",
|
||||
+ .id = 0,
|
||||
+ .dev = {
|
||||
+ .platform_data = &compex_flash_data,
|
||||
+ .platform_data = &compex42x_flash_data,
|
||||
+ },
|
||||
+ .num_resources = 1,
|
||||
+ .resource = &compex_flash_resource,
|
||||
+ .resource = &compex42x_flash_resource,
|
||||
+};
|
||||
+
|
||||
+static struct resource compex_uart_resources[] = {
|
||||
+static struct resource compex42x_uart_resources[] = {
|
||||
+ {
|
||||
+ .start = IXP4XX_UART1_BASE_PHYS,
|
||||
+ .end = IXP4XX_UART1_BASE_PHYS + 0x0fff,
|
||||
|
@ -104,7 +97,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
+ }
|
||||
+};
|
||||
+
|
||||
+static struct plat_serial8250_port compex_uart_data[] = {
|
||||
+static struct plat_serial8250_port compex42x_uart_data[] = {
|
||||
+ {
|
||||
+ .mapbase = IXP4XX_UART1_BASE_PHYS,
|
||||
+ .membase = (char *)IXP4XX_UART1_BASE_VIRT + REG_OFFSET,
|
||||
|
@ -126,15 +119,15 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
+ { },
|
||||
+};
|
||||
+
|
||||
+static struct platform_device compex_uart = {
|
||||
+static struct platform_device compex42x_uart = {
|
||||
+ .name = "serial8250",
|
||||
+ .id = PLAT8250_DEV_PLATFORM,
|
||||
+ .dev.platform_data = compex_uart_data,
|
||||
+ .dev.platform_data = compex42x_uart_data,
|
||||
+ .num_resources = 2,
|
||||
+ .resource = compex_uart_resources,
|
||||
+ .resource = compex42x_uart_resources,
|
||||
+};
|
||||
+
|
||||
+static struct eth_plat_info compex_plat_eth[] = {
|
||||
+static struct eth_plat_info compex42x_plat_eth[] = {
|
||||
+ {
|
||||
+ .phy = IXP4XX_ETH_PHY_MAX_ADDR,
|
||||
+ .phy_mask = 0xf0000,
|
||||
|
@ -147,34 +140,34 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
+ }
|
||||
+};
|
||||
+
|
||||
+static struct platform_device compex_eth[] = {
|
||||
+static struct platform_device compex42x_eth[] = {
|
||||
+ {
|
||||
+ .name = "ixp4xx_eth",
|
||||
+ .id = IXP4XX_ETH_NPEB,
|
||||
+ .dev.platform_data = compex_plat_eth,
|
||||
+ .dev.platform_data = compex42x_plat_eth,
|
||||
+ }, {
|
||||
+ .name = "ixp4xx_eth",
|
||||
+ .id = IXP4XX_ETH_NPEC,
|
||||
+ .dev.platform_data = compex_plat_eth + 1,
|
||||
+ .dev.platform_data = compex42x_plat_eth + 1,
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
+static struct platform_device *compex_devices[] __initdata = {
|
||||
+ &compex_flash,
|
||||
+ &compex_uart,
|
||||
+ &compex_eth[0],
|
||||
+ &compex_eth[1],
|
||||
+static struct platform_device *compex42x_devices[] __initdata = {
|
||||
+ &compex42x_flash,
|
||||
+ &compex42x_uart,
|
||||
+ &compex42x_eth[0],
|
||||
+ &compex42x_eth[1],
|
||||
+};
|
||||
+
|
||||
+static void __init compex_init(void)
|
||||
+static void __init compex42x_init(void)
|
||||
+{
|
||||
+ ixp4xx_sys_init();
|
||||
+
|
||||
+ compex_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
|
||||
+ compex_flash_resource.end =
|
||||
+ compex42x_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
|
||||
+ compex42x_flash_resource.end =
|
||||
+ IXP4XX_EXP_BUS_BASE(0) + SZ_32M - 1;
|
||||
+
|
||||
+ platform_add_devices(compex_devices, ARRAY_SIZE(compex_devices));
|
||||
+ platform_add_devices(compex42x_devices, ARRAY_SIZE(compex42x_devices));
|
||||
+}
|
||||
+
|
||||
+MACHINE_START(COMPEX, "Compex WP18 / NP18A")
|
||||
|
@ -183,7 +176,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
+ .init_irq = ixp4xx_init_irq,
|
||||
+ .timer = &ixp4xx_timer,
|
||||
+ .atag_offset = 0x0100,
|
||||
+ .init_machine = compex_init,
|
||||
+ .init_machine = compex42x_init,
|
||||
+#if defined(CONFIG_PCI)
|
||||
+ .dma_zone_size = SZ_64M,
|
||||
+#endif
|
||||
|
@ -197,18 +190,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
|
|||
if (machine_is_ixdp425() || machine_is_ixcdp1100() ||
|
||||
- machine_is_ixdp465() || machine_is_kixrp435())
|
||||
+ machine_is_ixdp465() || machine_is_kixrp435() ||
|
||||
+ machine_is_compex())
|
||||
+ machine_is_compex42x())
|
||||
pci_common_init(&ixdp425_pci);
|
||||
return 0;
|
||||
}
|
||||
--- a/arch/arm/tools/mach-types
|
||||
+++ b/arch/arm/tools/mach-types
|
||||
@@ -1273,7 +1273,7 @@ oiab MACH_OIAB OIAB 1269
|
||||
smdk6400 MACH_SMDK6400 SMDK6400 1270
|
||||
nokia_n800 MACH_NOKIA_N800 NOKIA_N800 1271
|
||||
greenphone MACH_GREENPHONE GREENPHONE 1272
|
||||
-compex42x MACH_COMPEXWP18 COMPEXWP18 1273
|
||||
+compex MACH_COMPEX COMPEX 1273
|
||||
xmate MACH_XMATE XMATE 1274
|
||||
energizer MACH_ENERGIZER ENERGIZER 1275
|
||||
ime1 MACH_IME1 IME1 1276
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/arch/arm/mach-ixp4xx/Kconfig
|
||||
+++ b/arch/arm/mach-ixp4xx/Kconfig
|
||||
@@ -97,6 +97,14 @@ config MACH_COMPEX
|
||||
@@ -97,6 +97,14 @@ config MACH_COMPEXWP18
|
||||
WP18 or NP18A boards. For more information on this
|
||||
platform, see http://www.compex.com.sg/home/OEM/product_ap.htm
|
||||
|
||||
|
@ -20,7 +20,7 @@
|
|||
@@ -22,6 +22,7 @@ obj-pci-$(CONFIG_MACH_ARCOM_VULCAN) += v
|
||||
obj-pci-$(CONFIG_MACH_PRONGHORN) += pronghorn-pci.o
|
||||
obj-pci-$(CONFIG_MACH_SIDEWINDER) += sidewinder-pci.o
|
||||
obj-pci-$(CONFIG_MACH_COMPEX) += ixdp425-pci.o
|
||||
obj-pci-$(CONFIG_MACH_COMPEXWP18) += ixdp425-pci.o
|
||||
+obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-pci.o
|
||||
|
||||
obj-y += common.o
|
||||
|
@ -28,7 +28,7 @@
|
|||
@@ -45,6 +46,7 @@ obj-$(CONFIG_MACH_ARCOM_VULCAN) += vulca
|
||||
obj-$(CONFIG_MACH_PRONGHORN) += pronghorn-setup.o
|
||||
obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
|
||||
obj-$(CONFIG_MACH_COMPEX) += compex-setup.o
|
||||
obj-$(CONFIG_MACH_COMPEXWP18) += compex42x-setup.o
|
||||
+obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-setup.o
|
||||
|
||||
obj-$(CONFIG_PCI) += $(obj-pci-$(CONFIG_PCI)) common-pci.o
|
||||
|
|
|
@ -160,8 +160,8 @@
|
|||
{
|
||||
if (machine_is_ixdp425() || machine_is_ixcdp1100() ||
|
||||
machine_is_ixdp465() || machine_is_kixrp435() ||
|
||||
- machine_is_compex())
|
||||
+ machine_is_compex() || machine_is_ap1000())
|
||||
- machine_is_compex42x())
|
||||
+ machine_is_compex42x() || machine_is_ap1000())
|
||||
pci_common_init(&ixdp425_pci);
|
||||
return 0;
|
||||
}
|
||||
|
@ -186,7 +186,7 @@
|
|||
+++ b/arch/arm/mach-ixp4xx/Makefile
|
||||
@@ -23,6 +23,7 @@ obj-pci-$(CONFIG_MACH_PRONGHORN) += pron
|
||||
obj-pci-$(CONFIG_MACH_SIDEWINDER) += sidewinder-pci.o
|
||||
obj-pci-$(CONFIG_MACH_COMPEX) += ixdp425-pci.o
|
||||
obj-pci-$(CONFIG_MACH_COMPEXWP18) += ixdp425-pci.o
|
||||
obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-pci.o
|
||||
+obj-pci-$(CONFIG_MACH_AP1000) += ixdp425-pci.o
|
||||
|
||||
|
@ -194,7 +194,7 @@
|
|||
|
||||
@@ -47,6 +48,7 @@ obj-$(CONFIG_MACH_PRONGHORN) += pronghor
|
||||
obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
|
||||
obj-$(CONFIG_MACH_COMPEX) += compex-setup.o
|
||||
obj-$(CONFIG_MACH_COMPEXWP18) += compex42x-setup.o
|
||||
obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-setup.o
|
||||
+obj-$(CONFIG_MACH_AP1000) += ap1000-setup.o
|
||||
|
||||
|
|
|
@ -18,7 +18,7 @@
|
|||
--- a/arch/arm/mach-ixp4xx/Makefile
|
||||
+++ b/arch/arm/mach-ixp4xx/Makefile
|
||||
@@ -24,6 +24,7 @@ obj-pci-$(CONFIG_MACH_SIDEWINDER) += sid
|
||||
obj-pci-$(CONFIG_MACH_COMPEX) += ixdp425-pci.o
|
||||
obj-pci-$(CONFIG_MACH_COMPEXWP18) += ixdp425-pci.o
|
||||
obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-pci.o
|
||||
obj-pci-$(CONFIG_MACH_AP1000) += ixdp425-pci.o
|
||||
+obj-pci-$(CONFIG_MACH_TW5334) += tw5334-pci.o
|
||||
|
@ -26,7 +26,7 @@
|
|||
obj-y += common.o
|
||||
|
||||
@@ -49,6 +50,7 @@ obj-$(CONFIG_MACH_SIDEWINDER) += sidewin
|
||||
obj-$(CONFIG_MACH_COMPEX) += compex-setup.o
|
||||
obj-$(CONFIG_MACH_COMPEXWP18) += compex42x-setup.o
|
||||
obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-setup.o
|
||||
obj-$(CONFIG_MACH_AP1000) += ap1000-setup.o
|
||||
+obj-$(CONFIG_MACH_TW5334) += tw5334-setup.o
|
||||
|
|
|
@ -458,7 +458,7 @@
|
|||
+
|
||||
--- a/arch/arm/mach-ixp4xx/Makefile
|
||||
+++ b/arch/arm/mach-ixp4xx/Makefile
|
||||
@@ -25,6 +25,7 @@ obj-pci-$(CONFIG_MACH_COMPEX) += ixdp42
|
||||
@@ -25,6 +25,7 @@ obj-pci-$(CONFIG_MACH_COMPEXWP18) += ixd
|
||||
obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-pci.o
|
||||
obj-pci-$(CONFIG_MACH_AP1000) += ixdp425-pci.o
|
||||
obj-pci-$(CONFIG_MACH_TW5334) += tw5334-pci.o
|
||||
|
@ -466,7 +466,7 @@
|
|||
|
||||
obj-y += common.o
|
||||
|
||||
@@ -51,6 +52,7 @@ obj-$(CONFIG_MACH_COMPEX) += compex-setu
|
||||
@@ -51,6 +52,7 @@ obj-$(CONFIG_MACH_COMPEXWP18) += compex4
|
||||
obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-setup.o
|
||||
obj-$(CONFIG_MACH_AP1000) += ap1000-setup.o
|
||||
obj-$(CONFIG_MACH_TW5334) += tw5334-setup.o
|
||||
|
|
|
@ -117,7 +117,7 @@
|
|||
.name = "intrq",
|
||||
.start = IRQ_IXP4XX_GPIO12,
|
||||
.end = IRQ_IXP4XX_GPIO12,
|
||||
@@ -133,21 +210,275 @@ static struct platform_device avila_pata
|
||||
@@ -133,21 +210,208 @@ static struct platform_device avila_pata
|
||||
.resource = avila_pata_resources,
|
||||
};
|
||||
|
||||
|
@ -330,17 +330,13 @@
|
|||
+ platform_device_register(&avila_npec_device);
|
||||
+
|
||||
+ platform_device_register(&avila_gpio_leds_device);
|
||||
+
|
||||
+ avila_pata_resources[0].start = IXP4XX_EXP_BUS_BASE(1);
|
||||
+ avila_pata_resources[0].end = IXP4XX_EXP_BUS_END(1);
|
||||
+
|
||||
+ avila_pata_resources[1].start = IXP4XX_EXP_BUS_BASE(2);
|
||||
+ avila_pata_resources[1].end = IXP4XX_EXP_BUS_END(2);
|
||||
+
|
||||
+ avila_pata_data.cs0_cfg = IXP4XX_EXP_CS1;
|
||||
+ avila_pata_data.cs1_cfg = IXP4XX_EXP_CS2;
|
||||
+
|
||||
+ platform_device_register(&avila_pata);
|
||||
|
||||
avila_pata_resources[0].start = IXP4XX_EXP_BUS_BASE(1);
|
||||
avila_pata_resources[0].end = IXP4XX_EXP_BUS_END(1);
|
||||
@@ -159,8 +423,339 @@ static void __init avila_init(void)
|
||||
avila_pata_data.cs1_cfg = IXP4XX_EXP_CS2;
|
||||
|
||||
platform_device_register(&avila_pata);
|
||||
+}
|
||||
+
|
||||
+static void __init avila_gw2347_setup(void)
|
||||
|
@ -397,13 +393,17 @@
|
|||
+ avila_latch_leds_data.num_leds = 5;
|
||||
+ avila_latch_leds_data.mem = 0x54000000;
|
||||
+ platform_device_register(&avila_latch_leds_device);
|
||||
|
||||
avila_pata_resources[0].start = IXP4XX_EXP_BUS_BASE(1);
|
||||
avila_pata_resources[0].end = IXP4XX_EXP_BUS_END(1);
|
||||
@@ -159,8 +495,272 @@ static void __init avila_init(void)
|
||||
avila_pata_data.cs1_cfg = IXP4XX_EXP_CS2;
|
||||
|
||||
platform_device_register(&avila_pata);
|
||||
+
|
||||
+ avila_pata_resources[0].start = IXP4XX_EXP_BUS_BASE(1);
|
||||
+ avila_pata_resources[0].end = IXP4XX_EXP_BUS_END(1);
|
||||
+
|
||||
+ avila_pata_resources[1].start = IXP4XX_EXP_BUS_BASE(2);
|
||||
+ avila_pata_resources[1].end = IXP4XX_EXP_BUS_END(2);
|
||||
+
|
||||
+ avila_pata_data.cs0_cfg = IXP4XX_EXP_CS1;
|
||||
+ avila_pata_data.cs1_cfg = IXP4XX_EXP_CS2;
|
||||
+
|
||||
+ platform_device_register(&avila_pata);
|
||||
+}
|
||||
+
|
||||
+static void __init avila_gw2357_setup(void)
|
||||
|
|
|
@ -12,7 +12,7 @@
|
|||
+ USR8200 router board. For more information on this platform, see
|
||||
+ http://openwrt.org
|
||||
+
|
||||
config MACH_COMPEX
|
||||
config MACH_COMPEXWP18
|
||||
bool "Compex WP18 / NP18A"
|
||||
select PCI
|
||||
--- a/arch/arm/mach-ixp4xx/Makefile
|
||||
|
|
|
@ -19,7 +19,7 @@
|
|||
--- a/arch/arm/mach-ixp4xx/Makefile
|
||||
+++ b/arch/arm/mach-ixp4xx/Makefile
|
||||
@@ -25,6 +25,7 @@ obj-pci-$(CONFIG_MACH_SIDEWINDER) += sid
|
||||
obj-pci-$(CONFIG_MACH_COMPEX) += ixdp425-pci.o
|
||||
obj-pci-$(CONFIG_MACH_COMPEXWP18) += ixdp425-pci.o
|
||||
obj-pci-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-pci.o
|
||||
obj-pci-$(CONFIG_MACH_AP1000) += ixdp425-pci.o
|
||||
+obj-pci-$(CONFIG_MACH_TW2662) += tw2662-pci.o
|
||||
|
@ -27,7 +27,7 @@
|
|||
obj-pci-$(CONFIG_MACH_MI424WR) += mi424wr-pci.o
|
||||
obj-pci-$(CONFIG_MACH_USR8200) += usr8200-pci.o
|
||||
@@ -54,6 +55,7 @@ obj-$(CONFIG_MACH_SIDEWINDER) += sidewin
|
||||
obj-$(CONFIG_MACH_COMPEX) += compex-setup.o
|
||||
obj-$(CONFIG_MACH_COMPEXWP18) += compex42x-setup.o
|
||||
obj-$(CONFIG_MACH_WRT300NV2) += wrt300nv2-setup.o
|
||||
obj-$(CONFIG_MACH_AP1000) += ap1000-setup.o
|
||||
+obj-$(CONFIG_MACH_TW2662) += tw2662-setup.o
|
||||
|
|
Loading…
Reference in a new issue