bcm53xx: backport BCM5301X patches from 2019-09-30
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
This commit is contained in:
parent
cea09329e5
commit
d5dcb1bf97
8 changed files with 471 additions and 30 deletions
|
@ -0,0 +1,70 @@
|
||||||
|
From 345fd105ff676ef672d1e41b31165b47aa040dab Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
|
||||||
|
Date: Wed, 21 Sep 2016 22:58:32 +0200
|
||||||
|
Subject: [PATCH] ARM: BCM5301X: Add separated DTS include file for BCM47094
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Use it to store BCM47094 specific properties/values and avoid repeating
|
||||||
|
them in device DTS files.
|
||||||
|
|
||||||
|
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
|
||||||
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/bcm47094-dlink-dir-885l.dts | 3 +--
|
||||||
|
arch/arm/boot/dts/bcm47094-netgear-r8500.dts | 3 +--
|
||||||
|
arch/arm/boot/dts/bcm47094.dtsi | 11 +++++++++++
|
||||||
|
3 files changed, 13 insertions(+), 4 deletions(-)
|
||||||
|
create mode 100644 arch/arm/boot/dts/bcm47094.dtsi
|
||||||
|
|
||||||
|
--- a/arch/arm/boot/dts/bcm47094-dlink-dir-885l.dts
|
||||||
|
+++ b/arch/arm/boot/dts/bcm47094-dlink-dir-885l.dts
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
|
||||||
|
/dts-v1/;
|
||||||
|
|
||||||
|
-#include "bcm4708.dtsi"
|
||||||
|
+#include "bcm47094.dtsi"
|
||||||
|
#include "bcm5301x-nand-cs0-bch1.dtsi"
|
||||||
|
|
||||||
|
/ {
|
||||||
|
@@ -107,7 +107,6 @@
|
||||||
|
|
||||||
|
&uart0 {
|
||||||
|
status = "okay";
|
||||||
|
- clock-frequency = <125000000>;
|
||||||
|
};
|
||||||
|
|
||||||
|
&usb3 {
|
||||||
|
--- a/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
||||||
|
+++ b/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
|
||||||
|
@@ -6,7 +6,7 @@
|
||||||
|
|
||||||
|
/dts-v1/;
|
||||||
|
|
||||||
|
-#include "bcm4708.dtsi"
|
||||||
|
+#include "bcm47094.dtsi"
|
||||||
|
#include "bcm5301x-nand-cs0-bch8.dtsi"
|
||||||
|
|
||||||
|
/ {
|
||||||
|
@@ -100,5 +100,4 @@
|
||||||
|
|
||||||
|
&uart0 {
|
||||||
|
status = "okay";
|
||||||
|
- clock-frequency = <125000000>;
|
||||||
|
};
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm/boot/dts/bcm47094.dtsi
|
||||||
|
@@ -0,0 +1,11 @@
|
||||||
|
+/*
|
||||||
|
+ * Copyright (C) 2016 Rafał Miłecki <rafal@milecki.pl>
|
||||||
|
+ *
|
||||||
|
+ * Licensed under the ISC license.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#include "bcm4708.dtsi"
|
||||||
|
+
|
||||||
|
+&uart0 {
|
||||||
|
+ clock-frequency = <125000000>;
|
||||||
|
+};
|
|
@ -0,0 +1,92 @@
|
||||||
|
From 3ede027b3dce2fca07350b7587c7c8f44706c94c Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
|
||||||
|
Date: Wed, 21 Sep 2016 22:58:33 +0200
|
||||||
|
Subject: [PATCH] ARM: BCM5301X: Enable UART on Netgear R8000
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
It was tested by LEDE users, all we need is to adjust clock frequency.
|
||||||
|
While we're at it create a separated DTS include file to share code with
|
||||||
|
other BCM4709 devices easier.
|
||||||
|
|
||||||
|
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
|
||||||
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts | 2 +-
|
||||||
|
arch/arm/boot/dts/bcm4709-buffalo-wxr-1900dhp.dts | 2 +-
|
||||||
|
arch/arm/boot/dts/bcm4709-netgear-r7000.dts | 2 +-
|
||||||
|
arch/arm/boot/dts/bcm4709-netgear-r8000.dts | 6 +++++-
|
||||||
|
arch/arm/boot/dts/bcm4709.dtsi | 11 +++++++++++
|
||||||
|
5 files changed, 19 insertions(+), 4 deletions(-)
|
||||||
|
create mode 100644 arch/arm/boot/dts/bcm4709.dtsi
|
||||||
|
|
||||||
|
--- a/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
|
||||||
|
+++ b/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
|
||||||
|
/dts-v1/;
|
||||||
|
|
||||||
|
-#include "bcm4708.dtsi"
|
||||||
|
+#include "bcm4709.dtsi"
|
||||||
|
#include "bcm5301x-nand-cs0-bch8.dtsi"
|
||||||
|
|
||||||
|
/ {
|
||||||
|
--- a/arch/arm/boot/dts/bcm4709-buffalo-wxr-1900dhp.dts
|
||||||
|
+++ b/arch/arm/boot/dts/bcm4709-buffalo-wxr-1900dhp.dts
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
|
||||||
|
/dts-v1/;
|
||||||
|
|
||||||
|
-#include "bcm4708.dtsi"
|
||||||
|
+#include "bcm4709.dtsi"
|
||||||
|
#include "bcm5301x-nand-cs0-bch8.dtsi"
|
||||||
|
|
||||||
|
/ {
|
||||||
|
--- a/arch/arm/boot/dts/bcm4709-netgear-r7000.dts
|
||||||
|
+++ b/arch/arm/boot/dts/bcm4709-netgear-r7000.dts
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
|
||||||
|
/dts-v1/;
|
||||||
|
|
||||||
|
-#include "bcm4708.dtsi"
|
||||||
|
+#include "bcm4709.dtsi"
|
||||||
|
#include "bcm5301x-nand-cs0-bch8.dtsi"
|
||||||
|
|
||||||
|
/ {
|
||||||
|
--- a/arch/arm/boot/dts/bcm4709-netgear-r8000.dts
|
||||||
|
+++ b/arch/arm/boot/dts/bcm4709-netgear-r8000.dts
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
|
||||||
|
/dts-v1/;
|
||||||
|
|
||||||
|
-#include "bcm4708.dtsi"
|
||||||
|
+#include "bcm4709.dtsi"
|
||||||
|
#include "bcm5301x-nand-cs0-bch8.dtsi"
|
||||||
|
|
||||||
|
/ {
|
||||||
|
@@ -107,6 +107,10 @@
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
+&uart0 {
|
||||||
|
+ status = "okay";
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
&usb2 {
|
||||||
|
vcc-gpio = <&chipcommon 0 GPIO_ACTIVE_HIGH>;
|
||||||
|
};
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm/boot/dts/bcm4709.dtsi
|
||||||
|
@@ -0,0 +1,11 @@
|
||||||
|
+/*
|
||||||
|
+ * Copyright (C) 2016 Rafał Miłecki <rafal@milecki.pl>
|
||||||
|
+ *
|
||||||
|
+ * Licensed under the ISC license.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#include "bcm4708.dtsi"
|
||||||
|
+
|
||||||
|
+&uart0 {
|
||||||
|
+ clock-frequency = <125000000>;
|
||||||
|
+};
|
|
@ -0,0 +1,51 @@
|
||||||
|
From 5b92db97f4ae345bd6f045c9427471680a7fe2e7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
|
||||||
|
Date: Wed, 21 Sep 2016 22:58:34 +0200
|
||||||
|
Subject: [PATCH] ARM: BCM5301X: Specify USB 3.0 PHY in DT
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Driver for Northstar USB 3.0 PHY has been recently added under the name
|
||||||
|
phy-bcm-ns-usb3. Add binding for it into the DT files.
|
||||||
|
The only slightly tricky part is BCM47094 which uses different PHY
|
||||||
|
version and requires different compatible value.
|
||||||
|
|
||||||
|
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
|
||||||
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/bcm47094.dtsi | 6 ++++++
|
||||||
|
arch/arm/boot/dts/bcm5301x.dtsi | 7 +++++++
|
||||||
|
2 files changed, 13 insertions(+)
|
||||||
|
|
||||||
|
--- a/arch/arm/boot/dts/bcm47094.dtsi
|
||||||
|
+++ b/arch/arm/boot/dts/bcm47094.dtsi
|
||||||
|
@@ -6,6 +6,12 @@
|
||||||
|
|
||||||
|
#include "bcm4708.dtsi"
|
||||||
|
|
||||||
|
+/ {
|
||||||
|
+ usb3_phy: usb3-phy {
|
||||||
|
+ compatible = "brcm,ns-bx-usb3-phy";
|
||||||
|
+ };
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
&uart0 {
|
||||||
|
clock-frequency = <125000000>;
|
||||||
|
};
|
||||||
|
--- a/arch/arm/boot/dts/bcm5301x.dtsi
|
||||||
|
+++ b/arch/arm/boot/dts/bcm5301x.dtsi
|
||||||
|
@@ -149,6 +149,13 @@
|
||||||
|
clock-names = "phy-ref-clk";
|
||||||
|
};
|
||||||
|
|
||||||
|
+ usb3_phy: usb3-phy {
|
||||||
|
+ compatible = "brcm,ns-ax-usb3-phy";
|
||||||
|
+ reg = <0x18105000 0x1000>, <0x18003000 0x1000>;
|
||||||
|
+ reg-names = "dmp", "ccb-mii";
|
||||||
|
+ #phy-cells = <0>;
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
axi@18000000 {
|
||||||
|
compatible = "brcm,bus-axi";
|
||||||
|
reg = <0x18000000 0x1000>;
|
|
@ -0,0 +1,93 @@
|
||||||
|
From 46daccf62d1651bf8b09978478ca6465a7a81f47 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Dan Haab <dhaab@luxul.com>
|
||||||
|
Date: Tue, 27 Sep 2016 11:27:10 -0600
|
||||||
|
Subject: [PATCH] ARM: BCM5301X: Add DT for Luxul XAP-1510
|
||||||
|
|
||||||
|
Luxul XAP-1510 is an AP device based on BCM4708 SoC with 2 x BCM4360
|
||||||
|
chipsets on PCB connected using PCIe.
|
||||||
|
|
||||||
|
Signed-off-by: Dan Haab <dhaab@luxul.com>
|
||||||
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/Makefile | 1 +
|
||||||
|
arch/arm/boot/dts/bcm4708-luxul-xap-1510.dts | 64 ++++++++++++++++++++++++++++
|
||||||
|
2 files changed, 65 insertions(+)
|
||||||
|
create mode 100644 arch/arm/boot/dts/bcm4708-luxul-xap-1510.dts
|
||||||
|
|
||||||
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
|
@@ -65,6 +65,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
||||||
|
bcm4708-asus-rt-ac56u.dtb \
|
||||||
|
bcm4708-asus-rt-ac68u.dtb \
|
||||||
|
bcm4708-buffalo-wzr-1750dhp.dtb \
|
||||||
|
+ bcm4708-luxul-xap-1510.dtb \
|
||||||
|
bcm4708-luxul-xwc-1000.dtb \
|
||||||
|
bcm4708-netgear-r6250.dtb \
|
||||||
|
bcm4708-netgear-r6300-v2.dtb \
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm/boot/dts/bcm4708-luxul-xap-1510.dts
|
||||||
|
@@ -0,0 +1,64 @@
|
||||||
|
+/*
|
||||||
|
+ * Copyright 2016 Luxul Inc.
|
||||||
|
+ *
|
||||||
|
+ * Licensed under the ISC license.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/dts-v1/;
|
||||||
|
+
|
||||||
|
+#include "bcm4708.dtsi"
|
||||||
|
+
|
||||||
|
+/ {
|
||||||
|
+ compatible = "luxul,xap-1510v1", "brcm,bcm4708";
|
||||||
|
+ model = "Luxul XAP-1510 V1";
|
||||||
|
+
|
||||||
|
+ chosen {
|
||||||
|
+ bootargs = "console=ttyS0,115200 earlycon";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ memory {
|
||||||
|
+ reg = <0x00000000 0x08000000>;
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ leds {
|
||||||
|
+ compatible = "gpio-leds";
|
||||||
|
+
|
||||||
|
+ 5ghz {
|
||||||
|
+ label = "bcm53xx:blue:5ghz";
|
||||||
|
+ gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "none";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ 2ghz {
|
||||||
|
+ label = "bcm53xx:blue:2ghz";
|
||||||
|
+ gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "none";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ status {
|
||||||
|
+ label = "bcm53xx:green:status";
|
||||||
|
+ gpios = <&chipcommon 15 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "timer";
|
||||||
|
+ };
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ gpio-keys {
|
||||||
|
+ compatible = "gpio-keys";
|
||||||
|
+ #address-cells = <1>;
|
||||||
|
+ #size-cells = <0>;
|
||||||
|
+
|
||||||
|
+ restart {
|
||||||
|
+ label = "Reset";
|
||||||
|
+ linux,code = <KEY_RESTART>;
|
||||||
|
+ gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
|
||||||
|
+ };
|
||||||
|
+ };
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&uart0 {
|
||||||
|
+ status = "okay";
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&spi_nor {
|
||||||
|
+ status = "okay";
|
||||||
|
+};
|
|
@ -0,0 +1,159 @@
|
||||||
|
From ef3bc318adeb15b38688df6a583bafea2befce43 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Dan Haab <dhaab@luxul.com>
|
||||||
|
Date: Tue, 27 Sep 2016 11:27:11 -0600
|
||||||
|
Subject: [PATCH] ARM: BCM5301X: Add DT for Luxul XWR-3100
|
||||||
|
|
||||||
|
Luxul XWR-3100 is a wireless router based on BCM47094 SoC with two
|
||||||
|
4366c0 FullMAC PCIe cards on the PCB. It uses NAND with BCH-4 ECC
|
||||||
|
algorithm.
|
||||||
|
|
||||||
|
Signed-off-by: Dan Haab <dhaab@luxul.com>
|
||||||
|
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
|
||||||
|
---
|
||||||
|
arch/arm/boot/dts/Makefile | 1 +
|
||||||
|
arch/arm/boot/dts/bcm47094-luxul-xwr-3100.dts | 111 ++++++++++++++++++++++++++
|
||||||
|
arch/arm/boot/dts/bcm5301x-nand-cs0-bch4.dtsi | 13 +++
|
||||||
|
3 files changed, 125 insertions(+)
|
||||||
|
create mode 100644 arch/arm/boot/dts/bcm47094-luxul-xwr-3100.dts
|
||||||
|
create mode 100644 arch/arm/boot/dts/bcm5301x-nand-cs0-bch4.dtsi
|
||||||
|
|
||||||
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
|
@@ -78,6 +78,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
||||||
|
bcm4709-netgear-r7000.dtb \
|
||||||
|
bcm4709-netgear-r8000.dtb \
|
||||||
|
bcm47094-dlink-dir-885l.dtb \
|
||||||
|
+ bcm47094-luxul-xwr-3100.dtb \
|
||||||
|
bcm47094-netgear-r8500.dtb \
|
||||||
|
bcm94708.dtb \
|
||||||
|
bcm94709.dtb \
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm/boot/dts/bcm47094-luxul-xwr-3100.dts
|
||||||
|
@@ -0,0 +1,111 @@
|
||||||
|
+/*
|
||||||
|
+ * Copyright 2016 Luxul Inc.
|
||||||
|
+ *
|
||||||
|
+ * Licensed under the ISC license.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+/dts-v1/;
|
||||||
|
+
|
||||||
|
+#include "bcm47094.dtsi"
|
||||||
|
+#include "bcm5301x-nand-cs0-bch4.dtsi"
|
||||||
|
+
|
||||||
|
+/ {
|
||||||
|
+ compatible = "luxul,xwr-3100v1", "brcm,bcm47094", "brcm,bcm4708";
|
||||||
|
+ model = "Luxul XWR-3100 V1";
|
||||||
|
+
|
||||||
|
+ chosen {
|
||||||
|
+ bootargs = "console=ttyS0,115200 earlycon";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ memory {
|
||||||
|
+ reg = <0x00000000 0x08000000>;
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ leds {
|
||||||
|
+ compatible = "gpio-leds";
|
||||||
|
+
|
||||||
|
+ power {
|
||||||
|
+ label = "bcm53xx:green:power";
|
||||||
|
+ gpios = <&chipcommon 0 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-on";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ lan3 {
|
||||||
|
+ label = "bcm53xx:green:lan1";
|
||||||
|
+ gpios = <&chipcommon 1 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ lan4 {
|
||||||
|
+ label = "bcm53xx:green:lan0";
|
||||||
|
+ gpios = <&chipcommon 2 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ wan {
|
||||||
|
+ label = "bcm53xx:green:wan";
|
||||||
|
+ gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ lan1 {
|
||||||
|
+ label = "bcm53xx:green:lan3";
|
||||||
|
+ gpios = <&chipcommon 4 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ lan2 {
|
||||||
|
+ label = "bcm53xx:green:lan2";
|
||||||
|
+ gpios = <&chipcommon 6 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ usb3 {
|
||||||
|
+ label = "bcm53xx:green:usb3";
|
||||||
|
+ gpios = <&chipcommon 8 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ status {
|
||||||
|
+ label = "bcm53xx:green:status";
|
||||||
|
+ gpios = <&chipcommon 10 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "timer";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ 2ghz {
|
||||||
|
+ label = "bcm53xx:green:2ghz";
|
||||||
|
+ gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ 5ghz {
|
||||||
|
+ label = "bcm53xx:green:5ghz";
|
||||||
|
+ gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
|
||||||
|
+ linux,default-trigger = "default-off";
|
||||||
|
+ };
|
||||||
|
+ };
|
||||||
|
+
|
||||||
|
+ gpio-keys {
|
||||||
|
+ compatible = "gpio-keys";
|
||||||
|
+ #address-cells = <1>;
|
||||||
|
+ #size-cells = <0>;
|
||||||
|
+
|
||||||
|
+ restart {
|
||||||
|
+ label = "Reset";
|
||||||
|
+ linux,code = <KEY_RESTART>;
|
||||||
|
+ gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
|
||||||
|
+ };
|
||||||
|
+ };
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&uart0 {
|
||||||
|
+ status = "okay";
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&usb3 {
|
||||||
|
+ vcc-gpio = <&chipcommon 18 GPIO_ACTIVE_HIGH>;
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+&spi_nor {
|
||||||
|
+ status = "okay";
|
||||||
|
+};
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/arch/arm/boot/dts/bcm5301x-nand-cs0-bch4.dtsi
|
||||||
|
@@ -0,0 +1,13 @@
|
||||||
|
+/*
|
||||||
|
+ * Copyright 2016 Luxul Inc.
|
||||||
|
+ *
|
||||||
|
+ * Licensed under the ISC license.
|
||||||
|
+ */
|
||||||
|
+
|
||||||
|
+#include "bcm5301x-nand-cs0.dtsi"
|
||||||
|
+
|
||||||
|
+&nandcs {
|
||||||
|
+ nand-ecc-algo = "bch";
|
||||||
|
+ nand-ecc-strength = <4>;
|
||||||
|
+ nand-ecc-step-size = <512>;
|
||||||
|
+};
|
|
@ -9,14 +9,14 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||||
|
|
||||||
--- a/arch/arm/boot/dts/Makefile
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
+++ b/arch/arm/boot/dts/Makefile
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
@@ -75,6 +75,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
@@ -76,6 +76,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
|
||||||
bcm4709-asus-rt-ac87u.dtb \
|
bcm4709-asus-rt-ac87u.dtb \
|
||||||
bcm4709-buffalo-wxr-1900dhp.dtb \
|
bcm4709-buffalo-wxr-1900dhp.dtb \
|
||||||
bcm4709-netgear-r7000.dtb \
|
bcm4709-netgear-r7000.dtb \
|
||||||
+ bcm4709-netgear-r7900.dtb \
|
+ bcm4709-netgear-r7900.dtb \
|
||||||
bcm4709-netgear-r8000.dtb \
|
bcm4709-netgear-r8000.dtb \
|
||||||
bcm47094-dlink-dir-885l.dtb \
|
bcm47094-dlink-dir-885l.dtb \
|
||||||
bcm47094-netgear-r8500.dtb \
|
bcm47094-luxul-xwr-3100.dtb \
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/arm/boot/dts/bcm4709-netgear-r7900.dts
|
+++ b/arch/arm/boot/dts/bcm4709-netgear-r7900.dts
|
||||||
@@ -0,0 +1,41 @@
|
@@ -0,0 +1,41 @@
|
||||||
|
@ -31,7 +31,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||||
+
|
+
|
||||||
+/dts-v1/;
|
+/dts-v1/;
|
||||||
+
|
+
|
||||||
+#include "bcm4708.dtsi"
|
+#include "bcm4709.dtsi"
|
||||||
+#include "bcm5301x-nand-cs0-bch8.dtsi"
|
+#include "bcm5301x-nand-cs0-bch8.dtsi"
|
||||||
+
|
+
|
||||||
+/ {
|
+/ {
|
||||||
|
|
|
@ -13,9 +13,9 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||||
bcm4708-asus-rt-ac68u.dtb \
|
bcm4708-asus-rt-ac68u.dtb \
|
||||||
bcm4708-buffalo-wzr-1750dhp.dtb \
|
bcm4708-buffalo-wzr-1750dhp.dtb \
|
||||||
+ bcm4708-linksys-ea6300-v1.dtb \
|
+ bcm4708-linksys-ea6300-v1.dtb \
|
||||||
|
bcm4708-luxul-xap-1510.dtb \
|
||||||
bcm4708-luxul-xwc-1000.dtb \
|
bcm4708-luxul-xwc-1000.dtb \
|
||||||
bcm4708-netgear-r6250.dtb \
|
bcm4708-netgear-r6250.dtb \
|
||||||
bcm4708-netgear-r6300-v2.dtb \
|
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/arch/arm/boot/dts/bcm4708-linksys-ea6300-v1.dts
|
+++ b/arch/arm/boot/dts/bcm4708-linksys-ea6300-v1.dts
|
||||||
@@ -0,0 +1,48 @@
|
@@ -0,0 +1,48 @@
|
||||||
|
|
|
@ -70,47 +70,23 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
|
||||||
+};
|
+};
|
||||||
--- a/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
|
--- a/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
|
||||||
+++ b/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
|
+++ b/arch/arm/boot/dts/bcm4709-asus-rt-ac87u.dts
|
||||||
@@ -65,3 +65,8 @@
|
@@ -65,3 +65,7 @@
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
+
|
+
|
||||||
+&uart0 {
|
+&uart0 {
|
||||||
+ status = "okay";
|
+ status = "okay";
|
||||||
+ clock-frequency = <125000000>;
|
|
||||||
+};
|
+};
|
||||||
--- a/arch/arm/boot/dts/bcm4709-buffalo-wxr-1900dhp.dts
|
--- a/arch/arm/boot/dts/bcm4709-buffalo-wxr-1900dhp.dts
|
||||||
+++ b/arch/arm/boot/dts/bcm4709-buffalo-wxr-1900dhp.dts
|
+++ b/arch/arm/boot/dts/bcm4709-buffalo-wxr-1900dhp.dts
|
||||||
@@ -128,6 +128,10 @@
|
@@ -128,6 +128,9 @@
|
||||||
};
|
};
|
||||||
};
|
};
|
||||||
|
|
||||||
+&uart0 {
|
+&uart0 {
|
||||||
+ status = "okay";
|
+ status = "okay";
|
||||||
+ clock-frequency = <125000000>;
|
|
||||||
+};
|
+};
|
||||||
|
|
||||||
&usb2 {
|
&usb2 {
|
||||||
vcc-gpio = <&chipcommon 13 GPIO_ACTIVE_HIGH>;
|
vcc-gpio = <&chipcommon 13 GPIO_ACTIVE_HIGH>;
|
||||||
--- a/arch/arm/boot/dts/bcm4709-netgear-r8000.dts
|
|
||||||
+++ b/arch/arm/boot/dts/bcm4709-netgear-r8000.dts
|
|
||||||
@@ -108,6 +108,11 @@
|
|
||||||
};
|
|
||||||
};
|
|
||||||
|
|
||||||
+&uart0 {
|
|
||||||
+ status = "okay";
|
|
||||||
+ clock-frequency = <125000000>;
|
|
||||||
+};
|
|
||||||
+
|
|
||||||
&usb2 {
|
|
||||||
vcc-gpio = <&chipcommon 0 GPIO_ACTIVE_HIGH>;
|
|
||||||
};
|
|
||||||
--- a/arch/arm/boot/dts/bcm4709-netgear-r7000.dts
|
|
||||||
+++ b/arch/arm/boot/dts/bcm4709-netgear-r7000.dts
|
|
||||||
@@ -104,4 +104,5 @@
|
|
||||||
|
|
||||||
&uart0 {
|
|
||||||
status = "okay";
|
|
||||||
+ clock-frequency = <125000000>;
|
|
||||||
};
|
|
||||||
|
|
Loading…
Reference in a new issue