mbedtls: fix missing mbedtls_time_t bug in mbedtls 2.3.0
This backports a commit from mbedtls current git which adds missing include for platform.h. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
3e5b50a8a7
commit
d43075710b
2 changed files with 22 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mbedtls
|
PKG_NAME:=mbedtls
|
||||||
PKG_VERSION:=2.3.0
|
PKG_VERSION:=2.3.0
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
PKG_USE_MIPS16:=0
|
PKG_USE_MIPS16:=0
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
|
||||||
|
|
|
@ -0,0 +1,21 @@
|
||||||
|
From 7247f99b3e068a2b90b7776a2cdd438fddb7a38b Mon Sep 17 00:00:00 2001
|
||||||
|
From: James Cowgill <james410@cowgill.org.uk>
|
||||||
|
Date: Mon, 11 Jul 2016 13:57:05 +0100
|
||||||
|
Subject: [PATCH] Fixes missing dependency in ss.h on platform.h
|
||||||
|
|
||||||
|
Fixes #522 - 'mbedtls_time_t does not name a type in ssl.h'
|
||||||
|
---
|
||||||
|
include/mbedtls/ssl.h | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
--- a/include/mbedtls/ssl.h
|
||||||
|
+++ b/include/mbedtls/ssl.h
|
||||||
|
@@ -54,7 +54,7 @@
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#if defined(MBEDTLS_HAVE_TIME)
|
||||||
|
-#include <time.h>
|
||||||
|
+#include "platform.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/*
|
Loading…
Reference in a new issue