kernel: update 3.10 to 3.10.36
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 40467
This commit is contained in:
parent
17f848538c
commit
d2812cb036
34 changed files with 54 additions and 64 deletions
|
@ -17,8 +17,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.9.11)
|
||||
LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.10.34)
|
||||
LINUX_KERNEL_MD5SUM:=30991b495a3d75196d5608072d2e62e6
|
||||
ifeq ($(LINUX_VERSION),3.10.36)
|
||||
LINUX_KERNEL_MD5SUM:=721f76050755ec8ec88876ee350a2726
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.12.10)
|
||||
LINUX_KERNEL_MD5SUM:=93325074b7b1d7bb76fb7d4348f0aa7a
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs atm
|
|||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
SUBTARGETS:=generic ac49x
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=mips16
|
|||
CPU_TYPE=34kc
|
||||
SUBTARGETS:=generic nand mikrotik
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
|||
BOARDNAME:=Atheros AR231x/AR5312
|
||||
FEATURES:=squashfs
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
|
|||
FEATURES:=squashfs
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci pcie gpio
|
|||
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
|
||||
CPU_TYPE:=cortex-a9
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -31,7 +31,7 @@ The PHY says it is not connected by default, just ignore it.
|
|||
|
||||
static const struct bcma_device_id bgmac_bcma_tbl[] = {
|
||||
BCMA_CORE(BCMA_MANUF_BCM, BCMA_CORE_4706_MAC_GBIT, BCMA_ANY_REV, BCMA_ANY_CLASS),
|
||||
@@ -1438,7 +1442,7 @@ static int bgmac_probe(struct bcma_devic
|
||||
@@ -1452,7 +1456,7 @@ static int bgmac_probe(struct bcma_devic
|
||||
int err;
|
||||
|
||||
/* We don't support 2nd, 3rd, ... units, SPROM has to be adjusted */
|
||||
|
@ -40,7 +40,7 @@ The PHY says it is not connected by default, just ignore it.
|
|||
pr_err("Unsupported core_unit %d\n", core->core_unit);
|
||||
return -ENOTSUPP;
|
||||
}
|
||||
@@ -1473,8 +1477,7 @@ static int bgmac_probe(struct bcma_devic
|
||||
@@ -1487,8 +1491,7 @@ static int bgmac_probe(struct bcma_devic
|
||||
}
|
||||
bgmac->cmn = core->bus->drv_gmac_cmn.core;
|
||||
|
||||
|
@ -50,7 +50,7 @@ The PHY says it is not connected by default, just ignore it.
|
|||
bgmac->phyaddr &= BGMAC_PHY_MASK;
|
||||
if (bgmac->phyaddr == BGMAC_PHY_MASK) {
|
||||
bgmac_err(bgmac, "No PHY found\n");
|
||||
@@ -1526,8 +1529,7 @@ static int bgmac_probe(struct bcma_devic
|
||||
@@ -1540,8 +1543,7 @@ static int bgmac_probe(struct bcma_devic
|
||||
/* TODO: reset the external phy. Specs are needed */
|
||||
bgmac_phy_reset(bgmac);
|
||||
|
||||
|
|
|
@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
|||
CPU_TYPE:=arm1176jzf-s
|
||||
CPU_SUBTYPE:=vfp
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM47xx/53xx (MIPS)
|
|||
FEATURES:=squashfs usb pcmcia
|
||||
MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += swconfig wpad-mini nvram \
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=brcm63xx
|
|||
BOARDNAME:=Broadcom BCM63xx
|
||||
SUBTARGETS:=generic smp
|
||||
FEATURES:=squashfs usb atm pci pcmcia usbgadget
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
|
|||
FEATURES:=squashfs
|
||||
CPU_TYPE:=fa526
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
|
|||
CPU_SUBTYPE:=neon
|
||||
MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
SUBTARGETS=generic harddisk
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2_nand ubifs
|
|||
CPU_TYPE:=xscale
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARDNAME:=Lantiq
|
|||
FEATURES:=squashfs ubifs
|
||||
SUBTARGETS=xway xrx200
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
CPU_TYPE:=mips32r2
|
||||
|
||||
|
|
|
@ -4,10 +4,8 @@ Date: Sun, 14 Jul 2013 22:26:43 +0200
|
|||
Subject: add basic tffs driver
|
||||
|
||||
---
|
||||
Index: linux-3.10.13/arch/mips/lantiq/xway/Makefile
|
||||
===================================================================
|
||||
--- linux-3.10.13.orig/arch/mips/lantiq/xway/Makefile 2013-09-29 00:18:30.164765435 +0200
|
||||
+++ linux-3.10.13/arch/mips/lantiq/xway/Makefile 2013-09-29 00:18:30.216765439 +0200
|
||||
--- a/arch/mips/lantiq/xway/Makefile
|
||||
+++ b/arch/mips/lantiq/xway/Makefile
|
||||
@@ -1,6 +1,6 @@
|
||||
obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
|
||||
|
||||
|
@ -16,10 +14,8 @@ Index: linux-3.10.13/arch/mips/lantiq/xway/Makefile
|
|||
|
||||
obj-$(CONFIG_PCI) += ath_eep.o rt_eep.o pci-ath-fixup.o
|
||||
|
||||
Index: linux-3.10.13/arch/mips/lantiq/xway/tffs.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ linux-3.10.13/arch/mips/lantiq/xway/tffs.c 2013-09-29 00:37:17.712792305 +0200
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/lantiq/xway/tffs.c
|
||||
@@ -0,0 +1,87 @@
|
||||
+#include <linux/module.h>
|
||||
+#include <linux/mtd/mtd.h>
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
Index: linux-3.10.34/drivers/mtd/nand/xway_nand.c
|
||||
===================================================================
|
||||
--- linux-3.10.34.orig/drivers/mtd/nand/xway_nand.c 2014-03-28 11:51:49.790953906 +0000
|
||||
+++ linux-3.10.34/drivers/mtd/nand/xway_nand.c 2014-03-28 15:45:08.196369790 +0000
|
||||
@@ -80,13 +80,16 @@
|
||||
--- a/drivers/mtd/nand/xway_nand.c
|
||||
+++ b/drivers/mtd/nand/xway_nand.c
|
||||
@@ -80,13 +80,16 @@ static void xway_reset_chip(struct nand_
|
||||
|
||||
static void xway_select_chip(struct mtd_info *mtd, int chip)
|
||||
{
|
||||
|
|
|
@ -9,8 +9,8 @@ Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com>
|
|||
lantiq-flash.c | 11 ++++++++++-
|
||||
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
--- a/drivers/mtd/maps/lantiq-flash.c 2014-03-23 09:18:25.099370216 +0100
|
||||
+++ b/drivers/mtd/maps/lantiq-flash.c 2014-03-19 17:19:45.732111306 +0100
|
||||
--- a/drivers/mtd/maps/lantiq-flash.c
|
||||
+++ b/drivers/mtd/maps/lantiq-flash.c
|
||||
@@ -117,6 +117,11 @@ ltq_mtd_probe(struct platform_device *pd
|
||||
struct cfi_private *cfi;
|
||||
int err;
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
Index: linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c
|
||||
===================================================================
|
||||
--- linux-3.10.34.orig/arch/mips/lantiq/xway/ath_eep.c 2014-04-03 13:25:03.128464891 +0100
|
||||
+++ linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c 2014-04-03 13:35:30.432482868 +0100
|
||||
@@ -36,10 +36,11 @@
|
||||
--- a/arch/mips/lantiq/xway/ath_eep.c
|
||||
+++ b/arch/mips/lantiq/xway/ath_eep.c
|
||||
@@ -36,10 +36,11 @@ static int ath9k_pci_plat_dev_init(struc
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
@ -15,7 +13,7 @@ Index: linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c
|
|||
u32 mac_inc = 0, pci_slot = 0;
|
||||
int i;
|
||||
struct mtd_info *the_mtd;
|
||||
@@ -112,6 +113,18 @@
|
||||
@@ -112,6 +113,18 @@ int __init of_ath9k_eeprom_probe(struct
|
||||
if (!of_property_read_u32(np, "ath,pci-slot", &pci_slot)) {
|
||||
ltq_pci_ath_fixup(pci_slot, ath9k_pdata.eeprom_data);
|
||||
dev_info(&pdev->dev, "pci slot: %u\n", pci_slot);
|
||||
|
@ -34,7 +32,7 @@ Index: linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c
|
|||
}
|
||||
|
||||
dev_info(&pdev->dev, "loaded ath9k eeprom\n");
|
||||
@@ -132,20 +145,19 @@
|
||||
@@ -132,20 +145,19 @@ static struct platform_driver ath9k_eepr
|
||||
},
|
||||
};
|
||||
|
||||
|
@ -58,7 +56,7 @@ Index: linux-3.10.34/arch/mips/lantiq/xway/ath_eep.c
|
|||
return 0;
|
||||
return platform_driver_probe(&ath9k_eeprom_driver, of_ath9k_eeprom_probe);
|
||||
}
|
||||
@@ -247,4 +259,4 @@
|
||||
@@ -247,4 +259,4 @@ static int __init of_ath5k_eeprom_init(v
|
||||
{
|
||||
return platform_driver_probe(&ath5k_eeprom_driver, of_ath5k_eeprom_probe);
|
||||
}
|
||||
|
|
|
@ -22,8 +22,8 @@ Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com>
|
|||
---
|
||||
|
||||
|
||||
--- a/drivers/mtd/nand/xway_nand.c 2014-04-01 20:14:53.072824371 +0200
|
||||
+++ b/drivers/mtd/nand/xway_nand.c 2014-04-01 21:24:52.798612391 +0200
|
||||
--- a/drivers/mtd/nand/xway_nand.c
|
||||
+++ b/drivers/mtd/nand/xway_nand.c
|
||||
@@ -102,7 +102,6 @@ static void xway_cmd_ctrl(struct mtd_inf
|
||||
{
|
||||
struct nand_chip *this = mtd->priv;
|
||||
|
|
|
@ -20,8 +20,8 @@ Signed-off-by: Ben Mulvihill <ben.mulvihill@gmail.com>
|
|||
---
|
||||
|
||||
|
||||
--- a/drivers/mtd/nand/xway_nand.c 2014-04-01 21:24:52.798612391 +0200
|
||||
+++ a/drivers/mtd/nand/xway_nand.c 2014-04-01 21:20:33.924585096 +0200
|
||||
--- a/drivers/mtd/nand/xway_nand.c
|
||||
+++ b/drivers/mtd/nand/xway_nand.c
|
||||
@@ -54,8 +54,27 @@
|
||||
#define NAND_CON_CSMUX (1 << 1)
|
||||
#define NAND_CON_NANDM 1
|
||||
|
|
|
@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
|
|||
INITRAMFS_EXTRA_FILES:=
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
|
|||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
SUBTARGETS=generic p1020
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
|
|||
CPU_SUBTYPE:=vfpv3
|
||||
MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -14,7 +14,7 @@ CPU_TYPE:=octeon
|
|||
CPU_CFLAGS_octeon:=-march=octeon
|
||||
MAINTAINER:=John Crispin <blogic@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs
|
|||
CPU_TYPE:=405
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs broken
|
|||
CPU_TYPE:=440
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
|
|||
SUBTARGETS:=rt305x mt7620a mt7620n mt7621 rt3883 rt288x
|
||||
FEATURES:=squashfs gpio
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=\
|
||||
|
|
|
@ -8,11 +8,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||
drivers/mtd/devices/m25p80.c | 127 ++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 127 insertions(+)
|
||||
|
||||
Index: linux-3.10.34/drivers/mtd/devices/m25p80.c
|
||||
===================================================================
|
||||
--- linux-3.10.34.orig/drivers/mtd/devices/m25p80.c 2014-03-30 19:40:10.135292951 +0100
|
||||
+++ linux-3.10.34/drivers/mtd/devices/m25p80.c 2014-03-30 19:44:40.151295482 +0100
|
||||
@@ -392,6 +392,58 @@
|
||||
--- a/drivers/mtd/devices/m25p80.c
|
||||
+++ b/drivers/mtd/devices/m25p80.c
|
||||
@@ -392,6 +392,58 @@ static int m25p80_read(struct mtd_info *
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
@ -71,7 +69,7 @@ Index: linux-3.10.34/drivers/mtd/devices/m25p80.c
|
|||
/*
|
||||
* Write an address range to the flash chip. Data must be written in
|
||||
* FLASH_PAGESIZE chunks. The address range may be any size provided
|
||||
@@ -479,6 +531,76 @@
|
||||
@@ -479,6 +531,76 @@ static int m25p80_write(struct mtd_info
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
@ -148,7 +146,7 @@ Index: linux-3.10.34/drivers/mtd/devices/m25p80.c
|
|||
static int sst_write(struct mtd_info *mtd, loff_t to, size_t len,
|
||||
size_t *retlen, const u_char *buf)
|
||||
{
|
||||
@@ -1058,6 +1180,12 @@
|
||||
@@ -1058,6 +1180,12 @@ static int m25p_probe(struct spi_device
|
||||
flash->fast_read = true;
|
||||
#endif
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
|||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=pci targz broken
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
|
||||
|
|
|
@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
|
|||
CPU_SUBTYPE:=vfp
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
DEVICE_TYPE:=developerboard
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=sparc
|
|||
BOARDNAME:=Sun UltraSPARC
|
||||
FEATURES+=fpu tgz ext4 squashfs broken
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
|
|||
SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
|
||||
rdc
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
KERNELNAME:=bzImage
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
|
|||
FEATURES:=targz ubifs audio
|
||||
SUBTARGETS:=qi_lb60 n516 n526 id800wt
|
||||
|
||||
LINUX_VERSION:=3.10.34
|
||||
LINUX_VERSION:=3.10.36
|
||||
|
||||
DEVICE_TYPE=other
|
||||
|
||||
|
|
Loading…
Reference in a new issue