ar7: refresh patches

SVN-Revision: 11452
This commit is contained in:
Matteo Croce 2008-06-12 22:33:48 +00:00
parent e8a8d5811d
commit d1c097e3d0
12 changed files with 80 additions and 122 deletions

View file

@ -1,8 +1,6 @@
Index: linux-2.6.25.4/arch/mips/Kconfig --- a/arch/mips/Kconfig
=================================================================== +++ b/arch/mips/Kconfig
--- linux-2.6.25.4.orig/arch/mips/Kconfig @@ -18,6 +18,24 @@
+++ linux-2.6.25.4/arch/mips/Kconfig
@@ -18,6 +18,24 @@ choice
prompt "System type" prompt "System type"
default SGI_IP22 default SGI_IP22
@ -27,11 +25,9 @@ Index: linux-2.6.25.4/arch/mips/Kconfig
config MACH_ALCHEMY config MACH_ALCHEMY
bool "Alchemy processor based machines" bool "Alchemy processor based machines"
Index: linux-2.6.25.4/arch/mips/kernel/traps.c --- a/arch/mips/kernel/traps.c
=================================================================== +++ b/arch/mips/kernel/traps.c
--- linux-2.6.25.4.orig/arch/mips/kernel/traps.c @@ -1112,9 +1112,22 @@
+++ linux-2.6.25.4/arch/mips/kernel/traps.c
@@ -1112,9 +1112,22 @@ void *set_except_vector(int n, void *add
exception_handlers[n] = handler; exception_handlers[n] = handler;
if (n == 0 && cpu_has_divec) { if (n == 0 && cpu_has_divec) {
@ -57,11 +53,9 @@ Index: linux-2.6.25.4/arch/mips/kernel/traps.c
} }
return (void *)old_handler; return (void *)old_handler;
} }
Index: linux-2.6.25.4/arch/mips/Makefile --- a/arch/mips/Makefile
=================================================================== +++ b/arch/mips/Makefile
--- linux-2.6.25.4.orig/arch/mips/Makefile @@ -167,6 +167,13 @@
+++ linux-2.6.25.4/arch/mips/Makefile
@@ -167,6 +167,13 @@ libs-$(CONFIG_SIBYTE_CFE) += arch/mips/s
# #
# #
@ -75,11 +69,9 @@ Index: linux-2.6.25.4/arch/mips/Makefile
# Acer PICA 61, Mips Magnum 4000 and Olivetti M700. # Acer PICA 61, Mips Magnum 4000 and Olivetti M700.
# #
core-$(CONFIG_MACH_JAZZ) += arch/mips/jazz/ core-$(CONFIG_MACH_JAZZ) += arch/mips/jazz/
Index: linux-2.6.25.4/include/asm-mips/page.h --- a/include/asm-mips/page.h
=================================================================== +++ b/include/asm-mips/page.h
--- linux-2.6.25.4.orig/include/asm-mips/page.h @@ -182,8 +182,10 @@
+++ linux-2.6.25.4/include/asm-mips/page.h
@@ -182,8 +182,10 @@ typedef struct { unsigned long pgprot; }
#define VM_DATA_DEFAULT_FLAGS (VM_READ | VM_WRITE | VM_EXEC | \ #define VM_DATA_DEFAULT_FLAGS (VM_READ | VM_WRITE | VM_EXEC | \
VM_MAYREAD | VM_MAYWRITE | VM_MAYEXEC) VM_MAYREAD | VM_MAYWRITE | VM_MAYEXEC)

View file

@ -1,8 +1,6 @@
Index: linux-2.6.25.4/drivers/mtd/Kconfig --- a/drivers/mtd/Kconfig
=================================================================== +++ b/drivers/mtd/Kconfig
--- linux-2.6.25.4.orig/drivers/mtd/Kconfig @@ -168,6 +168,12 @@
+++ linux-2.6.25.4/drivers/mtd/Kconfig
@@ -168,6 +168,12 @@ config MTD_OF_PARTS
the partition map from the children of the flash node, the partition map from the children of the flash node,
as described in Documentation/powerpc/booting-without-of.txt. as described in Documentation/powerpc/booting-without-of.txt.
@ -15,11 +13,9 @@ Index: linux-2.6.25.4/drivers/mtd/Kconfig
comment "User Modules And Translation Layers" comment "User Modules And Translation Layers"
config MTD_CHAR config MTD_CHAR
Index: linux-2.6.25.4/drivers/mtd/Makefile --- a/drivers/mtd/Makefile
=================================================================== +++ b/drivers/mtd/Makefile
--- linux-2.6.25.4.orig/drivers/mtd/Makefile @@ -12,6 +12,7 @@
+++ linux-2.6.25.4/drivers/mtd/Makefile
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
@ -27,11 +23,9 @@ Index: linux-2.6.25.4/drivers/mtd/Makefile
# 'Users' - code which presents functionality to userspace. # 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o obj-$(CONFIG_MTD_CHAR) += mtdchar.o
Index: linux-2.6.25.4/drivers/mtd/maps/physmap.c --- a/drivers/mtd/maps/physmap.c
=================================================================== +++ b/drivers/mtd/maps/physmap.c
--- linux-2.6.25.4.orig/drivers/mtd/maps/physmap.c @@ -87,7 +87,8 @@
+++ linux-2.6.25.4/drivers/mtd/maps/physmap.c
@@ -87,7 +87,8 @@ static int physmap_flash_remove(struct p
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL }; static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS #ifdef CONFIG_MTD_PARTITIONS

View file

@ -1,8 +1,6 @@
Index: linux-2.6.25.4/drivers/char/Kconfig --- a/drivers/char/Kconfig
=================================================================== +++ b/drivers/char/Kconfig
--- linux-2.6.25.4.orig/drivers/char/Kconfig @@ -913,6 +913,15 @@
+++ linux-2.6.25.4/drivers/char/Kconfig
@@ -913,6 +913,15 @@ config MWAVE
To compile this driver as a module, choose M here: the To compile this driver as a module, choose M here: the
module will be called mwave. module will be called mwave.
@ -18,11 +16,9 @@ Index: linux-2.6.25.4/drivers/char/Kconfig
config SCx200_GPIO config SCx200_GPIO
tristate "NatSemi SCx200 GPIO Support" tristate "NatSemi SCx200 GPIO Support"
depends on SCx200 depends on SCx200
Index: linux-2.6.25.4/drivers/char/Makefile --- a/drivers/char/Makefile
=================================================================== +++ b/drivers/char/Makefile
--- linux-2.6.25.4.orig/drivers/char/Makefile @@ -90,6 +90,7 @@
+++ linux-2.6.25.4/drivers/char/Makefile
@@ -90,6 +90,7 @@ obj-$(CONFIG_COBALT_LCD) += lcd.o
obj-$(CONFIG_PPDEV) += ppdev.o obj-$(CONFIG_PPDEV) += ppdev.o
obj-$(CONFIG_NWBUTTON) += nwbutton.o obj-$(CONFIG_NWBUTTON) += nwbutton.o
obj-$(CONFIG_NWFLASH) += nwflash.o obj-$(CONFIG_NWFLASH) += nwflash.o

View file

@ -1,19 +1,15 @@
Index: linux-2.6.25.4/drivers/Kconfig --- a/drivers/Kconfig
=================================================================== +++ b/drivers/Kconfig
--- linux-2.6.25.4.orig/drivers/Kconfig @@ -97,4 +97,6 @@
+++ linux-2.6.25.4/drivers/Kconfig
@@ -97,4 +97,6 @@ source "drivers/dca/Kconfig"
source "drivers/auxdisplay/Kconfig" source "drivers/auxdisplay/Kconfig"
source "drivers/uio/Kconfig" source "drivers/uio/Kconfig"
+ +
+source "drivers/vlynq/Kconfig" +source "drivers/vlynq/Kconfig"
endmenu endmenu
Index: linux-2.6.25.4/drivers/Makefile --- a/drivers/Makefile
=================================================================== +++ b/drivers/Makefile
--- linux-2.6.25.4.orig/drivers/Makefile @@ -91,5 +91,6 @@
+++ linux-2.6.25.4/drivers/Makefile
@@ -91,5 +91,6 @@ obj-$(CONFIG_DCA) += dca/
obj-$(CONFIG_HID) += hid/ obj-$(CONFIG_HID) += hid/
obj-$(CONFIG_PPC_PS3) += ps3/ obj-$(CONFIG_PPC_PS3) += ps3/
obj-$(CONFIG_OF) += of/ obj-$(CONFIG_OF) += of/

View file

@ -1,7 +1,5 @@
Index: linux-2.6.25.4/drivers/net/cpmac.c --- a/drivers/net/cpmac.c
=================================================================== +++ b/drivers/net/cpmac.c
--- linux-2.6.25.4.orig/drivers/net/cpmac.c
+++ linux-2.6.25.4/drivers/net/cpmac.c
@@ -38,6 +38,7 @@ @@ -38,6 +38,7 @@
#include <linux/platform_device.h> #include <linux/platform_device.h>
#include <linux/dma-mapping.h> #include <linux/dma-mapping.h>
@ -10,7 +8,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
MODULE_AUTHOR("Eugene Konev <ejka@imfi.kspu.ru>"); MODULE_AUTHOR("Eugene Konev <ejka@imfi.kspu.ru>");
MODULE_DESCRIPTION("TI AR7 ethernet driver (CPMAC)"); MODULE_DESCRIPTION("TI AR7 ethernet driver (CPMAC)");
@@ -207,6 +208,7 @@ struct cpmac_priv { @@ -207,6 +208,7 @@
struct work_struct reset_work; struct work_struct reset_work;
struct platform_device *pdev; struct platform_device *pdev;
struct napi_struct napi; struct napi_struct napi;
@ -18,7 +16,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
}; };
static irqreturn_t cpmac_irq(int, void *); static irqreturn_t cpmac_irq(int, void *);
@@ -455,6 +457,9 @@ static int cpmac_start_xmit(struct sk_bu @@ -455,6 +457,9 @@
struct cpmac_desc *desc; struct cpmac_desc *desc;
struct cpmac_priv *priv = netdev_priv(dev); struct cpmac_priv *priv = netdev_priv(dev);
@ -28,7 +26,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
if (unlikely(skb_padto(skb, ETH_ZLEN))) if (unlikely(skb_padto(skb, ETH_ZLEN)))
return NETDEV_TX_OK; return NETDEV_TX_OK;
@@ -634,14 +639,14 @@ static void cpmac_clear_tx(struct net_de @@ -634,14 +639,14 @@
priv->desc_ring[i].dataflags = 0; priv->desc_ring[i].dataflags = 0;
if (priv->desc_ring[i].skb) { if (priv->desc_ring[i].skb) {
dev_kfree_skb_any(priv->desc_ring[i].skb); dev_kfree_skb_any(priv->desc_ring[i].skb);
@ -45,7 +43,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
struct cpmac_priv *priv = struct cpmac_priv *priv =
container_of(work, struct cpmac_priv, reset_work); container_of(work, struct cpmac_priv, reset_work);
@@ -650,8 +655,47 @@ static void cpmac_hw_error(struct work_s @@ -650,8 +655,47 @@
spin_unlock(&priv->rx_lock); spin_unlock(&priv->rx_lock);
cpmac_clear_tx(priv->dev); cpmac_clear_tx(priv->dev);
cpmac_hw_start(priv->dev); cpmac_hw_start(priv->dev);
@ -95,7 +93,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
} }
static irqreturn_t cpmac_irq(int irq, void *dev_id) static irqreturn_t cpmac_irq(int irq, void *dev_id)
@@ -682,49 +726,33 @@ static irqreturn_t cpmac_irq(int irq, vo @@ -682,49 +726,33 @@
cpmac_write(priv->regs, CPMAC_MAC_EOI_VECTOR, 0); cpmac_write(priv->regs, CPMAC_MAC_EOI_VECTOR, 0);
@ -159,7 +157,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
} }
static int cpmac_ioctl(struct net_device *dev, struct ifreq *ifr, int cmd) static int cpmac_ioctl(struct net_device *dev, struct ifreq *ifr, int cmd)
@@ -911,6 +939,7 @@ static int cpmac_open(struct net_device @@ -911,6 +939,7 @@
goto fail_irq; goto fail_irq;
} }

View file

@ -1,8 +1,6 @@
Index: linux-2.6.25.4/drivers/net/Kconfig --- a/drivers/net/Kconfig
=================================================================== +++ b/drivers/net/Kconfig
--- linux-2.6.25.4.orig/drivers/net/Kconfig @@ -1874,7 +1874,7 @@
+++ linux-2.6.25.4/drivers/net/Kconfig
@@ -1874,7 +1874,7 @@ config SC92031
config CPMAC config CPMAC
tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)" tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)"

View file

@ -13,10 +13,8 @@ Signed-off-by: Anton Vorontsov <avorontsov@ru.mvista.com>
drivers/net/cpmac.c | 19 +++---------------- drivers/net/cpmac.c | 19 +++----------------
2 files changed, 20 insertions(+), 16 deletions(-) 2 files changed, 20 insertions(+), 16 deletions(-)
Index: linux-2.6.25.4/arch/mips/ar7/platform.c --- a/arch/mips/ar7/platform.c
=================================================================== +++ b/arch/mips/ar7/platform.c
--- linux-2.6.25.4.orig/arch/mips/ar7/platform.c
+++ linux-2.6.25.4/arch/mips/ar7/platform.c
@@ -33,6 +33,8 @@ @@ -33,6 +33,8 @@
#include <linux/vlynq.h> #include <linux/vlynq.h>
#include <linux/leds.h> #include <linux/leds.h>
@ -26,7 +24,7 @@ Index: linux-2.6.25.4/arch/mips/ar7/platform.c
#include <asm/addrspace.h> #include <asm/addrspace.h>
#include <asm/ar7/ar7.h> #include <asm/ar7/ar7.h>
@@ -205,6 +207,13 @@ static struct physmap_flash_data physmap @@ -205,6 +207,13 @@
.width = 2, .width = 2,
}; };
@ -40,7 +38,7 @@ Index: linux-2.6.25.4/arch/mips/ar7/platform.c
static struct plat_cpmac_data cpmac_low_data = { static struct plat_cpmac_data cpmac_low_data = {
.reset_bit = 17, .reset_bit = 17,
.power_bit = 20, .power_bit = 20,
@@ -506,6 +515,10 @@ static int __init ar7_register_devices(v @@ -506,6 +515,10 @@
} }
if (ar7_has_high_cpmac()) { if (ar7_has_high_cpmac()) {
@ -51,7 +49,7 @@ Index: linux-2.6.25.4/arch/mips/ar7/platform.c
cpmac_get_mac(1, cpmac_high_data.dev_addr); cpmac_get_mac(1, cpmac_high_data.dev_addr);
res = platform_device_register(&cpmac_high); res = platform_device_register(&cpmac_high);
if (res) if (res)
@@ -514,6 +527,10 @@ static int __init ar7_register_devices(v @@ -514,6 +527,10 @@
cpmac_low_data.phy_mask = 0xffffffff; cpmac_low_data.phy_mask = 0xffffffff;
} }
@ -62,11 +60,9 @@ Index: linux-2.6.25.4/arch/mips/ar7/platform.c
cpmac_get_mac(0, cpmac_low_data.dev_addr); cpmac_get_mac(0, cpmac_low_data.dev_addr);
res = platform_device_register(&cpmac_low); res = platform_device_register(&cpmac_low);
if (res) if (res)
Index: linux-2.6.25.4/drivers/net/cpmac.c --- a/drivers/net/cpmac.c
=================================================================== +++ b/drivers/net/cpmac.c
--- linux-2.6.25.4.orig/drivers/net/cpmac.c @@ -1035,23 +1035,10 @@
+++ linux-2.6.25.4/drivers/net/cpmac.c
@@ -1035,23 +1035,10 @@ static int __devinit cpmac_probe(struct
if (phy_id == PHY_MAX_ADDR) { if (phy_id == PHY_MAX_ADDR) {
if (external_switch || dumb_switch) { if (external_switch || dumb_switch) {

View file

@ -1,8 +1,6 @@
Index: linux-2.6.25.4/drivers/net/cpmac.c --- a/drivers/net/cpmac.c
=================================================================== +++ b/drivers/net/cpmac.c
--- linux-2.6.25.4.orig/drivers/net/cpmac.c @@ -187,6 +187,7 @@
+++ linux-2.6.25.4/drivers/net/cpmac.c
@@ -187,6 +187,7 @@ struct cpmac_desc {
#define CPMAC_EOQ 0x1000 #define CPMAC_EOQ 0x1000
struct sk_buff *skb; struct sk_buff *skb;
struct cpmac_desc *next; struct cpmac_desc *next;
@ -10,7 +8,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
dma_addr_t mapping; dma_addr_t mapping;
dma_addr_t data_mapping; dma_addr_t data_mapping;
}; };
@@ -242,6 +243,16 @@ static void cpmac_dump_desc(struct net_d @@ -242,6 +243,16 @@
printk("\n"); printk("\n");
} }
@ -27,7 +25,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
static void cpmac_dump_skb(struct net_device *dev, struct sk_buff *skb) static void cpmac_dump_skb(struct net_device *dev, struct sk_buff *skb)
{ {
int i; int i;
@@ -413,21 +424,40 @@ static struct sk_buff *cpmac_rx_one(stru @@ -413,21 +424,40 @@
static int cpmac_poll(struct napi_struct *napi, int budget) static int cpmac_poll(struct napi_struct *napi, int budget)
{ {
struct sk_buff *skb; struct sk_buff *skb;
@ -70,7 +68,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
skb = cpmac_rx_one(priv, desc); skb = cpmac_rx_one(priv, desc);
if (likely(skb)) { if (likely(skb)) {
netif_receive_skb(skb); netif_receive_skb(skb);
@@ -436,19 +466,81 @@ static int cpmac_poll(struct napi_struct @@ -436,19 +466,81 @@
desc = desc->next; desc = desc->next;
} }
@ -154,7 +152,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
} }
static int cpmac_start_xmit(struct sk_buff *skb, struct net_device *dev) static int cpmac_start_xmit(struct sk_buff *skb, struct net_device *dev)
@@ -625,8 +717,10 @@ static void cpmac_clear_rx(struct net_de @@ -625,8 +717,10 @@
desc->dataflags = CPMAC_OWN; desc->dataflags = CPMAC_OWN;
dev->stats.rx_dropped++; dev->stats.rx_dropped++;
} }
@ -165,7 +163,7 @@ Index: linux-2.6.25.4/drivers/net/cpmac.c
} }
static void cpmac_clear_tx(struct net_device *dev) static void cpmac_clear_tx(struct net_device *dev)
@@ -928,9 +1022,12 @@ static int cpmac_open(struct net_device @@ -928,9 +1022,12 @@
desc->buflen = CPMAC_SKB_SIZE; desc->buflen = CPMAC_SKB_SIZE;
desc->dataflags = CPMAC_OWN; desc->dataflags = CPMAC_OWN;
desc->next = &priv->rx_head[(i + 1) % priv->ring_size]; desc->next = &priv->rx_head[(i + 1) % priv->ring_size];

View file

@ -1,8 +1,6 @@
Index: linux-2.6.25.4/drivers/net/cpmac.c --- a/drivers/net/cpmac.c
=================================================================== +++ b/drivers/net/cpmac.c
--- linux-2.6.25.4.orig/drivers/net/cpmac.c @@ -1178,9 +1178,7 @@
+++ linux-2.6.25.4/drivers/net/cpmac.c
@@ -1178,9 +1178,7 @@ static int __devinit cpmac_probe(struct
priv->msg_enable = netif_msg_init(debug_level, 0xff); priv->msg_enable = netif_msg_init(debug_level, 0xff);
memcpy(dev->dev_addr, pdata->dev_addr, sizeof(dev->dev_addr)); memcpy(dev->dev_addr, pdata->dev_addr, sizeof(dev->dev_addr));

View file

@ -1,7 +1,5 @@
Index: linux-2.6.25.4/drivers/mtd/ar7part.c --- a/drivers/mtd/ar7part.c
=================================================================== +++ b/drivers/mtd/ar7part.c
--- linux-2.6.25.4.orig/drivers/mtd/ar7part.c
+++ linux-2.6.25.4/drivers/mtd/ar7part.c
@@ -34,6 +34,10 @@ @@ -34,6 +34,10 @@
#define LOADER_MAGIC1 le32_to_cpu(0xfeedfa42) #define LOADER_MAGIC1 le32_to_cpu(0xfeedfa42)
#define LOADER_MAGIC2 le32_to_cpu(0xfeed1281) #define LOADER_MAGIC2 le32_to_cpu(0xfeed1281)
@ -13,7 +11,7 @@ Index: linux-2.6.25.4/drivers/mtd/ar7part.c
struct ar7_bin_rec { struct ar7_bin_rec {
unsigned int checksum; unsigned int checksum;
unsigned int length; unsigned int length;
@@ -47,7 +51,8 @@ static int create_mtd_partitions(struct @@ -47,7 +51,8 @@
unsigned long origin) unsigned long origin)
{ {
struct ar7_bin_rec header; struct ar7_bin_rec header;
@ -23,7 +21,7 @@ Index: linux-2.6.25.4/drivers/mtd/ar7part.c
unsigned int pre_size = master->erasesize, post_size = 0; unsigned int pre_size = master->erasesize, post_size = 0;
unsigned int root_offset = ROOT_OFFSET; unsigned int root_offset = ROOT_OFFSET;
@@ -66,7 +71,7 @@ static int create_mtd_partitions(struct @@ -66,7 +71,7 @@
do { /* Try 10 blocks starting from master->erasesize */ do { /* Try 10 blocks starting from master->erasesize */
offset = pre_size; offset = pre_size;
master->read(master, offset, master->read(master, offset,
@ -32,7 +30,7 @@ Index: linux-2.6.25.4/drivers/mtd/ar7part.c
if (!strncmp((char *)&header, "TIENV0.8", 8)) if (!strncmp((char *)&header, "TIENV0.8", 8))
ar7_parts[1].offset = pre_size; ar7_parts[1].offset = pre_size;
if (header.checksum == LOADER_MAGIC1) if (header.checksum == LOADER_MAGIC1)
@@ -88,7 +93,7 @@ static int create_mtd_partitions(struct @@ -88,7 +93,7 @@
while (header.length) { while (header.length) {
offset += sizeof(header) + header.length; offset += sizeof(header) + header.length;
master->read(master, offset, sizeof(header), master->read(master, offset, sizeof(header),
@ -41,7 +39,7 @@ Index: linux-2.6.25.4/drivers/mtd/ar7part.c
} }
root_offset = offset + sizeof(header) + 4; root_offset = offset + sizeof(header) + 4;
break; break;
@@ -96,10 +101,10 @@ static int create_mtd_partitions(struct @@ -96,10 +101,10 @@
while (header.length) { while (header.length) {
offset += sizeof(header) + header.length; offset += sizeof(header) + header.length;
master->read(master, offset, sizeof(header), master->read(master, offset, sizeof(header),

View file

@ -1,8 +1,6 @@
Index: linux-2.6.25.4/drivers/serial/8250.c --- a/drivers/serial/8250.c
=================================================================== +++ b/drivers/serial/8250.c
--- linux-2.6.25.4.orig/drivers/serial/8250.c @@ -267,6 +267,13 @@
+++ linux-2.6.25.4/drivers/serial/8250.c
@@ -267,6 +267,13 @@ static const struct serial8250_config ua
.fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10, .fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10,
.flags = UART_CAP_FIFO, .flags = UART_CAP_FIFO,
}, },
@ -16,7 +14,7 @@ Index: linux-2.6.25.4/drivers/serial/8250.c
}; };
#if defined (CONFIG_SERIAL_8250_AU1X00) #if defined (CONFIG_SERIAL_8250_AU1X00)
@@ -2455,7 +2462,11 @@ static void serial8250_console_putchar(s @@ -2455,7 +2462,11 @@
{ {
struct uart_8250_port *up = (struct uart_8250_port *)port; struct uart_8250_port *up = (struct uart_8250_port *)port;
@ -28,10 +26,8 @@ Index: linux-2.6.25.4/drivers/serial/8250.c
serial_out(up, UART_TX, ch); serial_out(up, UART_TX, ch);
} }
Index: linux-2.6.25.4/include/linux/serial_core.h --- a/include/linux/serial_core.h
=================================================================== +++ b/include/linux/serial_core.h
--- linux-2.6.25.4.orig/include/linux/serial_core.h
+++ linux-2.6.25.4/include/linux/serial_core.h
@@ -40,7 +40,8 @@ @@ -40,7 +40,8 @@
#define PORT_NS16550A 14 #define PORT_NS16550A 14
#define PORT_XSCALE 15 #define PORT_XSCALE 15

View file

@ -1,18 +1,16 @@
Index: linux-2.6.25.4/drivers/net/cpmac.c --- a/drivers/net/cpmac.c
=================================================================== +++ b/drivers/net/cpmac.c
--- linux-2.6.25.4.orig/drivers/net/cpmac.c @@ -947,7 +947,8 @@
+++ linux-2.6.25.4/drivers/net/cpmac.c
@@ -936,7 +936,8 @@ static void cpmac_adjust_link(struct net
int new_state = 0; int new_state = 0;
spin_lock(&priv->lock); spin_lock(&priv->lock);
- if (priv->phy->link) { - if (priv->phy->link) {
+ if (1 /* priv->phy->link */ ) { + if (1 /* priv->phy->link */) {
+ netif_carrier_on(dev); + netif_carrier_on(dev);
netif_start_queue(dev); netif_start_queue(dev);
if (priv->phy->duplex != priv->oldduplex) { if (priv->phy->duplex != priv->oldduplex) {
new_state = 1; new_state = 1;
@@ -948,11 +949,11 @@ static void cpmac_adjust_link(struct net @@ -959,11 +960,11 @@
priv->oldspeed = priv->phy->speed; priv->oldspeed = priv->phy->speed;
} }