busybox: fix hexdump segmentation fault with an empty leading format unit
SVN-Revision: 29156
This commit is contained in:
parent
817c72ef02
commit
d0f5b51a8b
2 changed files with 14 additions and 1 deletions
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=busybox
|
PKG_NAME:=busybox
|
||||||
PKG_VERSION:=1.19.3
|
PKG_VERSION:=1.19.3
|
||||||
PKG_RELEASE:=5
|
PKG_RELEASE:=6
|
||||||
PKG_FLAGS:=essential
|
PKG_FLAGS:=essential
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
@ -72,6 +72,8 @@ ifdef CONFIG_BUSYBOX_USE_LIBRPC
|
||||||
LDLIBS += rpc
|
LDLIBS += rpc
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
TARGET_CFLAGS += -ggdb3
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
||||||
CC="$(TARGET_CC)" \
|
CC="$(TARGET_CC)" \
|
||||||
|
|
11
package/busybox/patches/700-hexdump_segfault_fix.patch
Normal file
11
package/busybox/patches/700-hexdump_segfault_fix.patch
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/libbb/dump.c
|
||||||
|
+++ b/libbb/dump.c
|
||||||
|
@@ -301,7 +301,7 @@ static NOINLINE void rewrite(priv_dumper
|
||||||
|
) {
|
||||||
|
fu->reps += (dumper->blocksize - fs->bcnt) / fu->bcnt;
|
||||||
|
}
|
||||||
|
- if (fu->reps > 1) {
|
||||||
|
+ if (fu->reps > 1 && fu->nextpr) {
|
||||||
|
for (pr = fu->nextpr;; pr = pr->nextpr)
|
||||||
|
if (!pr->nextpr)
|
||||||
|
break;
|
Loading…
Reference in a new issue