tools: automake: update to v1.15
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43895
This commit is contained in:
parent
da9782f935
commit
cdaf75b641
3 changed files with 42 additions and 40 deletions
|
@ -1,5 +1,5 @@
|
||||||
#
|
#
|
||||||
# Copyright (C) 2006-2013 OpenWrt.org
|
# Copyright (C) 2006-2015 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
@ -7,11 +7,11 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=automake
|
PKG_NAME:=automake
|
||||||
PKG_VERSION:=1.11.6
|
PKG_VERSION:=1.15
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=@GNU/automake
|
PKG_SOURCE_URL:=@GNU/automake
|
||||||
PKG_MD5SUM:=cf4752287ad708f83bd3689da57a32c9
|
PKG_MD5SUM:=9a1ddb0e053474d9d1105cfe39b0c48d
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
|
|
||||||
|
@ -19,6 +19,9 @@ HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
|
||||||
HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
|
HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
|
||||||
|
|
||||||
define Host/Install
|
define Host/Install
|
||||||
|
# remove old automake resources to avoid version conflicts
|
||||||
|
rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*
|
||||||
|
rm -rf $(STAGING_DIR_HOST)/share/automake-[0-9]*
|
||||||
$(MAKE) -C $(HOST_BUILD_DIR) install
|
$(MAKE) -C $(HOST_BUILD_DIR) install
|
||||||
mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
|
mv $(STAGING_DIR_HOST)/bin/aclocal $(STAGING_DIR_HOST)/bin/aclocal.real
|
||||||
$(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
|
$(INSTALL_BIN) ./files/aclocal $(STAGING_DIR_HOST)/bin
|
||||||
|
@ -26,6 +29,7 @@ define Host/Install
|
||||||
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
|
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.10
|
||||||
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
|
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11
|
||||||
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
|
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.11.6
|
||||||
|
ln -sf aclocal $(STAGING_DIR_HOST)/bin/aclocal-1.15
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Host/Clean
|
define Host/Clean
|
||||||
|
|
|
@ -1,17 +1,27 @@
|
||||||
--- a/aclocal.in
|
--- a/lib/Automake/Config.in
|
||||||
+++ b/aclocal.in
|
+++ b/lib/Automake/Config.in
|
||||||
@@ -27,7 +27,8 @@
|
@@ -32,7 +32,7 @@ our $PACKAGE = '@PACKAGE@';
|
||||||
|
our $PACKAGE_BUGREPORT = '@PACKAGE_BUGREPORT@';
|
||||||
|
our $VERSION = '@VERSION@';
|
||||||
|
our $RELEASE_YEAR = '@RELEASE_YEAR@';
|
||||||
|
-our $libdir = '@datadir@/@PACKAGE@-@APIVERSION@';
|
||||||
|
+our $libdir = $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@';
|
||||||
|
|
||||||
|
our $perl_threads = 0;
|
||||||
|
# We need at least this version for CLONE support.
|
||||||
|
--- a/bin/aclocal.in
|
||||||
|
+++ b/bin/aclocal.in
|
||||||
|
@@ -27,7 +27,7 @@ eval 'case $# in 0) exec @PERL@ -S "$0";
|
||||||
|
|
||||||
BEGIN
|
BEGIN
|
||||||
{
|
{
|
||||||
- my $perllibdir = $ENV{'perllibdir'} || '@datadir@/@PACKAGE@-@APIVERSION@';
|
- @Aclocal::perl_libdirs = ('@datadir@/@PACKAGE@-@APIVERSION@')
|
||||||
+ my $perllibdir = $ENV{'perllibdir'} ||
|
+ @Aclocal::perl_libdirs = ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@')
|
||||||
+ ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@');
|
unless @Aclocal::perl_libdirs;
|
||||||
unshift @INC, (split '@PATH_SEPARATOR@', $perllibdir);
|
unshift @INC, @Aclocal::perl_libdirs;
|
||||||
}
|
}
|
||||||
|
@@ -69,8 +69,8 @@ $perl_threads = 0;
|
||||||
@@ -58,8 +59,8 @@
|
# ACLOCAL_PATH environment variable, and reset with the '--system-acdir'
|
||||||
# ACLOCAL_PATH environment variable, and reset with the `--system-acdir'
|
|
||||||
# option.
|
# option.
|
||||||
my @user_includes = ();
|
my @user_includes = ();
|
||||||
-my @automake_includes = ("@datadir@/aclocal-$APIVERSION");
|
-my @automake_includes = ("@datadir@/aclocal-$APIVERSION");
|
||||||
|
@ -21,26 +31,14 @@
|
||||||
|
|
||||||
# Whether we should copy M4 file in $user_includes[0].
|
# Whether we should copy M4 file in $user_includes[0].
|
||||||
my $install = 0;
|
my $install = 0;
|
||||||
--- a/automake.in
|
--- a/bin/automake.in
|
||||||
+++ b/automake.in
|
+++ b/bin/automake.in
|
||||||
@@ -31,7 +31,8 @@
|
@@ -31,7 +31,7 @@ use strict;
|
||||||
|
|
||||||
BEGIN
|
BEGIN
|
||||||
{
|
{
|
||||||
- my $perllibdir = $ENV{'perllibdir'} || '@datadir@/@PACKAGE@-@APIVERSION@';
|
- @Automake::perl_libdirs = ('@datadir@/@PACKAGE@-@APIVERSION@')
|
||||||
+ my $perllibdir = $ENV{'perllibdir'} ||
|
+ @Automake::perl_libdirs = ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@')
|
||||||
+ ($ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@');
|
unless @Automake::perl_libdirs;
|
||||||
unshift @INC, (split '@PATH_SEPARATOR@', $perllibdir);
|
unshift @INC, @Automake::perl_libdirs;
|
||||||
|
|
||||||
# Override SHELL. This is required on DJGPP so that system() uses
|
|
||||||
--- a/lib/Automake/Config.in
|
|
||||||
+++ b/lib/Automake/Config.in
|
|
||||||
@@ -31,7 +31,7 @@
|
|
||||||
our $PACKAGE = '@PACKAGE@';
|
|
||||||
our $PACKAGE_BUGREPORT = '@PACKAGE_BUGREPORT@';
|
|
||||||
our $VERSION = '@VERSION@';
|
|
||||||
-our $libdir = '@datadir@/@PACKAGE@-@APIVERSION@';
|
|
||||||
+our $libdir = $ENV{'STAGING_DIR'} ? $ENV{'STAGING_DIR'} . '/../host/share/@PACKAGE@-@APIVERSION@' : '@datadir@/@PACKAGE@-@APIVERSION@';
|
|
||||||
our $perl_threads = @PERL_THREADS@;
|
|
||||||
|
|
||||||
1;
|
|
||||||
|
|
|
@ -1,15 +1,15 @@
|
||||||
--- a/aclocal.in
|
--- a/bin/aclocal.in
|
||||||
+++ b/aclocal.in
|
+++ b/bin/aclocal.in
|
||||||
@@ -327,6 +327,12 @@
|
@@ -354,6 +354,12 @@ sub scan_m4_dirs ($$@)
|
||||||
|
|
||||||
foreach my $m4dir (@dirlist)
|
foreach my $m4dir (@dirlist)
|
||||||
{
|
{
|
||||||
+ if (! -d $m4dir)
|
+ if (! -d $m4dir)
|
||||||
+ {
|
+ {
|
||||||
+ msg ('override', "warning: skipping not existing directory `$m4dir'");
|
+ msg ('override', "warning: skipping not existing directory `$m4dir'");
|
||||||
+ next;
|
+ next;
|
||||||
+ }
|
+ }
|
||||||
+
|
+
|
||||||
if (! opendir (DIR, $m4dir))
|
if (! opendir (DIR, $m4dir))
|
||||||
{
|
{
|
||||||
if ($install && $type == FT_USER && $first_user_m4dir)
|
# TODO: maybe avoid complaining only if errno == ENONENT?
|
||||||
|
|
Loading…
Reference in a new issue