atheros: v3.18: rename ATHEROS_AR231X symbol to ATH25
This patch starts upsteam ath25 code backporting. No functional changes. Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com> SVN-Revision: 44706
This commit is contained in:
parent
d3354d1aac
commit
cd34dcd2ce
12 changed files with 24 additions and 24 deletions
|
@ -12,7 +12,7 @@
|
|||
+
|
||||
config MTD_MYLOADER_PARTS
|
||||
tristate "MyLoader partition parsing"
|
||||
depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
|
||||
depends on ADM5120 || ATH25 || ATHEROS_AR71XX || ATH79
|
||||
--- a/drivers/mtd/Makefile
|
||||
+++ b/drivers/mtd/Makefile
|
||||
@@ -16,6 +16,7 @@ obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
||||
|
|
|
@ -12,7 +12,7 @@ CONFIG_ARCH_MIGHT_HAVE_PC_SERIO=y
|
|||
CONFIG_ARCH_REQUIRE_GPIOLIB=y
|
||||
CONFIG_ARCH_SUSPEND_POSSIBLE=y
|
||||
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
|
||||
CONFIG_ATHEROS_AR231X=y
|
||||
CONFIG_ATH25=y
|
||||
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
|
||||
CONFIG_CEVT_R4K=y
|
||||
CONFIG_CLONE_BACKWARDS=y
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -154,6 +154,19 @@ config BCM63XX
|
||||
help
|
||||
Support for BCM63XX based boards
|
||||
@@ -96,6 +96,19 @@ config AR7
|
||||
Support for the Texas Instruments AR7 System-on-a-Chip
|
||||
family: TNETD7100, 7200 and 7300.
|
||||
|
||||
+config ATHEROS_AR231X
|
||||
+config ATH25
|
||||
+ bool "Atheros 231x/531x SoC support"
|
||||
+ select CEVT_R4K
|
||||
+ select CSRC_R4K
|
||||
|
@ -17,9 +17,9 @@
|
|||
+ help
|
||||
+ Support for AR231x and AR531x based boards
|
||||
+
|
||||
config MIPS_COBALT
|
||||
bool "Cobalt Server"
|
||||
select CEVT_R4K
|
||||
config ATH79
|
||||
bool "Atheros AR71XX/AR724X/AR913X based boards"
|
||||
select ARCH_REQUIRE_GPIOLIB
|
||||
@@ -834,6 +847,7 @@ config MIPS_PARAVIRT
|
||||
|
||||
endchoice
|
||||
|
@ -44,20 +44,20 @@
|
|||
+#
|
||||
+# Atheros AR531X/AR231X WiSoC
|
||||
+#
|
||||
+platform-$(CONFIG_ATHEROS_AR231X) += ar231x/
|
||||
+cflags-$(CONFIG_ATHEROS_AR231X) += -I$(srctree)/arch/mips/include/asm/mach-ar231x
|
||||
+load-$(CONFIG_ATHEROS_AR231X) += 0xffffffff80041000
|
||||
+platform-$(CONFIG_ATH25) += ar231x/
|
||||
+cflags-$(CONFIG_ATH25) += -I$(srctree)/arch/mips/include/asm/mach-ar231x
|
||||
+load-$(CONFIG_ATH25) += 0xffffffff80041000
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/ar231x/Kconfig
|
||||
@@ -0,0 +1,9 @@
|
||||
+config SOC_AR5312
|
||||
+ bool "Atheros 5312/2312+ support"
|
||||
+ depends on ATHEROS_AR231X
|
||||
+ depends on ATH25
|
||||
+ default y
|
||||
+
|
||||
+config SOC_AR2315
|
||||
+ bool "Atheros 2315+ support"
|
||||
+ depends on ATHEROS_AR231X
|
||||
+ depends on ATH25
|
||||
+ default y
|
||||
--- /dev/null
|
||||
+++ b/arch/mips/ar231x/Makefile
|
||||
|
|
|
@ -60,7 +60,7 @@
|
|||
obj-$(CONFIG_SOC_AR2315) += ar2315.o
|
||||
--- a/arch/mips/Kconfig
|
||||
+++ b/arch/mips/Kconfig
|
||||
@@ -164,6 +164,7 @@ config ATHEROS_AR231X
|
||||
@@ -106,6 +106,7 @@ config ATH25
|
||||
select SYS_SUPPORTS_BIG_ENDIAN
|
||||
select SYS_SUPPORTS_32BIT_KERNEL
|
||||
select ARCH_REQUIRE_GPIOLIB
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
@@ -1,6 +1,7 @@
|
||||
config SOC_AR5312
|
||||
bool "Atheros 5312/2312+ support"
|
||||
depends on ATHEROS_AR231X
|
||||
depends on ATH25
|
||||
+ select GPIO_AR5312
|
||||
default y
|
||||
|
||||
|
|
|
@ -3,7 +3,7 @@
|
|||
@@ -7,4 +7,5 @@ config SOC_AR5312
|
||||
config SOC_AR2315
|
||||
bool "Atheros 2315+ support"
|
||||
depends on ATHEROS_AR231X
|
||||
depends on ATH25
|
||||
+ select GPIO_AR2315
|
||||
default y
|
||||
--- a/arch/mips/ar231x/ar2315.c
|
||||
|
|
|
@ -359,7 +359,7 @@
|
|||
--- a/arch/mips/ar231x/Kconfig
|
||||
+++ b/arch/mips/ar231x/Kconfig
|
||||
@@ -9,3 +9,10 @@ config SOC_AR2315
|
||||
depends on ATHEROS_AR231X
|
||||
depends on ATH25
|
||||
select GPIO_AR2315
|
||||
default y
|
||||
+
|
||||
|
|
|
@ -12,7 +12,7 @@
|
|||
bool "Atheros devices"
|
||||
default y
|
||||
- depends on PCI
|
||||
+ depends on (PCI || ATHEROS_AR231X)
|
||||
+ depends on (PCI || ATH25)
|
||||
---help---
|
||||
If you have a network (Ethernet) card belonging to this class, say Y
|
||||
and read the Ethernet-HOWTO, available from
|
||||
|
@ -22,7 +22,7 @@
|
|||
|
||||
+config NET_AR231X
|
||||
+ tristate "Atheros AR231X built-in Ethernet support"
|
||||
+ depends on ATHEROS_AR231X
|
||||
+ depends on ATH25
|
||||
+ help
|
||||
+ Support for the AR231x/531x ethernet controller
|
||||
+
|
||||
|
|
|
@ -218,7 +218,7 @@
|
|||
|
||||
+config AR2315_WDT
|
||||
+ tristate "Atheros AR2315+ WiSoCs Watchdog Timer"
|
||||
+ depends on ATHEROS_AR231X
|
||||
+ depends on ATH25
|
||||
+ help
|
||||
+ Hardware driver for the built-in watchdog timer on the Atheros
|
||||
+ AR2315/AR2316 WiSoCs.
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
|
||||
+config MTD_MYLOADER_PARTS
|
||||
+ tristate "MyLoader partition parsing"
|
||||
+ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
|
||||
+ depends on ADM5120 || ATH25 || ATHEROS_AR71XX || ATH79
|
||||
+ ---help---
|
||||
+ MyLoader is a bootloader which allows the user to define partitions
|
||||
+ in flash devices, by putting a table in the second erase block
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
|
||||
+config MTD_MYLOADER_PARTS
|
||||
+ tristate "MyLoader partition parsing"
|
||||
+ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
|
||||
+ depends on ADM5120 || ATH25 || ATHEROS_AR71XX || ATH79
|
||||
+ ---help---
|
||||
+ MyLoader is a bootloader which allows the user to define partitions
|
||||
+ in flash devices, by putting a table in the second erase block
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
|
||||
+config MTD_MYLOADER_PARTS
|
||||
+ tristate "MyLoader partition parsing"
|
||||
+ depends on ADM5120 || ATHEROS_AR231X || ATHEROS_AR71XX || ATH79
|
||||
+ depends on ADM5120 || ATH25 || ATHEROS_AR71XX || ATH79
|
||||
+ ---help---
|
||||
+ MyLoader is a bootloader which allows the user to define partitions
|
||||
+ in flash devices, by putting a table in the second erase block
|
||||
|
|
Loading…
Reference in a new issue