kernel: stop patching -funit-at-a-time into CFLAGS, it has no effect on recent compilers
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37598
This commit is contained in:
parent
c67a12711d
commit
cc26f768e4
5 changed files with 0 additions and 50 deletions
|
@ -12,13 +12,3 @@
|
||||||
endif
|
endif
|
||||||
|
|
||||||
include $(srctree)/arch/$(SRCARCH)/Makefile
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|
||||||
@@ -647,6 +647,9 @@ endif
|
|
||||||
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
||||||
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
||||||
|
|
||||||
+# improve gcc optimization
|
|
||||||
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
||||||
+
|
|
||||||
# warn about C99 declaration after statement
|
|
||||||
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
||||||
|
|
||||||
|
|
|
@ -12,13 +12,3 @@
|
||||||
endif
|
endif
|
||||||
|
|
||||||
include $(srctree)/arch/$(SRCARCH)/Makefile
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|
||||||
@@ -620,6 +620,9 @@ endif
|
|
||||||
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
||||||
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
||||||
|
|
||||||
+# improve gcc optimization
|
|
||||||
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
||||||
+
|
|
||||||
# warn about C99 declaration after statement
|
|
||||||
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
||||||
|
|
||||||
|
|
|
@ -12,13 +12,3 @@
|
||||||
endif
|
endif
|
||||||
|
|
||||||
include $(srctree)/arch/$(SRCARCH)/Makefile
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|
||||||
@@ -627,6 +627,9 @@ endif
|
|
||||||
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
||||||
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
||||||
|
|
||||||
+# improve gcc optimization
|
|
||||||
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
||||||
+
|
|
||||||
# warn about C99 declaration after statement
|
|
||||||
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
||||||
|
|
||||||
|
|
|
@ -12,13 +12,3 @@
|
||||||
endif
|
endif
|
||||||
|
|
||||||
include $(srctree)/arch/$(SRCARCH)/Makefile
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|
||||||
@@ -645,6 +645,9 @@ endif
|
|
||||||
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
||||||
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
||||||
|
|
||||||
+# improve gcc optimization
|
|
||||||
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
||||||
+
|
|
||||||
# warn about C99 declaration after statement
|
|
||||||
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
||||||
|
|
||||||
|
|
|
@ -12,13 +12,3 @@
|
||||||
endif
|
endif
|
||||||
|
|
||||||
include $(srctree)/arch/$(SRCARCH)/Makefile
|
include $(srctree)/arch/$(SRCARCH)/Makefile
|
||||||
@@ -647,6 +647,9 @@ endif
|
|
||||||
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
||||||
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
||||||
|
|
||||||
+# improve gcc optimization
|
|
||||||
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
||||||
+
|
|
||||||
# warn about C99 declaration after statement
|
|
||||||
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue