kirkwood: convert iconnect, ib62x0 and pogoplug_e02 to the new image build code
Update the correspoding u-boot configs to stop relying on kernel-in-rootfs, which was removed a while back Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
3f55e5aeb5
commit
c9e4cf2299
5 changed files with 58 additions and 38 deletions
|
@ -1,6 +1,6 @@
|
|||
--- a/include/configs/iconnect.h
|
||||
+++ b/include/configs/iconnect.h
|
||||
@@ -59,30 +59,35 @@
|
||||
@@ -59,30 +59,29 @@
|
||||
#define CONFIG_ENV_IS_NOWHERE
|
||||
#endif
|
||||
#define CONFIG_ENV_SIZE 0x20000
|
||||
|
@ -13,14 +13,11 @@
|
|||
#define CONFIG_BOOTCOMMAND \
|
||||
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
|
||||
- "ubi part rootfs; " \
|
||||
+ "ubi part root; " \
|
||||
"ubifsmount ubi:rootfs; " \
|
||||
"ubifsload 0x800000 ${kernel}; " \
|
||||
- "bootm 0x800000"
|
||||
+ "ubifsload 0x700000 ${fdt}; " \
|
||||
+ "ubifsumount; " \
|
||||
+ "fdt addr 0x700000; fdt resize; fdt chosen; " \
|
||||
+ "bootz 0x800000 - 0x700000"
|
||||
- "ubifsmount ubi:rootfs; " \
|
||||
- "ubifsload 0x800000 ${kernel}; " \
|
||||
+ "ubi part ubi; " \
|
||||
+ "ubi read 0x800000 kernel; " \
|
||||
"bootm 0x800000"
|
||||
|
||||
#define CONFIG_MTDPARTS \
|
||||
- "mtdparts=orion_nand:" \
|
||||
|
@ -31,7 +28,7 @@
|
|||
+ "0xe0000@0x0(uboot)," \
|
||||
+ "0x20000@0xe0000(uboot_env)," \
|
||||
+ "0x100000@0x100000(second_stage_uboot)," \
|
||||
+ "-@0x200000(root)\0"
|
||||
+ "-@0x200000(ubi)\0"
|
||||
|
||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||
"console=console=ttyS0,115200\0" \
|
||||
|
@ -39,9 +36,7 @@
|
|||
"mtdparts="CONFIG_MTDPARTS \
|
||||
- "kernel=/boot/uImage\0" \
|
||||
- "bootargs_root=noinitrd ubi.mtd=2 root=ubi0:rootfs rootfstype=ubifs\0"
|
||||
+ "kernel=/boot/zImage\0" \
|
||||
+ "fdt=/boot/iconnect.dtb\0" \
|
||||
+ "bootargs_root=ubi.mtd=3 root=ubi0:rootfs rootfstype=ubifs rw\0"
|
||||
+ "bootargs_root=\0"
|
||||
|
||||
/*
|
||||
* Ethernet driver configuration
|
||||
|
|
|
@ -1,21 +1,36 @@
|
|||
--- a/include/configs/ib62x0.h
|
||||
+++ b/include/configs/ib62x0.h
|
||||
@@ -74,7 +74,8 @@
|
||||
@@ -62,27 +62,22 @@
|
||||
*/
|
||||
#define CONFIG_BOOTCOMMAND \
|
||||
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
|
||||
- "ubi part root; " \
|
||||
- "ubifsmount ubi:rootfs; " \
|
||||
- "ubifsload 0x800000 ${kernel}; " \
|
||||
- "ubifsload 0x700000 ${fdt}; " \
|
||||
- "ubifsumount; " \
|
||||
- "fdt addr 0x700000; fdt resize; fdt chosen; " \
|
||||
- "bootz 0x800000 - 0x700000"
|
||||
+ "ubi part ubi; " \
|
||||
+ "ubi read 0x800000 kernel; " \
|
||||
+ "bootm 0x800000"
|
||||
|
||||
#define CONFIG_MTDPARTS \
|
||||
"mtdparts=orion_nand:" \
|
||||
"0xe0000@0x0(uboot)," \
|
||||
"0x20000@0xe0000(uboot_env)," \
|
||||
- "-@0x100000(root)\0"
|
||||
+ "0x100000@0x100000(second_stage_uboot)," \
|
||||
+ "-@0x200000(root)\0"
|
||||
+ "-@0x200000(ubi)\0"
|
||||
|
||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||
"console=console=ttyS0,115200\0" \
|
||||
@@ -82,7 +83,7 @@
|
||||
"mtdids=nand0=orion_nand\0" \
|
||||
"mtdparts="CONFIG_MTDPARTS \
|
||||
"kernel=/boot/zImage\0" \
|
||||
"fdt=/boot/ib62x0.dtb\0" \
|
||||
- "kernel=/boot/zImage\0" \
|
||||
- "fdt=/boot/ib62x0.dtb\0" \
|
||||
- "bootargs_root=ubi.mtd=2 root=ubi0:rootfs rootfstype=ubifs rw\0"
|
||||
+ "bootargs_root=ubi.mtd=3 root=ubi0:rootfs rootfstype=ubifs rw\0"
|
||||
+ "bootargs_root=\0"
|
||||
|
||||
/*
|
||||
* Ethernet driver configuration
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/include/configs/pogo_e02.h
|
||||
+++ b/include/configs/pogo_e02.h
|
||||
@@ -54,23 +54,35 @@
|
||||
@@ -54,23 +54,30 @@
|
||||
#endif
|
||||
|
||||
#define CONFIG_ENV_SIZE 0x20000 /* 128k */
|
||||
|
@ -15,20 +15,17 @@
|
|||
- "run bootcmd_usb; " \
|
||||
- "bootm 0x00800000 0x01100000"
|
||||
+ "setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
|
||||
+ "ubi part root; " \
|
||||
+ "ubifsmount ubi:rootfs; " \
|
||||
+ "ubifsload 0x800000 ${kernel}; " \
|
||||
+ "ubifsload 0x700000 ${fdt}; " \
|
||||
+ "ubifsumount; " \
|
||||
+ "fdt addr 0x700000; fdt resize; fdt chosen; " \
|
||||
+ "bootz 0x800000 - 0x700000"
|
||||
+ "ubi part ubi; " \
|
||||
+ "ubifsmount ubi:rootfs; " \
|
||||
+ "ubi read 0x800000 kernel; " \
|
||||
+ "bootm 0x800000"
|
||||
+
|
||||
+#define CONFIG_MTDPARTS \
|
||||
+ "mtdparts=orion_nand:" \
|
||||
+ "0xe0000@0x0(uboot)," \
|
||||
+ "0x20000@0xe0000(uboot_env)," \
|
||||
+ "0x100000@0x100000(second_stage_uboot)," \
|
||||
+ "-@0x200000(root)\0"
|
||||
+ "-@0x200000(ubi)\0"
|
||||
|
||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||
- "mtdparts=mtdparts=orion_nand:1M(u-boot),4M(uImage)," \
|
||||
|
@ -40,9 +37,7 @@
|
|||
+ "console=console=ttyS0,115200\0" \
|
||||
+ "mtdids=nand0=orion_nand\0" \
|
||||
+ "mtdparts="CONFIG_MTDPARTS \
|
||||
+ "kernel=/boot/zImage\0" \
|
||||
+ "fdt=/boot/pogo_e02.dtb\0" \
|
||||
+ "bootargs_root=ubi.mtd=3 root=ubi0:rootfs rootfstype=ubifs rw\0"
|
||||
+ "bootargs_root=\0"
|
||||
|
||||
/*
|
||||
* Ethernet Driver configuration
|
||||
|
|
|
@ -19,7 +19,7 @@
|
|||
#endif /* _CONFIG_DOCKSTAR_H */
|
||||
--- a/include/configs/ib62x0.h
|
||||
+++ b/include/configs/ib62x0.h
|
||||
@@ -114,4 +114,6 @@
|
||||
@@ -108,4 +108,6 @@
|
||||
#define CONFIG_RTC_MV
|
||||
#endif /* CONFIG_CMD_DATE */
|
||||
|
||||
|
@ -28,7 +28,7 @@
|
|||
#endif /* _CONFIG_IB62x0_H */
|
||||
--- a/include/configs/iconnect.h
|
||||
+++ b/include/configs/iconnect.h
|
||||
@@ -109,4 +109,6 @@
|
||||
@@ -103,4 +103,6 @@
|
||||
#define CONFIG_MTD_PARTITIONS
|
||||
#define CONFIG_CMD_MTDPARTS
|
||||
|
||||
|
@ -80,7 +80,7 @@
|
|||
+#endif /* __OPENWRT_KIRKWOOD_COMMON_H */
|
||||
--- a/include/configs/pogo_e02.h
|
||||
+++ b/include/configs/pogo_e02.h
|
||||
@@ -104,4 +104,6 @@
|
||||
@@ -99,4 +99,6 @@
|
||||
#define CONFIG_CMD_MTDPARTS
|
||||
#define CONFIG_LZO
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
|
|||
include $(INCLUDE_DIR)/image.mk
|
||||
|
||||
KERNEL_LOADADDR:=0x8000
|
||||
TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome
|
||||
TARGET_DEVICES = linksys-audi linksys-viper dockstar goflexnet goflexhome iconnect pogo_e02 ib62x0
|
||||
|
||||
UBI_OPTS := -m 2048 -p 128KiB -s 512
|
||||
UBIFS_OPTS := -m 2048 -e 126KiB -c 4096
|
||||
|
@ -70,6 +70,24 @@ define Device/linksys-viper
|
|||
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
|
||||
endef
|
||||
|
||||
define Device/iconnect
|
||||
$(Device/dockstar)
|
||||
PROFILES := Generic ICONNECT
|
||||
DEVICE_DTS := kirkwood-iconnect
|
||||
endef
|
||||
|
||||
define Device/pogo_e02
|
||||
$(Device/dockstar)
|
||||
PROFILES := Generic POGOE02
|
||||
DEVICE_DTS := kirkwood-pogo_e02
|
||||
endef
|
||||
|
||||
define Device/ib62x0
|
||||
$(Device/dockstar)
|
||||
PROFILES := Generic IB62X0
|
||||
DEVICE_DTS := kirkwood-ib62x0
|
||||
endef
|
||||
|
||||
define Image/BuildKernel/Template
|
||||
|
||||
$(CP) $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
|
||||
|
@ -144,11 +162,8 @@ IOMEGA_IX2_200_UBIFS_OPTS := -m 512 -e 15872 -c 2048
|
|||
IOMEGA_IX2_200_UBI_OPTS := -m 512 -p 16384 -s 256
|
||||
|
||||
Image/BuildKernel/Template/Generic=$(call Image/BuildKernel/Template)
|
||||
Image/BuildKernel/Template/IB62X0=$(call Image/BuildKernel/Template,ib62x0)
|
||||
Image/BuildKernel/Template/ICONNECT=$(call Image/BuildKernel/Template,iconnect)
|
||||
Image/BuildKernel/Template/IOMEGA_IX2_200=$(call Image/BuildKernel/Template,iomega_ix2_200)
|
||||
Image/BuildKernel/Template/NSA310S=$(call Image/BuildKernel/Template,nsa310s)
|
||||
Image/BuildKernel/Template/POGOE02=$(call Image/BuildKernel/Template,pogo_e02)
|
||||
Image/BuildKernel/Template/SHEEVAPLUG=$(call Image/BuildKernel/Template,sheevaplug)
|
||||
Image/BuildKernel/Template/SHEEVAPLUGSATA=$(call Image/BuildKernel/Template,sheevaplug-esata)
|
||||
Image/BuildKernel/Template/GuruplugServerPlus=$(call Image/BuildKernel/Template,guruplug-server-plus)
|
||||
|
|
Loading…
Reference in a new issue