kernel: add own Kconfig for OpenWrt mtdsplit drivers
There are pretty many OpenWrt patches against mtd subsystem resulting in a bit of mess and growing maintenance cost. My idea is to use an extra "mtdsplit" directory with OpenWrt specific files (including Kconfig). This is the first step to achieve this. This patch adds a "mtdsplit" directory with Kconfig and replaces 4 patches with a single one. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 42287
This commit is contained in:
parent
730589281e
commit
c9813699b6
5 changed files with 30 additions and 83 deletions
24
target/linux/generic/files/drivers/mtd/mtdsplit/Kconfig
Normal file
24
target/linux/generic/files/drivers/mtd/mtdsplit/Kconfig
Normal file
|
@ -0,0 +1,24 @@
|
|||
comment "Rootfs partition parsers"
|
||||
|
||||
config MTD_SPLIT_SQUASHFS_ROOT
|
||||
bool "Squashfs based root partition parser"
|
||||
select MTD_SPLIT
|
||||
default n
|
||||
help
|
||||
This provides a parsing function which allows to detect the
|
||||
offset and size of the unused portion of a rootfs partition
|
||||
containing a squashfs.
|
||||
|
||||
comment "Firmware partition parsers"
|
||||
|
||||
config MTD_SPLIT_SEAMA_FW
|
||||
bool "Seama firmware parser"
|
||||
select MTD_SPLIT
|
||||
|
||||
config MTD_SPLIT_UIMAGE_FW
|
||||
bool "uImage based firmware partition parser"
|
||||
select MTD_SPLIT
|
||||
|
||||
config MTD_SPLIT_LZMA_FW
|
||||
bool "LZMA compressed kernel based firmware partition parser"
|
||||
select MTD_SPLIT
|
|
@ -1,30 +1,24 @@
|
|||
--- a/drivers/mtd/Kconfig
|
||||
+++ b/drivers/mtd/Kconfig
|
||||
@@ -37,6 +37,17 @@ config MTD_UIMAGE_SPLIT
|
||||
@@ -37,6 +37,8 @@ config MTD_UIMAGE_SPLIT
|
||||
depends on MTD_SPLIT_FIRMWARE
|
||||
default y
|
||||
|
||||
+comment "Rootfs partition parsers"
|
||||
+
|
||||
+config MTD_SPLIT_SQUASHFS_ROOT
|
||||
+ bool "Squashfs based root partition parser"
|
||||
+ select MTD_SPLIT
|
||||
+ default n
|
||||
+ help
|
||||
+ This provides a parsing function which allows to detect the
|
||||
+ offset and size of the unused portion of a rootfs partition
|
||||
+ containing a squashfs.
|
||||
+source "drivers/mtd/mtdsplit/Kconfig"
|
||||
+
|
||||
config MTD_SPLIT
|
||||
def_bool n
|
||||
help
|
||||
--- a/drivers/mtd/Makefile
|
||||
+++ b/drivers/mtd/Makefile
|
||||
@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD) += mtd.o
|
||||
@@ -7,6 +7,10 @@ obj-$(CONFIG_MTD) += mtd.o
|
||||
mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
|
||||
|
||||
mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
|
||||
+mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
|
||||
+mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
|
||||
+mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
|
||||
+mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
|
||||
|
||||
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
||||
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
@ -1,25 +0,0 @@
|
|||
--- a/drivers/mtd/Kconfig
|
||||
+++ b/drivers/mtd/Kconfig
|
||||
@@ -48,6 +48,12 @@ config MTD_SPLIT_SQUASHFS_ROOT
|
||||
offset and size of the unused portion of a rootfs partition
|
||||
containing a squashfs.
|
||||
|
||||
+comment "Firmware partition parsers"
|
||||
+
|
||||
+config MTD_SPLIT_UIMAGE_FW
|
||||
+ bool "uImage based firmware partition parser"
|
||||
+ select MTD_SPLIT
|
||||
+
|
||||
config MTD_SPLIT
|
||||
def_bool n
|
||||
help
|
||||
--- a/drivers/mtd/Makefile
|
||||
+++ b/drivers/mtd/Makefile
|
||||
@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdconc
|
||||
|
||||
mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
|
||||
mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
|
||||
+mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
|
||||
|
||||
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
||||
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
@ -1,23 +0,0 @@
|
|||
--- a/drivers/mtd/Kconfig
|
||||
+++ b/drivers/mtd/Kconfig
|
||||
@@ -50,6 +50,10 @@ config MTD_SPLIT_SQUASHFS_ROOT
|
||||
|
||||
comment "Firmware partition parsers"
|
||||
|
||||
+config MTD_SPLIT_SEAMA_FW
|
||||
+ bool "Seama firmware parser"
|
||||
+ select MTD_SPLIT
|
||||
+
|
||||
config MTD_SPLIT_UIMAGE_FW
|
||||
bool "uImage based firmware partition parser"
|
||||
select MTD_SPLIT
|
||||
--- a/drivers/mtd/Makefile
|
||||
+++ b/drivers/mtd/Makefile
|
||||
@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD) += mtd.o
|
||||
mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
|
||||
|
||||
mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
|
||||
+mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
|
||||
mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
|
||||
mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
|
||||
|
|
@ -1,23 +0,0 @@
|
|||
--- a/drivers/mtd/Kconfig
|
||||
+++ b/drivers/mtd/Kconfig
|
||||
@@ -58,6 +58,10 @@ config MTD_SPLIT_UIMAGE_FW
|
||||
bool "uImage based firmware partition parser"
|
||||
select MTD_SPLIT
|
||||
|
||||
+config MTD_SPLIT_LZMA_FW
|
||||
+ bool "LZMA compressed kernel based firmware partition parser"
|
||||
+ select MTD_SPLIT
|
||||
+
|
||||
config MTD_SPLIT
|
||||
def_bool n
|
||||
help
|
||||
--- a/drivers/mtd/Makefile
|
||||
+++ b/drivers/mtd/Makefile
|
||||
@@ -10,6 +10,7 @@ mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
|
||||
mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
|
||||
mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
|
||||
mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
|
||||
+mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
|
||||
|
||||
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
||||
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
Loading…
Reference in a new issue