2.6.{28,30}: refresh patches
SVN-Revision: 16934
This commit is contained in:
parent
2404c8c77b
commit
c7fdb609e4
4 changed files with 6 additions and 18 deletions
|
@ -6,11 +6,9 @@ precious blocks on an embedded system.
|
||||||
|
|
||||||
Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
Signed-off-by: Florian Fainelli <florian@openwrt.org>
|
||||||
--
|
--
|
||||||
diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
|
|
||||||
index 65d3b19..a467ee5 100644
|
|
||||||
--- a/arch/mips/Kconfig
|
--- a/arch/mips/Kconfig
|
||||||
+++ b/arch/mips/Kconfig
|
+++ b/arch/mips/Kconfig
|
||||||
@@ -811,6 +811,17 @@ config I8259
|
@@ -751,6 +751,17 @@ config I8259
|
||||||
config MIPS_BONITO64
|
config MIPS_BONITO64
|
||||||
bool
|
bool
|
||||||
|
|
||||||
|
@ -28,8 +26,6 @@ index 65d3b19..a467ee5 100644
|
||||||
config MIPS_MSC
|
config MIPS_MSC
|
||||||
bool
|
bool
|
||||||
|
|
||||||
diff --git a/arch/mips/math-emu/Makefile b/arch/mips/math-emu/Makefile
|
|
||||||
index d547efd..7fdef24 100644
|
|
||||||
--- a/arch/mips/math-emu/Makefile
|
--- a/arch/mips/math-emu/Makefile
|
||||||
+++ b/arch/mips/math-emu/Makefile
|
+++ b/arch/mips/math-emu/Makefile
|
||||||
@@ -2,12 +2,14 @@
|
@@ -2,12 +2,14 @@
|
||||||
|
@ -49,8 +45,6 @@ index d547efd..7fdef24 100644
|
||||||
+ dp_sqrt.o sp_sqrt.o
|
+ dp_sqrt.o sp_sqrt.o
|
||||||
|
|
||||||
EXTRA_CFLAGS += -Werror
|
EXTRA_CFLAGS += -Werror
|
||||||
diff --git a/arch/mips/math-emu/cp1emu.c b/arch/mips/math-emu/cp1emu.c
|
|
||||||
index 890f779..9f4c767 100644
|
|
||||||
--- a/arch/mips/math-emu/cp1emu.c
|
--- a/arch/mips/math-emu/cp1emu.c
|
||||||
+++ b/arch/mips/math-emu/cp1emu.c
|
+++ b/arch/mips/math-emu/cp1emu.c
|
||||||
@@ -56,6 +56,12 @@
|
@@ -56,6 +56,12 @@
|
||||||
|
@ -77,7 +71,7 @@ index 890f779..9f4c767 100644
|
||||||
/* Control registers */
|
/* Control registers */
|
||||||
|
|
||||||
#define FPCREG_RID 0 /* $0 = revision id */
|
#define FPCREG_RID 0 /* $0 = revision id */
|
||||||
@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_regs *xcp, struct mips_fpu_struct *ctx,
|
@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_r
|
||||||
|
|
||||||
return sig;
|
return sig;
|
||||||
}
|
}
|
||||||
|
@ -91,11 +85,9 @@ index 890f779..9f4c767 100644
|
||||||
|
|
||||||
#ifdef CONFIG_DEBUG_FS
|
#ifdef CONFIG_DEBUG_FS
|
||||||
extern struct dentry *mips_debugfs_dir;
|
extern struct dentry *mips_debugfs_dir;
|
||||||
diff --git a/arch/mips/math-emu/dsemul.c b/arch/mips/math-emu/dsemul.c
|
|
||||||
index df7b9d9..9b42bfd 100644
|
|
||||||
--- a/arch/mips/math-emu/dsemul.c
|
--- a/arch/mips/math-emu/dsemul.c
|
||||||
+++ b/arch/mips/math-emu/dsemul.c
|
+++ b/arch/mips/math-emu/dsemul.c
|
||||||
@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mips_instruction ir, unsigned long cpc)
|
@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mi
|
||||||
return SIGILL; /* force out of emulation loop */
|
return SIGILL; /* force out of emulation loop */
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -113,8 +105,6 @@ index df7b9d9..9b42bfd 100644
|
||||||
+ return 0;
|
+ return 0;
|
||||||
+}
|
+}
|
||||||
+#endif /* CONFIG_MIPS_FPU_EMU */
|
+#endif /* CONFIG_MIPS_FPU_EMU */
|
||||||
diff --git a/arch/mips/math-emu/kernel_linkage.c b/arch/mips/math-emu/kernel_linkage.c
|
|
||||||
index 52e6c58..211a399 100644
|
|
||||||
--- a/arch/mips/math-emu/kernel_linkage.c
|
--- a/arch/mips/math-emu/kernel_linkage.c
|
||||||
+++ b/arch/mips/math-emu/kernel_linkage.c
|
+++ b/arch/mips/math-emu/kernel_linkage.c
|
||||||
@@ -29,6 +29,7 @@
|
@@ -29,6 +29,7 @@
|
||||||
|
@ -125,7 +115,7 @@ index 52e6c58..211a399 100644
|
||||||
void fpu_emulator_init_fpu(void)
|
void fpu_emulator_init_fpu(void)
|
||||||
{
|
{
|
||||||
static int first = 1;
|
static int first = 1;
|
||||||
@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struct sigcontext32 __user *sc)
|
@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struc
|
||||||
|
|
||||||
return err;
|
return err;
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,6 +1,6 @@
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -566,6 +566,9 @@ endif
|
@@ -567,6 +567,9 @@ endif
|
||||||
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
||||||
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
||||||
|
|
||||||
|
|
|
@ -8,8 +8,6 @@
|
||||||
#define FB_ACCEL_NEOMAGIC_NM2070 90 /* NeoMagic NM2070 */
|
#define FB_ACCEL_NEOMAGIC_NM2070 90 /* NeoMagic NM2070 */
|
||||||
#define FB_ACCEL_NEOMAGIC_NM2090 91 /* NeoMagic NM2090 */
|
#define FB_ACCEL_NEOMAGIC_NM2090 91 /* NeoMagic NM2090 */
|
||||||
#define FB_ACCEL_NEOMAGIC_NM2093 92 /* NeoMagic NM2093 */
|
#define FB_ACCEL_NEOMAGIC_NM2093 92 /* NeoMagic NM2093 */
|
||||||
diff --git a/Kbuild b/Kbuild
|
|
||||||
index 3f0eaa3..72699f0 100644
|
|
||||||
--- a/include/linux/Kbuild
|
--- a/include/linux/Kbuild
|
||||||
+++ b/include/linux/Kbuild
|
+++ b/include/linux/Kbuild
|
||||||
@@ -75,6 +75,8 @@ header-y += genetlink.h
|
@@ -75,6 +75,8 @@ header-y += genetlink.h
|
||||||
|
|
|
@ -116,7 +116,7 @@
|
||||||
void *caller)
|
void *caller)
|
||||||
--- a/include/linux/mm.h
|
--- a/include/linux/mm.h
|
||||||
+++ b/include/linux/mm.h
|
+++ b/include/linux/mm.h
|
||||||
@@ -728,6 +728,7 @@ static inline int shmem_lock(struct file
|
@@ -726,6 +726,7 @@ static inline int shmem_lock(struct file
|
||||||
#endif
|
#endif
|
||||||
struct file *shmem_file_setup(char *name, loff_t size, unsigned long flags);
|
struct file *shmem_file_setup(char *name, loff_t size, unsigned long flags);
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue