bison: make yacc wrapper relocatable
SVN-Revision: 29831
This commit is contained in:
parent
e2180091d9
commit
c7d19be230
1 changed files with 20 additions and 0 deletions
20
tools/bison/patches/000-relocatable.patch
Normal file
20
tools/bison/patches/000-relocatable.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -77,6 +77,7 @@ MOSTLYCLEANFILES = yacc
|
||||
|
||||
yacc:
|
||||
echo '#! /bin/sh' >$@
|
||||
+ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
||||
echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
||||
chmod a+x $@
|
||||
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -1352,6 +1352,7 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
|
||||
yacc:
|
||||
echo '#! /bin/sh' >$@
|
||||
+ echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
||||
echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
||||
chmod a+x $@
|
||||
|
Loading…
Reference in a new issue