Hi all, here is a patch for package/ar7-atm. It fixes the bug #2377, which reports a WARNING: at kernel/softirq.c:138 local_bh_enable().
Make the TIATM driver use tasklet, instead of BH without the flag, the TIATM driver treats packets inside BH, which is wrong for most skbuff stuff. Use tasklet instead. Signed-off-by: <benoit.ganne@gmail.com> SVN-Revision: 10141
This commit is contained in:
parent
47bf8f89da
commit
c3c33ff16a
1 changed files with 12 additions and 0 deletions
12
package/ar7-atm/patches/150-tasklet_mode.patch
Normal file
12
package/ar7-atm/patches/150-tasklet_mode.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Naur sangam_atm-D7.03.01.00.orig/Makefile sangam_atm-D7.03.01.00/Makefile
|
||||
--- sangam_atm-D7.03.01.00.orig/Makefile 2008-01-07 10:30:34.000000000 +0100
|
||||
+++ sangam_atm-D7.03.01.00/Makefile 2008-01-07 10:31:40.000000000 +0100
|
||||
@@ -5,6 +5,7 @@
|
||||
CONFIG_SANGAM_ATM=m
|
||||
#EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
|
||||
#EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
|
||||
-EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL
|
||||
+#EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL
|
||||
+EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL -DCPATM_TASKLET_MODE
|
||||
obj-$(CONFIG_SANGAM_ATM) := tiatm.o
|
||||
tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o dsl_hal_advcfg.o
|
Loading…
Reference in a new issue