refresh patches

SVN-Revision: 16156
This commit is contained in:
Florian Fainelli 2009-05-28 19:04:19 +00:00
parent e0c3e283da
commit c2df3a7179
8 changed files with 18 additions and 17 deletions

View file

@ -1,6 +1,6 @@
--- a/arch/mips/Kconfig --- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig +++ b/arch/mips/Kconfig
@@ -18,6 +18,24 @@ choice @@ -19,6 +19,24 @@ choice
prompt "System type" prompt "System type"
default SGI_IP22 default SGI_IP22
@ -27,7 +27,7 @@
--- a/arch/mips/kernel/traps.c --- a/arch/mips/kernel/traps.c
+++ b/arch/mips/kernel/traps.c +++ b/arch/mips/kernel/traps.c
@@ -1188,9 +1188,22 @@ void *set_except_vector(int n, void *add @@ -1203,9 +1203,22 @@ void *set_except_vector(int n, void *add
exception_handlers[n] = handler; exception_handlers[n] = handler;
if (n == 0 && cpu_has_divec) { if (n == 0 && cpu_has_divec) {

View file

@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig --- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig +++ b/drivers/mtd/Kconfig
@@ -190,6 +190,12 @@ config MTD_MYLOADER_PARTS @@ -188,6 +188,12 @@ config MTD_MYLOADER_PARTS
You will still need the parsing functions to be called by the driver You will still need the parsing functions to be called by the driver
for your particular device. It won't happen automatically. for your particular device. It won't happen automatically.
@ -15,7 +15,7 @@
config MTD_CHAR config MTD_CHAR
--- a/drivers/mtd/maps/physmap.c --- a/drivers/mtd/maps/physmap.c
+++ b/drivers/mtd/maps/physmap.c +++ b/drivers/mtd/maps/physmap.c
@@ -87,7 +87,7 @@ static int physmap_flash_remove(struct p @@ -85,7 +85,7 @@ static int physmap_flash_remove(struct p
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL }; static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS #ifdef CONFIG_MTD_PARTITIONS

View file

@ -1,6 +1,6 @@
--- a/drivers/char/Kconfig --- a/drivers/char/Kconfig
+++ b/drivers/char/Kconfig +++ b/drivers/char/Kconfig
@@ -960,6 +960,15 @@ config MWAVE @@ -968,6 +968,15 @@ config MWAVE
To compile this driver as a module, choose M here: the To compile this driver as a module, choose M here: the
module will be called mwave. module will be called mwave.
@ -18,7 +18,7 @@
depends on SCx200 depends on SCx200
--- a/drivers/char/Makefile --- a/drivers/char/Makefile
+++ b/drivers/char/Makefile +++ b/drivers/char/Makefile
@@ -91,6 +91,7 @@ obj-$(CONFIG_COBALT_LCD) += lcd.o @@ -90,6 +90,7 @@ obj-$(CONFIG_HW_RANDOM) += hw_random/
obj-$(CONFIG_PPDEV) += ppdev.o obj-$(CONFIG_PPDEV) += ppdev.o
obj-$(CONFIG_NWBUTTON) += nwbutton.o obj-$(CONFIG_NWBUTTON) += nwbutton.o
obj-$(CONFIG_NWFLASH) += nwflash.o obj-$(CONFIG_NWFLASH) += nwflash.o

View file

@ -10,10 +10,11 @@
endmenu endmenu
--- a/drivers/Makefile --- a/drivers/Makefile
+++ b/drivers/Makefile +++ b/drivers/Makefile
@@ -92,5 +92,6 @@ obj-$(CONFIG_DCA) += dca/ @@ -96,6 +96,7 @@ obj-$(CONFIG_DCA) += dca/
obj-$(CONFIG_HID) += hid/ obj-$(CONFIG_HID) += hid/
obj-$(CONFIG_PPC_PS3) += ps3/ obj-$(CONFIG_PPC_PS3) += ps3/
obj-$(CONFIG_OF) += of/ obj-$(CONFIG_OF) += of/
+obj-$(CONFIG_VLYNQ) += vlynq/ +obj-$(CONFIG_VLYNQ) += vlynq/
obj-$(CONFIG_SSB) += ssb/ obj-$(CONFIG_SSB) += ssb/
obj-$(CONFIG_VIRTIO) += virtio/ obj-$(CONFIG_VIRTIO) += virtio/
obj-$(CONFIG_REGULATOR) += regulator/

View file

@ -1,6 +1,6 @@
--- a/drivers/net/Kconfig --- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig +++ b/drivers/net/Kconfig
@@ -1867,7 +1867,7 @@ config SC92031 @@ -1823,7 +1823,7 @@ config SC92031
config CPMAC config CPMAC
tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)" tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)"

View file

@ -1,6 +1,6 @@
--- a/drivers/serial/8250.c --- a/drivers/serial/8250.c
+++ b/drivers/serial/8250.c +++ b/drivers/serial/8250.c
@@ -266,6 +266,13 @@ static const struct serial8250_config ua @@ -264,6 +264,13 @@ static const struct serial8250_config ua
.fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10, .fcr = UART_FCR_ENABLE_FIFO | UART_FCR_R_TRIG_10,
.flags = UART_CAP_FIFO, .flags = UART_CAP_FIFO,
}, },
@ -14,7 +14,7 @@
}; };
#if defined (CONFIG_SERIAL_8250_AU1X00) #if defined (CONFIG_SERIAL_8250_AU1X00)
@@ -2524,7 +2531,11 @@ static void serial8250_console_putchar(s @@ -2552,7 +2559,11 @@ static void serial8250_console_putchar(s
{ {
struct uart_8250_port *up = (struct uart_8250_port *)port; struct uart_8250_port *up = (struct uart_8250_port *)port;

View file

@ -19,7 +19,7 @@ because other drivers do it in the same way.
--- a/drivers/net/cpmac.c --- a/drivers/net/cpmac.c
+++ b/drivers/net/cpmac.c +++ b/drivers/net/cpmac.c
@@ -621,13 +621,13 @@ @@ -621,13 +621,13 @@ static void cpmac_end_xmit(struct net_de
dev_kfree_skb_irq(desc->skb); dev_kfree_skb_irq(desc->skb);
desc->skb = NULL; desc->skb = NULL;
@ -35,7 +35,7 @@ because other drivers do it in the same way.
netif_wake_subqueue(dev, queue); netif_wake_subqueue(dev, queue);
} }
} }
@@ -737,7 +737,6 @@ @@ -737,7 +737,6 @@ static void cpmac_clear_tx(struct net_de
static void cpmac_hw_error(struct work_struct *work) static void cpmac_hw_error(struct work_struct *work)
{ {
@ -43,7 +43,7 @@ because other drivers do it in the same way.
struct cpmac_priv *priv = struct cpmac_priv *priv =
container_of(work, struct cpmac_priv, reset_work); container_of(work, struct cpmac_priv, reset_work);
@@ -824,7 +823,6 @@ @@ -824,7 +823,6 @@ static irqreturn_t cpmac_irq(int irq, vo
static void cpmac_tx_timeout(struct net_device *dev) static void cpmac_tx_timeout(struct net_device *dev)
{ {
@ -51,7 +51,7 @@ because other drivers do it in the same way.
struct cpmac_priv *priv = netdev_priv(dev); struct cpmac_priv *priv = netdev_priv(dev);
spin_lock(&priv->lock); spin_lock(&priv->lock);
@@ -1103,7 +1101,7 @@ @@ -1103,7 +1101,7 @@ static int external_switch;
static int __devinit cpmac_probe(struct platform_device *pdev) static int __devinit cpmac_probe(struct platform_device *pdev)
{ {
@ -60,7 +60,7 @@ because other drivers do it in the same way.
char *mdio_bus_id = "0"; char *mdio_bus_id = "0";
struct resource *mem; struct resource *mem;
struct cpmac_priv *priv; struct cpmac_priv *priv;
@@ -1132,6 +1130,7 @@ @@ -1132,6 +1130,7 @@ static int __devinit cpmac_probe(struct
} }
dev = alloc_etherdev_mq(sizeof(*priv), CPMAC_QUEUES); dev = alloc_etherdev_mq(sizeof(*priv), CPMAC_QUEUES);

View file

@ -8,7 +8,7 @@
static int debug; static int debug;
/* initially all NULL */ /* initially all NULL */
static struct usb_serial *serial_table[SERIAL_TTY_MINORS]; static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
@@ -856,7 +857,7 @@ int usb_serial_probe(struct usb_interfac @@ -835,7 +836,7 @@ int usb_serial_probe(struct usb_interfac
dev_err(&interface->dev, "No free urbs available\n"); dev_err(&interface->dev, "No free urbs available\n");
goto probe_error; goto probe_error;
} }
@ -17,7 +17,7 @@
port->bulk_in_size = buffer_size; port->bulk_in_size = buffer_size;
port->bulk_in_endpointAddress = endpoint->bEndpointAddress; port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL); port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
@@ -1292,3 +1293,5 @@ MODULE_LICENSE("GPL"); @@ -1255,3 +1256,5 @@ MODULE_LICENSE("GPL");
module_param(debug, bool, S_IRUGO | S_IWUSR); module_param(debug, bool, S_IRUGO | S_IWUSR);
MODULE_PARM_DESC(debug, "Debug enabled or not"); MODULE_PARM_DESC(debug, "Debug enabled or not");