image.mk: prepare for defining device profile data in the Device section
Signed-off-by: Felix Fietkau <nbd@nbd.name>
This commit is contained in:
parent
40f933d7ff
commit
bcf67b6974
1 changed files with 24 additions and 1 deletions
|
@ -439,6 +439,9 @@ endef
|
||||||
define Device/Init
|
define Device/Init
|
||||||
PROFILES := $(PROFILE)
|
PROFILES := $(PROFILE)
|
||||||
DEVICE_NAME := $(1)
|
DEVICE_NAME := $(1)
|
||||||
|
DEVICE_TITLE :=
|
||||||
|
DEVICE_PACKAGES :=
|
||||||
|
DEVICE_DESCRIPTION = Build firmware images for $$(DEVICE_TITLE)
|
||||||
KERNEL:=
|
KERNEL:=
|
||||||
KERNEL_INITRAMFS = $$(KERNEL)
|
KERNEL_INITRAMFS = $$(KERNEL)
|
||||||
KERNEL_SIZE:=
|
KERNEL_SIZE:=
|
||||||
|
@ -548,17 +551,37 @@ define Device/Build
|
||||||
$$(call Device/Build/image,$$(fs),$$(image),$(1)))))
|
$$(call Device/Build/image,$$(fs),$$(image),$(1)))))
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Device/DumpInfo
|
||||||
|
Target-Profile: DEVICE_$(1)
|
||||||
|
Target-Profile-Name: $(DEVICE_TITLE)
|
||||||
|
Target-Profile-Packages: $(DEVICE_PACKAGES)
|
||||||
|
Target-Profile-Description:
|
||||||
|
$(DEVICE_DESCRIPTION)
|
||||||
|
@@
|
||||||
|
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Device/Dump
|
||||||
|
$$(eval $$(if $$(DEVICE_TITLE),$$(info $$(call Device/DumpInfo,$(1)))))
|
||||||
|
endef
|
||||||
|
|
||||||
define Device
|
define Device
|
||||||
$(call Device/Init,$(1))
|
$(call Device/Init,$(1))
|
||||||
$(call Device/Default,$(1))
|
$(call Device/Default,$(1))
|
||||||
$(call Device/Check,$(1))
|
$(call Device/Check,$(1))
|
||||||
$(call Device/$(1),$(1))
|
$(call Device/$(1),$(1))
|
||||||
$(call Device/Build,$(1))
|
$(call Device/$(if $(DUMP),Dump,Build),$(1))
|
||||||
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define BuildImage
|
define BuildImage
|
||||||
|
|
||||||
|
ifneq ($(DUMP),)
|
||||||
|
all: dumpinfo
|
||||||
|
dumpinfo: FORCE
|
||||||
|
@true
|
||||||
|
endif
|
||||||
|
|
||||||
download:
|
download:
|
||||||
prepare:
|
prepare:
|
||||||
compile:
|
compile:
|
||||||
|
|
Loading…
Reference in a new issue