wireless-tools: fix a bug in iwconfig power command
SVN-Revision: 16491
This commit is contained in:
parent
606193fc1f
commit
bb5799aa95
2 changed files with 14 additions and 1 deletions
|
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
|||
PKG_NAME:=wireless-tools
|
||||
PKG_VERSION:=29
|
||||
PKG_MINOR:=
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=wireless_tools.$(PKG_VERSION)$(PKG_MINOR).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
--- a/iwconfig.c
|
||||
+++ b/iwconfig.c
|
||||
@@ -1034,8 +1034,8 @@ set_power_info(int skfd,
|
||||
wrq.u.power.disabled = 0;
|
||||
|
||||
/* Is there any value to grab ? */
|
||||
- value = strtod(args[0], &unit);
|
||||
- if(unit != args[0])
|
||||
+ value = strtod(args[i], &unit);
|
||||
+ if(unit != args[i])
|
||||
{
|
||||
struct iw_range range;
|
||||
int flags;
|
Loading…
Reference in a new issue