add experimental sane-backends package, like to get canon scanner working via saned
SVN-Revision: 2726
This commit is contained in:
parent
bbce027d7d
commit
b93531e40e
6 changed files with 94 additions and 0 deletions
|
@ -31,6 +31,7 @@ source "package/sablevm/Config.in"
|
|||
source "package/sablevm-classpath/Config.in"
|
||||
source "package/libffi-sable/Config.in"
|
||||
endmenu
|
||||
source "package/sane-backends/Config.in"
|
||||
menu "rrdtool........................... Round-Robin Database (RRD) libraries and tools"
|
||||
source "package/rrdtool/Config.in"
|
||||
source "package/rrdtool1/Config.in"
|
||||
|
|
|
@ -181,6 +181,7 @@ package-$(BR2_PACKAGE_RSYNC) += rsync
|
|||
package-$(BR2_PACKAGE_SABLEVM) += sablevm
|
||||
package-$(BR2_COMPILE_SABLEVM_CLASSPATH) += sablevm-classpath
|
||||
package-$(BR2_COMPILE_SAMBA) += samba
|
||||
package-$(BR2_PACKAGE_SANE_BACKENDS) += sane-backends
|
||||
package-$(BR2_PACKAGE_SCDP) += scdp
|
||||
package-$(BR2_PACKAGE_SCREEN) += screen
|
||||
package-$(BR2_PACKAGE_SDK) += sdk
|
||||
|
|
8
openwrt/package/sane-backends/Config.in
Normal file
8
openwrt/package/sane-backends/Config.in
Normal file
|
@ -0,0 +1,8 @@
|
|||
config BR2_PACKAGE_SANE_BACKENDS
|
||||
prompt "sane-backends........................ scanner access now easy"
|
||||
tristate
|
||||
default m if CONFIG_DEVEL
|
||||
help
|
||||
Scanner access now easy
|
||||
|
||||
http://www.sane-project.org
|
68
openwrt/package/sane-backends/Makefile
Normal file
68
openwrt/package/sane-backends/Makefile
Normal file
|
@ -0,0 +1,68 @@
|
|||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sane-backends
|
||||
PKG_VERSION:=1.0.16
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=x
|
||||
|
||||
PKG_SOURCE_URL:=ftp://ftp.sane-project.org/pub/sane/$(PKG_NAME)-$(PKG_VERSION)/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,SANE_BACKENDS,sane-backends,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(strip $(TARGET_CFLAGS))" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--enable-shared \
|
||||
--disable-static \
|
||||
--disable-ipv6 \
|
||||
--disable-translations \
|
||||
--without-gphoto2 \
|
||||
--disable-debug \
|
||||
);
|
||||
touch $(PKG_BUILD_DIR)/.configured
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
install
|
||||
touch $(PKG_BUILD_DIR)/.built
|
||||
|
||||
$(IPKG_SANE_BACKENDS):
|
||||
install -d -m0755 $(IDIR_SANE_BACKENDS)/usr/sbin
|
||||
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/saned $(IDIR_SANE_BACKENDS)/usr/sbin/
|
||||
$(RSTRIP) $(IDIR_SANE_BACKENDS)
|
||||
$(IPKG_BUILD) $(IDIR_SANE_BACKENDS) $(PACKAGE_DIR)
|
4
openwrt/package/sane-backends/ipkg/sane-backends.control
Normal file
4
openwrt/package/sane-backends/ipkg/sane-backends.control
Normal file
|
@ -0,0 +1,4 @@
|
|||
Package: sane-backends
|
||||
Priority: optional
|
||||
Section: misc
|
||||
Description: Scanner access now easy
|
|
@ -0,0 +1,12 @@
|
|||
diff -Nur sane-backends-1.0.16/Makefile.in sane-backends-1.0.16.patched/Makefile.in
|
||||
--- sane-backends-1.0.16/Makefile.in 2005-07-17 13:52:54.000000000 +0200
|
||||
+++ sane-backends-1.0.16.patched/Makefile.in 2005-12-17 00:28:38.144022500 +0100
|
||||
@@ -33,7 +33,7 @@
|
||||
|
||||
@SET_MAKE@
|
||||
|
||||
-SUBDIRS = include lib sanei backend frontend tools doc po
|
||||
+SUBDIRS = include lib sanei backend frontend
|
||||
|
||||
DISTFILES = AUTHORS COPYING ChangeLog ChangeLog-1.0.0 ChangeLog-1.0.1 \
|
||||
ChangeLog-1.0.2 ChangeLog-1.0.3 ChangeLog-1.0.4 ChangeLog-1.0.5 \
|
Loading…
Reference in a new issue