fix gdb compile
SVN-Revision: 14015
This commit is contained in:
parent
ff55a79717
commit
b8aa79853d
2 changed files with 14 additions and 2 deletions
|
@ -22,6 +22,7 @@ include $(INCLUDE_DIR)/host-build.mk
|
|||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
gdb_cv_func_sigsetjmp=yes \
|
||||
CFLAGS="-O2" \
|
||||
$(PKG_BUILD_DIR)/configure \
|
||||
--prefix=$(TOOLCHAIN_DIR)/usr \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
|
@ -48,8 +49,8 @@ endef
|
|||
|
||||
define Build/Clean
|
||||
rm -rf \
|
||||
$(PKG_BUILD_DIR)
|
||||
$(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CROSS)gdb
|
||||
$(PKG_BUILD_DIR) \
|
||||
$(TOOLCHAIN_DIR)/usr/bin/$(TARGET_CROSS)gdb \
|
||||
$(TOOLCHAIN_DIR)/usr/bin/$(GNU_TARGET_NAME)-gdb
|
||||
endef
|
||||
|
||||
|
|
11
toolchain/gdb/patches/910-missing_header.patch
Normal file
11
toolchain/gdb/patches/910-missing_header.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/gdb/inferior.h
|
||||
+++ b/gdb/inferior.h
|
||||
@@ -21,6 +21,8 @@
|
||||
Foundation, Inc., 59 Temple Place - Suite 330,
|
||||
Boston, MA 02111-1307, USA. */
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#if !defined (INFERIOR_H)
|
||||
#define INFERIOR_H 1
|
||||
|
Loading…
Reference in a new issue