deal with 'set-but-unused-variables' in a more generic way
SVN-Revision: 31123
This commit is contained in:
parent
c3bba7f8c6
commit
b4508ce183
1 changed files with 12 additions and 44 deletions
|
@ -1,44 +1,12 @@
|
|||
--- a/arch/mips/kernel/signal.c
|
||||
+++ b/arch/mips/kernel/signal.c
|
||||
@@ -84,7 +84,7 @@ static int protected_save_fp_context(str
|
||||
|
||||
static int protected_restore_fp_context(struct sigcontext __user *sc)
|
||||
{
|
||||
- int err, tmp;
|
||||
+ int err, tmp __maybe_unused;
|
||||
while (1) {
|
||||
lock_fpu_owner();
|
||||
own_fpu_inatomic(0);
|
||||
--- a/arch/mips/kernel/syscall.c
|
||||
+++ b/arch/mips/kernel/syscall.c
|
||||
@@ -383,7 +383,7 @@ save_static_function(sys_sysmips);
|
||||
static int __used noinline
|
||||
_sys_sysmips(nabi_no_regargs struct pt_regs regs)
|
||||
{
|
||||
- long cmd, arg1, arg2, arg3;
|
||||
+ long cmd, arg1, arg2, arg3 __maybe_unused;
|
||||
|
||||
cmd = regs.regs[4];
|
||||
arg1 = regs.regs[5];
|
||||
--- a/arch/mips/mm/init.c
|
||||
+++ b/arch/mips/mm/init.c
|
||||
@@ -324,7 +324,7 @@ int page_is_ram(unsigned long pagenr)
|
||||
void __init paging_init(void)
|
||||
{
|
||||
unsigned long max_zone_pfns[MAX_NR_ZONES];
|
||||
- unsigned long lastpfn;
|
||||
+ unsigned long lastpfn __maybe_unused;
|
||||
|
||||
pagetable_init();
|
||||
|
||||
--- a/arch/mips/mm/c-r4k.c
|
||||
+++ b/arch/mips/mm/c-r4k.c
|
||||
@@ -1075,7 +1075,7 @@ static int __cpuinit probe_scache(void)
|
||||
unsigned long flags, addr, begin, end, pow2;
|
||||
unsigned int config = read_c0_config();
|
||||
struct cpuinfo_mips *c = ¤t_cpu_data;
|
||||
- int tmp;
|
||||
+ int tmp __maybe_unused;
|
||||
|
||||
if (config & CONF_SC)
|
||||
return 0;
|
||||
--- linux-2.6.37.6.org/Makefile 2012-03-28 17:10:58.297558774 +0200
|
||||
+++ linux-2.6.37.6.mod/Makefile 2012-03-28 17:15:00.161564521 +0200
|
||||
@@ -354,7 +354,8 @@
|
||||
-fno-strict-aliasing -fno-common \
|
||||
-Werror-implicit-function-declaration \
|
||||
-Wno-format-security \
|
||||
- -fno-delete-null-pointer-checks
|
||||
+ -fno-delete-null-pointer-checks \
|
||||
+ -Wno-error=unused-but-set-variable
|
||||
KBUILD_AFLAGS_KERNEL :=
|
||||
KBUILD_CFLAGS_KERNEL :=
|
||||
KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||
|
|
Loading…
Reference in a new issue