kernel: update linux 3.2 to 3.2.2
SVN-Revision: 29967
This commit is contained in:
parent
1015fab0d7
commit
b3568b10c2
8 changed files with 15 additions and 25 deletions
|
@ -35,8 +35,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),3.1.10)
|
||||
LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),3.2.1)
|
||||
LINUX_KERNEL_MD5SUM:=090eb3dae0f520f7770f85193e931ad3
|
||||
ifeq ($(LINUX_VERSION),3.2.2)
|
||||
LINUX_KERNEL_MD5SUM:=c0303125c8eda431b10084eece7564e3
|
||||
endif
|
||||
|
||||
# disable the md5sum check for unknown kernel versions
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=jffs2 usb pci
|
|||
SUBTARGETS=au1500 au1550
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.2.1
|
||||
LINUX_VERSION:=3.2.2
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += wpad-mini yamonenv
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb
|
|||
CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
|
||||
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
|
||||
|
||||
LINUX_VERSION:=3.2.1
|
||||
LINUX_VERSION:=3.2.2
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/mm/shmem.c
|
||||
+++ b/mm/shmem.c
|
||||
@@ -2462,6 +2462,16 @@ EXPORT_SYMBOL_GPL(shmem_truncate_range);
|
||||
@@ -2491,6 +2491,16 @@ EXPORT_SYMBOL_GPL(shmem_truncate_range);
|
||||
|
||||
/* common code */
|
||||
|
||||
|
@ -17,7 +17,7 @@
|
|||
/**
|
||||
* shmem_file_setup - get an unlinked file living in tmpfs
|
||||
* @name: name for dentry (to be seen in /proc/<pid>/maps
|
||||
@@ -2539,11 +2549,8 @@ int shmem_zero_setup(struct vm_area_stru
|
||||
@@ -2568,11 +2578,8 @@ int shmem_zero_setup(struct vm_area_stru
|
||||
if (IS_ERR(file))
|
||||
return PTR_ERR(file);
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=omap4
|
|||
BOARDNAME:=TI OMAP4
|
||||
FEATURES:=usb targz
|
||||
|
||||
LINUX_VERSION:=3.2.1
|
||||
LINUX_VERSION:=3.2.2
|
||||
CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
|
||||
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
|
||||
|
||||
|
|
|
@ -43,11 +43,9 @@ Signed-off-by: Paul Walmsley <paul@pwsan.com>
|
|||
Signed-off-by: Tony Lindgren <tony@atomide.com>
|
||||
---
|
||||
|
||||
diff --git a/arch/arm/mach-omap2/omap_hwmod.c b/arch/arm/mach-omap2/omap_hwmod.c
|
||||
index 207a2ff..ebace0f 100644
|
||||
--- a/arch/arm/mach-omap2/omap_hwmod.c
|
||||
+++ b/arch/arm/mach-omap2/omap_hwmod.c
|
||||
@@ -706,27 +706,65 @@ static void _enable_module(struct omap_hwmod *oh)
|
||||
@@ -706,27 +706,65 @@ static void _enable_module(struct omap_h
|
||||
}
|
||||
|
||||
/**
|
||||
|
@ -120,7 +118,7 @@ index 207a2ff..ebace0f 100644
|
|||
}
|
||||
|
||||
/**
|
||||
@@ -1153,36 +1191,6 @@ static int _wait_target_ready(struct omap_hwmod *oh)
|
||||
@@ -1153,36 +1191,6 @@ static int _wait_target_ready(struct oma
|
||||
}
|
||||
|
||||
/**
|
||||
|
@ -157,7 +155,7 @@ index 207a2ff..ebace0f 100644
|
|||
* _lookup_hardreset - fill register bit info for this hwmod/reset line
|
||||
* @oh: struct omap_hwmod *
|
||||
* @name: name of the reset line in the context of this hwmod
|
||||
@@ -1524,8 +1532,6 @@ static int _enable(struct omap_hwmod *oh)
|
||||
@@ -1524,8 +1532,6 @@ static int _enable(struct omap_hwmod *oh
|
||||
*/
|
||||
static int _idle(struct omap_hwmod *oh)
|
||||
{
|
||||
|
@ -181,7 +179,7 @@ index 207a2ff..ebace0f 100644
|
|||
/*
|
||||
* The module must be in idle mode before disabling any parents
|
||||
* clocks. Otherwise, the parent clock might be disabled before
|
||||
@@ -1642,11 +1646,7 @@ static int _shutdown(struct omap_hwmod *oh)
|
||||
@@ -1642,11 +1646,7 @@ static int _shutdown(struct omap_hwmod *
|
||||
if (oh->_state == _HWMOD_STATE_ENABLED) {
|
||||
_del_initiator_dep(oh, mpu_oh);
|
||||
/* XXX what about the other system initiators here? dma, dsp */
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
diff --git a/arch/arm/mach-omap2/twl-common.c b/arch/arm/mach-omap2/twl-common.c
|
||||
index daa056e..fe03b09 100644
|
||||
--- a/arch/arm/mach-omap2/twl-common.c
|
||||
+++ b/arch/arm/mach-omap2/twl-common.c
|
||||
@@ -261,6 +261,7 @@ static struct regulator_init_data omap4_vusb_idata = {
|
||||
@@ -281,6 +281,7 @@ static struct regulator_init_data omap4_
|
||||
static struct regulator_init_data omap4_clk32kg_idata = {
|
||||
.constraints = {
|
||||
.valid_ops_mask = REGULATOR_CHANGE_STATUS,
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
diff --git a/arch/arm/mach-omap2/id.c b/arch/arm/mach-omap2/id.c
|
||||
index 7f47092..2a05d3d 100644
|
||||
--- a/arch/arm/mach-omap2/id.c
|
||||
+++ b/arch/arm/mach-omap2/id.c
|
||||
@@ -389,8 +389,10 @@ static void __init omap4_check_revision(void)
|
||||
@@ -389,8 +389,10 @@ static void __init omap4_check_revision(
|
||||
omap_revision = OMAP4430_REV_ES2_1;
|
||||
break;
|
||||
case 4:
|
||||
|
@ -14,7 +12,7 @@ index 7f47092..2a05d3d 100644
|
|||
}
|
||||
break;
|
||||
case 0xb94e:
|
||||
@@ -403,7 +405,7 @@ static void __init omap4_check_revision(void)
|
||||
@@ -403,7 +405,7 @@ static void __init omap4_check_revision(
|
||||
break;
|
||||
default:
|
||||
/* Unknown default to latest silicon rev as default */
|
||||
|
@ -23,11 +21,9 @@ index 7f47092..2a05d3d 100644
|
|||
}
|
||||
|
||||
pr_info("OMAP%04x ES%d.%d\n", omap_rev() >> 16,
|
||||
diff --git a/arch/arm/mach-omap2/omap_hwmod_44xx_data.c b/arch/arm/mach-omap2/omap_hwmod_44xx_data.c
|
||||
index 7695e5d..71d3e36 100644
|
||||
--- a/arch/arm/mach-omap2/omap_hwmod_44xx_data.c
|
||||
+++ b/arch/arm/mach-omap2/omap_hwmod_44xx_data.c
|
||||
@@ -2257,7 +2257,8 @@ static struct omap_hwmod_class omap44xx_i2c_hwmod_class = {
|
||||
@@ -2257,7 +2257,8 @@ static struct omap_hwmod_class omap44xx_
|
||||
};
|
||||
|
||||
static struct omap_i2c_dev_attr i2c_dev_attr = {
|
||||
|
@ -37,8 +33,6 @@ index 7695e5d..71d3e36 100644
|
|||
};
|
||||
|
||||
/* i2c1 */
|
||||
diff --git a/arch/arm/plat-omap/include/plat/cpu.h b/arch/arm/plat-omap/include/plat/cpu.h
|
||||
index 408a12f..e279395 100644
|
||||
--- a/arch/arm/plat-omap/include/plat/cpu.h
|
||||
+++ b/arch/arm/plat-omap/include/plat/cpu.h
|
||||
@@ -391,6 +391,7 @@ IS_OMAP_TYPE(3517, 0x3517)
|
||||
|
|
Loading…
Reference in a new issue