curl: bump to 7.56.1
Refresh patches Remove 320-curl-confopts.m4-fix-disable-threaded-resolver.patch as integrated upstream See https://curl.haxx.se/changes.html for the bugfixes in 7.56.0 and 7.56.1 Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
This commit is contained in:
parent
f6c01306cb
commit
b00cf0e58e
3 changed files with 5 additions and 41 deletions
|
@ -8,15 +8,15 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=curl
|
PKG_NAME:=curl
|
||||||
PKG_VERSION:=7.55.1
|
PKG_VERSION:=7.56.1
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
|
PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
|
||||||
http://curl.mirror.anstey.ca/ \
|
http://curl.mirror.anstey.ca/ \
|
||||||
http://curl.askapache.com/download/ \
|
http://curl.askapache.com/download/ \
|
||||||
https://curl.haxx.se/download/
|
https://curl.haxx.se/download/
|
||||||
PKG_HASH:=e5b1a92ed3b0c11f149886458fa063419500819f1610c020d62f25b8e4b16cfb
|
PKG_HASH:=2594670367875e7d87b0f129b5e4690150780884d90244ba0fe3e74a778b5f90
|
||||||
|
|
||||||
PKG_LICENSE:=MIT
|
PKG_LICENSE:=MIT
|
||||||
PKG_LICENSE_FILES:=COPYING
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
|
@ -1,8 +1,8 @@
|
||||||
--- a/lib/vtls/mbedtls.c
|
--- a/lib/vtls/mbedtls.c
|
||||||
+++ b/lib/vtls/mbedtls.c
|
+++ b/lib/vtls/mbedtls.c
|
||||||
@@ -796,7 +796,7 @@ void Curl_mbedtls_session_free(void *ptr
|
@@ -814,7 +814,7 @@ static void Curl_mbedtls_session_free(vo
|
||||||
|
|
||||||
size_t Curl_mbedtls_version(char *buffer, size_t size)
|
static size_t Curl_mbedtls_version(char *buffer, size_t size)
|
||||||
{
|
{
|
||||||
- unsigned int version = mbedtls_version_get_number();
|
- unsigned int version = mbedtls_version_get_number();
|
||||||
+ unsigned int version = MBEDTLS_VERSION_NUMBER;
|
+ unsigned int version = MBEDTLS_VERSION_NUMBER;
|
||||||
|
|
|
@ -1,36 +0,0 @@
|
||||||
From 3cb4bb6b5fb8a936cb69e2e9ea6a4e692122abb9 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jakub Zakrzewski <slither.jz@gmail.com>
|
|
||||||
Date: Tue, 15 Aug 2017 13:21:33 -0400
|
|
||||||
Subject: [PATCH] curl-confopts.m4: fix --disable-threaded-resolver
|
|
||||||
|
|
||||||
Closes https://github.com/curl/curl/issues/1784
|
|
||||||
---
|
|
||||||
m4/curl-confopts.m4 | 8 ++++----
|
|
||||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/m4/curl-confopts.m4 b/m4/curl-confopts.m4
|
|
||||||
index d77a884..6dcd0f1 100644
|
|
||||||
--- a/m4/curl-confopts.m4
|
|
||||||
+++ b/m4/curl-confopts.m4
|
|
||||||
@@ -37,14 +37,14 @@ AC_HELP_STRING([--enable-threaded-resolver],[Enable threaded resolver])
|
|
||||||
AC_HELP_STRING([--disable-threaded-resolver],[Disable threaded resolver]),
|
|
||||||
OPT_THRES=$enableval)
|
|
||||||
case "$OPT_THRES" in
|
|
||||||
- *)
|
|
||||||
- dnl configure option not specified
|
|
||||||
- want_thres="yes"
|
|
||||||
- ;;
|
|
||||||
no)
|
|
||||||
dnl --disable-threaded-resolver option used
|
|
||||||
want_thres="no"
|
|
||||||
;;
|
|
||||||
+ *)
|
|
||||||
+ dnl configure option not specified
|
|
||||||
+ want_thres="yes"
|
|
||||||
+ ;;
|
|
||||||
esac
|
|
||||||
AC_MSG_RESULT([$want_thres])
|
|
||||||
])
|
|
||||||
--
|
|
||||||
1.9.1
|
|
||||||
|
|
Loading…
Reference in a new issue