gcc: add an updated version of 4.4.1+cs - successfully builds a toolchain now, please test!
SVN-Revision: 23101
This commit is contained in:
parent
c749f9a924
commit
affb66c2c6
8 changed files with 29776 additions and 69073 deletions
|
@ -58,7 +58,6 @@ choice
|
|||
|
||||
config GCC_VERSION_4_4_1_CS
|
||||
bool "gcc 4.4.1 with CodeSourcery enhancements"
|
||||
depends BROKEN
|
||||
|
||||
config GCC_VERSION_4_4_3_CS
|
||||
bool "gcc 4.4.3 with CodeSourcery enhancements"
|
||||
|
|
File diff suppressed because it is too large
Load diff
29759
toolchain/gcc/patches/4.4.1+cs/000-codesourcery_2010_71.patch
Normal file
29759
toolchain/gcc/patches/4.4.1+cs/000-codesourcery_2010_71.patch
Normal file
File diff suppressed because it is too large
Load diff
|
@ -1,24 +1,6 @@
|
|||
--- a/config.sub
|
||||
+++ b/config.sub
|
||||
@@ -283,6 +283,7 @@ case $basic_machine in
|
||||
| sparcv8 | sparcv9 | sparcv9b | sparcv9v \
|
||||
| spu | strongarm \
|
||||
| tahoe | thumb | tic4x | tic80 | tron \
|
||||
+ | ubicom32 \
|
||||
| v850 | v850e \
|
||||
| ubicom32 \
|
||||
| we32k \
|
||||
@@ -367,6 +368,7 @@ case $basic_machine in
|
||||
| tahoe-* | thumb-* \
|
||||
| tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
|
||||
| tron-* \
|
||||
+ | ubicom32-* \
|
||||
| v850-* | v850e-* | vax-* \
|
||||
| ubicom32-* \
|
||||
| we32k-* \
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -2688,6 +2688,9 @@ case "${target}" in
|
||||
@@ -2688,6 +2688,9 @@
|
||||
ip2k-*-*)
|
||||
noconfigdirs="$noconfigdirs target-libiberty target-libstdc++-v3 ${libgcj}"
|
||||
;;
|
||||
|
@ -9331,7 +9313,7 @@
|
|||
+#define FATAL_EXIT_CODE 33
|
||||
--- a/gcc/config.gcc
|
||||
+++ b/gcc/config.gcc
|
||||
@@ -2314,6 +2314,34 @@ spu-*-elf*)
|
||||
@@ -2320,6 +2320,34 @@
|
||||
c_target_objs="${c_target_objs} spu-c.o"
|
||||
cxx_target_objs="${cxx_target_objs} spu-c.o"
|
||||
;;
|
||||
|
@ -9368,7 +9350,7 @@
|
|||
tm_file="dbxelf.h elfos.h svr4.h v850/v850.h"
|
||||
--- a/libgcc/config.host
|
||||
+++ b/libgcc/config.host
|
||||
@@ -551,6 +551,15 @@ sparc64-*-netbsd*)
|
||||
@@ -562,6 +562,15 @@
|
||||
;;
|
||||
spu-*-elf*)
|
||||
;;
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/libgcc/Makefile.in
|
||||
+++ b/libgcc/Makefile.in
|
||||
@@ -729,11 +729,12 @@ $(libgcov-objects): %$(objext): $(gcc_sr
|
||||
@@ -735,11 +735,12 @@
|
||||
|
||||
# Static libraries.
|
||||
libgcc.a: $(libgcc-objects)
|
||||
|
@ -14,7 +14,7 @@
|
|||
-rm -f $@
|
||||
|
||||
objects="$(objects)"; \
|
||||
@@ -755,7 +756,7 @@ libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_E
|
||||
@@ -761,7 +762,7 @@
|
||||
endif
|
||||
|
||||
ifeq ($(enable_shared),yes)
|
||||
|
@ -23,7 +23,7 @@
|
|||
ifneq ($(LIBUNWIND),)
|
||||
all: libunwind$(SHLIB_EXT)
|
||||
endif
|
||||
@@ -928,6 +929,10 @@ install-shared:
|
||||
@@ -934,6 +935,10 @@
|
||||
chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
|
||||
$(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@
|
|||
|
||||
--- a/gcc/c-opts.c
|
||||
+++ b/gcc/c-opts.c
|
||||
@@ -105,6 +105,9 @@
|
||||
@@ -106,6 +106,9 @@
|
||||
/* Number of deferred options scanned for -include. */
|
||||
static size_t include_cursor;
|
||||
|
||||
|
@ -23,7 +23,7 @@
|
|||
static void set_Wimplicit (int);
|
||||
static void handle_OPT_d (const char *);
|
||||
static void set_std_cxx98 (int);
|
||||
@@ -690,6 +701,12 @@
|
||||
@@ -689,6 +692,12 @@
|
||||
flag_exceptions = value;
|
||||
break;
|
||||
|
||||
|
@ -36,7 +36,7 @@
|
|||
case OPT_fimplement_inlines:
|
||||
flag_implement_inlines = value;
|
||||
break;
|
||||
@@ -1209,6 +1226,47 @@
|
||||
@@ -1198,6 +1207,47 @@
|
||||
return false;
|
||||
}
|
||||
|
||||
|
@ -86,7 +86,7 @@
|
|||
|
||||
--- a/gcc/c.opt
|
||||
+++ b/gcc/c.opt
|
||||
@@ -609,6 +613,9 @@
|
||||
@@ -609,6 +609,9 @@
|
||||
fhonor-std
|
||||
C++ ObjC++
|
||||
|
||||
|
@ -98,7 +98,7 @@
|
|||
Assume normal C execution environment
|
||||
--- a/gcc/common.opt
|
||||
+++ b/gcc/common.opt
|
||||
@@ -573,6 +577,9 @@
|
||||
@@ -587,6 +587,9 @@
|
||||
Common Report Var(flag_guess_branch_prob) Optimization
|
||||
Enable guessing of branch probabilities
|
||||
|
||||
|
@ -142,7 +142,7 @@
|
|||
break;
|
||||
--- a/gcc/doc/invoke.texi
|
||||
+++ b/gcc/doc/invoke.texi
|
||||
@@ -5699,7 +5715,7 @@
|
||||
@@ -5699,7 +5699,7 @@
|
||||
second branch or a point immediately following it, depending on whether
|
||||
the condition is known to be true or false.
|
||||
|
||||
|
@ -151,7 +151,7 @@
|
|||
|
||||
@item -fsplit-wide-types
|
||||
@opindex fsplit-wide-types
|
||||
@@ -5844,7 +5860,7 @@
|
||||
@@ -5844,7 +5844,7 @@
|
||||
@option{-fno-delete-null-pointer-checks} to disable this optimization
|
||||
for programs which depend on that behavior.
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- gcc-4.4.0/gcc/config/arm/arm-protos.h 2009-02-20 16:20:38.000000000 +0100
|
||||
+++ gcc-4.4.0.new/gcc/config/arm/arm-protos.h 2009-04-22 16:00:58.000000000 +0200
|
||||
--- a/gcc/config/arm/arm-protos.h
|
||||
+++ b/gcc/config/arm/arm-protos.h
|
||||
@@ -43,10 +43,10 @@
|
||||
extern void arm_output_fn_unwind (FILE *, bool);
|
||||
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
Index: gcc-4.4.1/gcc/config.gcc
|
||||
===================================================================
|
||||
--- gcc-4.4.1.orig/gcc/config.gcc 2009-10-21 16:14:24.000000000 +0200
|
||||
+++ gcc-4.4.1/gcc/config.gcc 2009-10-21 16:14:25.000000000 +0200
|
||||
--- a/gcc/config.gcc
|
||||
+++ b/gcc/config.gcc
|
||||
@@ -1499,6 +1499,7 @@
|
||||
if test x$sjlj != x1; then
|
||||
tmake_file="$tmake_file m68k/t-slibgcc-elf-ver"
|
||||
|
|
Loading…
Reference in a new issue