use host-side lzma decompression tool, lzma-4.32 from openwrt produces non-working bzImages, switch to 2.6.30, strip down kernel configuration

SVN-Revision: 18325
This commit is contained in:
Florian Fainelli 2009-11-06 08:42:41 +00:00
parent 186b555e56
commit ad2bd568f5
3 changed files with 11 additions and 4 deletions

View file

@ -12,7 +12,7 @@ BOARDNAME:=RDC 321x
FEATURES:=squashfs jffs2 pci usb
CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
LINUX_VERSION:=2.6.28.10
LINUX_VERSION:=2.6.30.9
include $(INCLUDE_DIR)/target.mk

View file

@ -60,8 +60,7 @@ CONFIG_DEVPORT=y
# CONFIG_DMA_API_DEBUG is not set
# CONFIG_DMI is not set
CONFIG_DOUBLEFAULT=y
CONFIG_EARLY_PRINTK=y
# CONFIG_EARLY_PRINTK_DBGP is not set
# CONFIG_EARLY_PRINTK is not set
# CONFIG_EDAC is not set
# CONFIG_EDD is not set
# CONFIG_EUROTECH_WDT is not set
@ -302,7 +301,7 @@ CONFIG_X86_RDC321X=y
CONFIG_X86_REBOOTFIXUPS=y
# CONFIG_X86_RESERVE_LOW_64K is not set
# CONFIG_X86_UP_APIC is not set
CONFIG_X86_VERBOSE_BOOTUP=y
# CONFIG_X86_VERBOSE_BOOTUP is not set
CONFIG_X86_WP_WORKS_OK=y
CONFIG_X86_XADD=y
# CONFIG_ZONE_DMA32 is not set

View file

@ -0,0 +1,8 @@
--- a/scripts/Makefile.lib 2009-11-06 08:55:20.000000000 +0100
+++ b/scripts/Makefile.lib 2009-11-06 09:08:45.000000000 +0100
@@ -204,4 +204,4 @@
# ---------------------------------------------------------------------------
quiet_cmd_lzma = LZMA $@
-cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
+cmd_lzma = (/usr/bin/lzma -9 -c $< ; $(size_append) $<) >$@ || (rm -f $@ ; false)