remove the custom Build/Prepare override in binutils, use PATCH_DIR, refresh patches using quilt
SVN-Revision: 7752
This commit is contained in:
parent
f6a92d6ffe
commit
a81db04ee6
14 changed files with 2268 additions and 2130 deletions
|
@ -20,17 +20,10 @@ PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
|
|||
PKG_MD5SUM:=unknown
|
||||
PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_CAT:=bzcat
|
||||
PATCH_DIR:=./patches/$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
if [ -d ./patches/$(PKG_VERSION) ]; then \
|
||||
$(SCRIPT_DIR)/patch-kernel.sh $(PKG_BUILD_DIR) ./patches/$(PKG_VERSION); \
|
||||
fi
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
./configure \
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
--- binutils-2.16.91.0.7/bfd/configure
|
||||
+++ binutils-2.16.91.0.7/bfd/configure
|
||||
Index: binutils-2.17/bfd/configure
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/bfd/configure 2007-06-28 09:19:34.892931920 +0200
|
||||
+++ binutils-2.17/bfd/configure 2007-06-28 09:19:35.023912008 +0200
|
||||
@@ -3576,7 +3576,7 @@
|
||||
;;
|
||||
|
||||
|
@ -9,8 +11,10 @@
|
|||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
--- binutils-2.16.91.0.7/binutils/configure
|
||||
+++ binutils-2.16.91.0.7/binutils/configure
|
||||
Index: binutils-2.17/binutils/configure
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/binutils/configure 2007-06-28 09:19:34.898931008 +0200
|
||||
+++ binutils-2.17/binutils/configure 2007-06-28 09:19:35.028911248 +0200
|
||||
@@ -3411,7 +3411,7 @@
|
||||
;;
|
||||
|
||||
|
@ -20,9 +24,11 @@
|
|||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
--- binutils-2.16.91.0.7/configure
|
||||
+++ binutils-2.16.91.0.7/configure
|
||||
@@ -1270,7 +1270,7 @@
|
||||
Index: binutils-2.17/configure
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/configure 2007-06-28 09:19:34.903930248 +0200
|
||||
+++ binutils-2.17/configure 2007-06-28 09:19:35.030910944 +0200
|
||||
@@ -1276,7 +1276,7 @@
|
||||
am33_2.0-*-linux*)
|
||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
||||
;;
|
||||
|
@ -31,7 +37,7 @@
|
|||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
||||
;;
|
||||
sh*-*-pe|mips*-*-pe|*arm-wince-pe)
|
||||
@@ -1578,7 +1578,7 @@
|
||||
@@ -1584,7 +1584,7 @@
|
||||
romp-*-*)
|
||||
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
|
||||
;;
|
||||
|
@ -40,8 +46,10 @@
|
|||
case "${host}" in
|
||||
i[3456789]86-*-vsta) ;; # don't add gprof back in
|
||||
i[3456789]86-*-go32*) ;; # don't add gprof back in
|
||||
--- binutils-2.16.91.0.7/configure.in
|
||||
+++ binutils-2.16.91.0.7/configure.in
|
||||
Index: binutils-2.17/configure.in
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/configure.in 2007-06-28 09:19:34.909929336 +0200
|
||||
+++ binutils-2.17/configure.in 2007-06-28 09:19:35.031910792 +0200
|
||||
@@ -468,7 +468,7 @@
|
||||
am33_2.0-*-linux*)
|
||||
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
|
||||
|
@ -60,8 +68,10 @@
|
|||
case "${host}" in
|
||||
i[[3456789]]86-*-vsta) ;; # don't add gprof back in
|
||||
i[[3456789]]86-*-go32*) ;; # don't add gprof back in
|
||||
--- binutils-2.16.91.0.7/gas/configure
|
||||
+++ binutils-2.16.91.0.7/gas/configure
|
||||
Index: binutils-2.17/gas/configure
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/gas/configure 2007-06-28 09:19:34.915928424 +0200
|
||||
+++ binutils-2.17/gas/configure 2007-06-28 09:19:35.035910184 +0200
|
||||
@@ -3411,7 +3411,7 @@
|
||||
;;
|
||||
|
||||
|
@ -71,10 +81,12 @@
|
|||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
--- binutils-2.16.91.0.7/gprof/configure
|
||||
+++ binutils-2.16.91.0.7/gprof/configure
|
||||
@@ -3419,6 +3419,11 @@
|
||||
lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
|
||||
Index: binutils-2.17/gprof/configure
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/gprof/configure 2007-06-28 09:19:34.921927512 +0200
|
||||
+++ binutils-2.17/gprof/configure 2007-06-28 09:19:35.042909120 +0200
|
||||
@@ -3414,6 +3414,11 @@
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
|
@ -85,8 +97,10 @@
|
|||
netbsd* | knetbsd*-gnu)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
||||
--- binutils-2.16.91.0.7/ld/configure
|
||||
+++ binutils-2.16.91.0.7/ld/configure
|
||||
Index: binutils-2.17/ld/configure
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/ld/configure 2007-06-28 09:19:34.927926600 +0200
|
||||
+++ binutils-2.17/ld/configure 2007-06-28 09:19:35.046908512 +0200
|
||||
@@ -3413,7 +3413,7 @@
|
||||
;;
|
||||
|
||||
|
@ -96,8 +110,10 @@
|
|||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
--- binutils-2.16.91.0.7/libtool.m4
|
||||
+++ binutils-2.16.91.0.7/libtool.m4
|
||||
Index: binutils-2.17/libtool.m4
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/libtool.m4 2007-06-28 09:19:34.933925688 +0200
|
||||
+++ binutils-2.17/libtool.m4 2007-06-28 09:19:35.047908360 +0200
|
||||
@@ -739,7 +739,7 @@
|
||||
;;
|
||||
|
||||
|
@ -107,8 +123,10 @@
|
|||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
--- binutils-2.16.91.0.7/ltconfig
|
||||
+++ binutils-2.16.91.0.7/ltconfig
|
||||
Index: binutils-2.17/ltconfig
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/ltconfig 2007-06-28 09:19:34.939924776 +0200
|
||||
+++ binutils-2.17/ltconfig 2007-06-28 09:19:35.048908208 +0200
|
||||
@@ -602,6 +602,7 @@
|
||||
|
||||
# Transform linux* to *-*-linux-gnu*, to support old configure scripts.
|
||||
|
@ -126,8 +144,10 @@
|
|||
version_type=linux
|
||||
need_lib_prefix=no
|
||||
need_version=no
|
||||
--- binutils-2.16.91.0.7/opcodes/configure
|
||||
+++ binutils-2.16.91.0.7/opcodes/configure
|
||||
Index: binutils-2.17/opcodes/configure
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/opcodes/configure 2007-06-28 09:19:34.946923712 +0200
|
||||
+++ binutils-2.17/opcodes/configure 2007-06-28 09:19:35.051907752 +0200
|
||||
@@ -3579,7 +3579,7 @@
|
||||
;;
|
||||
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
diff -urN binutils-2.16.91.0.7.orig/configure binutils-2.16.91.0.7/configure
|
||||
--- binutils-2.16.91.0.7.orig/configure 2006-05-31 14:54:24.000000000 +0300
|
||||
+++ binutils-2.16.91.0.7/configure 2006-05-31 14:55:53.000000000 +0300
|
||||
@@ -1299,7 +1299,7 @@
|
||||
Index: binutils-2.17/configure
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/configure 2007-06-28 09:19:35.030910944 +0200
|
||||
+++ binutils-2.17/configure 2007-06-28 09:19:35.592825520 +0200
|
||||
@@ -1305,7 +1305,7 @@
|
||||
arm-*-elf* | strongarm-*-elf* | xscale-*-elf* | arm*-*-eabi* )
|
||||
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
||||
;;
|
||||
|
@ -10,9 +11,10 @@ diff -urN binutils-2.16.91.0.7.orig/configure binutils-2.16.91.0.7/configure
|
|||
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
||||
noconfigdirs="$noconfigdirs target-libjava target-libobjc"
|
||||
;;
|
||||
diff -urN binutils-2.16.91.0.7.orig/configure.in binutils-2.16.91.0.7/configure.in
|
||||
--- binutils-2.16.91.0.7.orig/configure.in 2006-05-31 14:54:24.000000000 +0300
|
||||
+++ binutils-2.16.91.0.7/configure.in 2006-05-31 14:55:53.000000000 +0300
|
||||
Index: binutils-2.17/configure.in
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/configure.in 2007-06-28 09:19:35.031910792 +0200
|
||||
+++ binutils-2.17/configure.in 2007-06-28 09:19:35.593825368 +0200
|
||||
@@ -497,7 +497,7 @@
|
||||
arm-*-elf* | strongarm-*-elf* | xscale-*-elf* | arm*-*-eabi* )
|
||||
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
||||
|
|
|
@ -26,8 +26,10 @@ esac
|
|||
exit 0
|
||||
|
||||
@DPATCH@
|
||||
--- binutils-2.16.91.0.1/ld/Makefile.am
|
||||
+++ binutils-2.16.91.0.1/ld/Makefile.am
|
||||
Index: binutils-2.17/ld/Makefile.am
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/ld/Makefile.am 2007-06-28 09:19:34.837940280 +0200
|
||||
+++ binutils-2.17/ld/Makefile.am 2007-06-28 09:19:35.795794664 +0200
|
||||
@@ -20,7 +20,7 @@
|
||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||
|
@ -37,9 +39,11 @@ exit 0
|
|||
|
||||
EMUL = @EMUL@
|
||||
EMULATION_OFILES = @EMULATION_OFILES@
|
||||
--- binutils-2.16.91.0.1/ld/Makefile.in
|
||||
+++ binutils-2.16.91.0.1/ld/Makefile.in
|
||||
@@ -268,7 +268,7 @@
|
||||
Index: binutils-2.17/ld/Makefile.in
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/ld/Makefile.in 2007-06-28 09:19:34.844939216 +0200
|
||||
+++ binutils-2.17/ld/Makefile.in 2007-06-28 09:19:35.796794512 +0200
|
||||
@@ -269,7 +269,7 @@
|
||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||
# directives need to be different for native and cross linkers.
|
||||
|
|
|
@ -24,10 +24,11 @@ esac
|
|||
exit 0
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad /home/james/debian/packages/binutils/binutils-2.14.90.0.6/bfd/opncls.c binutils-2.14.90.0.6/bfd/opncls.c
|
||||
--- /home/james/debian/packages/binutils/binutils-2.14.90.0.6/bfd/opncls.c 2003-07-23 16:08:09.000000000 +0100
|
||||
+++ binutils-2.14.90.0.6/bfd/opncls.c 2003-09-10 22:35:00.000000000 +0100
|
||||
@@ -150,6 +150,13 @@
|
||||
Index: binutils-2.17/bfd/opncls.c
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/bfd/opncls.c 2007-06-28 09:19:34.818943168 +0200
|
||||
+++ binutils-2.17/bfd/opncls.c 2007-06-28 09:19:35.993764568 +0200
|
||||
@@ -158,6 +158,13 @@
|
||||
{
|
||||
bfd *nbfd;
|
||||
const bfd_target *target_vec;
|
||||
|
|
|
@ -24,10 +24,11 @@ esac
|
|||
exit 0
|
||||
|
||||
@DPATCH@
|
||||
diff -urNad /home/james/debian/packages/binutils/new/binutils-2.15/ld/emultempl/elf32.em binutils-2.15/ld/emultempl/elf32.em
|
||||
--- /home/james/debian/packages/binutils/new/binutils-2.15/ld/emultempl/elf32.em 2004-05-21 23:12:58.000000000 +0100
|
||||
+++ binutils-2.15/ld/emultempl/elf32.em 2004-05-21 23:12:59.000000000 +0100
|
||||
@@ -692,6 +692,8 @@
|
||||
Index: binutils-2.17/ld/emultempl/elf32.em
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/ld/emultempl/elf32.em 2007-06-28 09:19:34.796946512 +0200
|
||||
+++ binutils-2.17/ld/emultempl/elf32.em 2007-06-28 09:19:36.178736448 +0200
|
||||
@@ -970,6 +970,8 @@
|
||||
&& command_line.rpath == NULL)
|
||||
{
|
||||
lib_path = (const char *) getenv ("LD_RUN_PATH");
|
||||
|
@ -36,7 +37,7 @@ diff -urNad /home/james/debian/packages/binutils/new/binutils-2.15/ld/emultempl/
|
|||
if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
|
||||
force))
|
||||
break;
|
||||
@@ -871,6 +873,8 @@
|
||||
@@ -1154,6 +1156,8 @@
|
||||
rpath = command_line.rpath;
|
||||
if (rpath == NULL)
|
||||
rpath = (const char *) getenv ("LD_RUN_PATH");
|
||||
|
|
|
@ -0,0 +1,13 @@
|
|||
Index: binutils-2.17/bfd/elf32-mips.c
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/bfd/elf32-mips.c 2007-06-28 09:19:34.774949856 +0200
|
||||
+++ binutils-2.17/bfd/elf32-mips.c 2007-06-28 09:19:36.366707872 +0200
|
||||
@@ -1617,7 +1617,7 @@
|
||||
|
||||
/* The SVR4 MIPS ABI says that this should be 0x10000, and Linux uses
|
||||
page sizes of up to that limit, so we need to respect it. */
|
||||
-#define ELF_MAXPAGESIZE 0x10000
|
||||
+#define ELF_MAXPAGESIZE 0x1000
|
||||
#define elf32_bed elf32_tradbed
|
||||
|
||||
/* Include the target file again for this target. */
|
File diff suppressed because it is too large
Load diff
|
@ -1,7 +1,7 @@
|
|||
Index: binutils/bfd/elf32-avr32.c
|
||||
Index: binutils-2.17/bfd/elf32-avr32.c
|
||||
===================================================================
|
||||
--- binutils/bfd/elf32-avr32.c (revision 8769)
|
||||
+++ binutils/bfd/elf32-avr32.c (working copy)
|
||||
--- binutils-2.17.orig/bfd/elf32-avr32.c 2007-06-28 09:19:36.580675344 +0200
|
||||
+++ binutils-2.17/bfd/elf32-avr32.c 2007-06-28 09:19:38.494384416 +0200
|
||||
@@ -298,7 +298,7 @@
|
||||
/* Shortcuts to get to dynamic linker sections. */
|
||||
asection *sgot;
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
Index: binutils/bfd/elf32-avr32.c
|
||||
Index: binutils-2.17/bfd/elf32-avr32.c
|
||||
===================================================================
|
||||
--- binutils/bfd/elf32-avr32.c (revision 24565)
|
||||
+++ binutils/bfd/elf32-avr32.c (working copy)
|
||||
@@ -2446,9 +2446,13 @@
|
||||
--- binutils-2.17.orig/bfd/elf32-avr32.c 2007-06-28 09:19:38.494384416 +0200
|
||||
+++ binutils-2.17/bfd/elf32-avr32.c 2007-06-28 09:19:38.682355840 +0200
|
||||
@@ -2449,9 +2449,13 @@
|
||||
after the relaxation code is done, so we can't really
|
||||
trust that our "distance" is correct. There's really no
|
||||
easy solution to this problem, so we'll just disallow
|
||||
|
|
|
@ -1,6 +1,8 @@
|
|||
--- a/bfd/elf32-avr32.c 2007-05-31 17:00:13.000000000 +0200
|
||||
+++ b/bfd/elf32-avr32.c 2007-05-30 14:07:25.000000000 +0200
|
||||
@@ -395,6 +395,8 @@ avr32_elf_link_hash_table_create(bfd *ab
|
||||
Index: binutils-2.17/bfd/elf32-avr32.c
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/bfd/elf32-avr32.c 2007-06-28 09:19:38.682355840 +0200
|
||||
+++ binutils-2.17/bfd/elf32-avr32.c 2007-06-28 09:19:38.869327416 +0200
|
||||
@@ -395,6 +395,8 @@
|
||||
/* Prevent the BFD core from creating bogus got_entry pointers */
|
||||
ret->root.init_got_refcount.glist = NULL;
|
||||
ret->root.init_plt_refcount.glist = NULL;
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
diff -urN binutils-2.17.orig/bfd/elf32-cris.c binutils-2.17/bfd/elf32-cris.c
|
||||
--- binutils-2.17.orig/bfd/elf32-cris.c 2007-06-12 22:23:24.000000000 +0200
|
||||
+++ binutils-2.17/bfd/elf32-cris.c 2007-06-12 22:28:54.000000000 +0200
|
||||
Index: binutils-2.17/bfd/elf32-cris.c
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/bfd/elf32-cris.c 2007-06-28 09:19:34.053059600 +0200
|
||||
+++ binutils-2.17/bfd/elf32-cris.c 2007-06-28 09:19:39.058298688 +0200
|
||||
@@ -2709,12 +2709,12 @@
|
||||
&& (sec->flags & SEC_READONLY) != 0)
|
||||
{
|
||||
|
|
|
@ -57,9 +57,11 @@ Andreas.
|
|||
* read.c (read_a_source_file): Ignore unknown text after line
|
||||
comment character. Fix misleading comment.
|
||||
|
||||
--- binutils/gas/read.c.~1.78.~ 2004-04-23 08:58:23.000000000 +0200
|
||||
+++ binutils/gas/read.c 2004-04-23 21:49:01.000000000 +0200
|
||||
@@ -950,10 +950,14 @@ read_a_source_file (char *name)
|
||||
Index: binutils-2.17/gas/read.c
|
||||
===================================================================
|
||||
--- binutils-2.17.orig/gas/read.c 2007-06-28 09:19:34.031062944 +0200
|
||||
+++ binutils-2.17/gas/read.c 2007-06-28 09:19:39.244270416 +0200
|
||||
@@ -1008,10 +1008,14 @@
|
||||
unsigned int new_length;
|
||||
char *tmp_buf = 0;
|
||||
|
||||
|
@ -76,7 +78,7 @@ Andreas.
|
|||
s += 4;
|
||||
|
||||
sb_new (&sbuf);
|
||||
@@ -1052,7 +1056,7 @@ read_a_source_file (char *name)
|
||||
@@ -1110,7 +1114,7 @@
|
||||
continue;
|
||||
#endif
|
||||
input_line_pointer--;
|
||||
|
@ -85,9 +87,3 @@ Andreas.
|
|||
demand_empty_rest_of_line ();
|
||||
}
|
||||
|
||||
|
||||
--
|
||||
Andreas Schwab, SuSE Labs, schwab@suse.de
|
||||
SuSE Linux AG, MaxfeldstraÃe 5, 90409 NÃrnberg, Germany
|
||||
Key fingerprint = 58CA 54C7 6D53 942B 1756 01D3 44D5 214B 8276 4ED5
|
||||
"And now for something completely different."
|
||||
|
|
Loading…
Reference in a new issue