upgrade to busybox 1.4.1
SVN-Revision: 6261
This commit is contained in:
parent
c7d1c75fad
commit
a763be2ac6
2 changed files with 2 additions and 13 deletions
|
@ -9,13 +9,13 @@
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=busybox
|
PKG_NAME:=busybox
|
||||||
PKG_VERSION:=1.4.0
|
PKG_VERSION:=1.4.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
|
PKG_SOURCE_URL:=http://www.busybox.net/downloads \
|
||||||
http://distfiles.gentoo.org/distfiles/
|
http://distfiles.gentoo.org/distfiles/
|
||||||
PKG_MD5SUM:=f24a3c1e08bc55ec44381d588e8bcced
|
PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
|
||||||
PKG_CAT:=bzcat
|
PKG_CAT:=bzcat
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- busybox-1.4.0/libbb/xreadlink.c Fri Jan 19 22:23:06 2007
|
|
||||||
+++ busybox-1.4.0-syslogd-n/libbb/xreadlink.c Tue Jan 23 22:35:45 2007
|
|
||||||
@@ -36,7 +36,7 @@
|
|
||||||
|
|
||||||
char *xmalloc_realpath(const char *path)
|
|
||||||
{
|
|
||||||
-#ifdef __GLIBC__
|
|
||||||
+#if defined(__GLIBC__) && !defined(__UCLIBC__)
|
|
||||||
/* glibc provides a non-standard extension */
|
|
||||||
return realpath(path, NULL);
|
|
||||||
#else
|
|
Loading…
Reference in a new issue