update to 2.6.30, refresh patches
SVN-Revision: 18635
This commit is contained in:
parent
6891ad6ef6
commit
a47b8566a1
35 changed files with 48 additions and 56 deletions
|
@ -19,8 +19,8 @@ endif
|
|||
ifeq ($(LINUX_VERSION),2.6.28.10)
|
||||
LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.30.9)
|
||||
LINUX_KERNEL_MD5SUM:=5a4cd5543a9d7c1a819700b21be31ef1
|
||||
ifeq ($(LINUX_VERSION),2.6.30.10)
|
||||
LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
|
||||
endif
|
||||
ifeq ($(LINUX_VERSION),2.6.31.6)
|
||||
LINUX_KERNEL_MD5SUM:=485472df88af84becdcf47f45de3ba46
|
||||
|
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||
|
||||
BOARD:=adm5120
|
||||
BOARDNAME:=Infineon/ADMtek ADM5120
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
SUBTARGETS:=router_le router_be
|
||||
INITRAMFS_EXTRA_FILES:=
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=mips
|
|||
BOARD:=amazon
|
||||
BOARDNAME:=Infineon Amazon
|
||||
FEATURES:=squashfs jffs2 broken
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=ar7
|
|||
BOARDNAME:=TI AR7
|
||||
FEATURES:=squashfs jffs2 atm
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Atheros AR71xx/AR7240/AR913x
|
|||
FEATURES:=squashfs jffs2 tgz
|
||||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=atheros
|
|||
BOARDNAME:=Atheros AR231x/AR5312
|
||||
FEATURES:=squashfs jffs2
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
|
|||
FEATURES:=jffs2 usb pci
|
||||
SUBTARGETS=au1500 au1550
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += hostapd-mini yamonenv
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=avr32
|
|||
BOARD:=avr32
|
||||
BOARDNAME:=Atmel AVR32
|
||||
FEATURES:=squashfs
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=brcm47xx
|
|||
BOARDNAME:=Broadcom BCM947xx/953xx
|
||||
FEATURES:=squashfs usb
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += hostapd-mini kmod-switch kmod-diag nvram
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=mips
|
|||
BOARD:=brcm63xx
|
||||
BOARDNAME:=Broadcom BCM63xx
|
||||
FEATURES:=squashfs jffs2 usb atm pci pcmcia
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
|
|||
FEATURES:=tgz pci ext2
|
||||
CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
diff -urN linux-2.6.30.7/arch/mips/Makefile linux-2.6.30.7.new/arch/mips/Makefile
|
||||
--- linux-2.6.30.7/arch/mips/Makefile 2009-09-27 13:17:16.000000000 +0200
|
||||
+++ linux-2.6.30.7.new/arch/mips/Makefile 2009-09-15 19:46:05.000000000 +0200
|
||||
@@ -83,7 +83,7 @@
|
||||
--- a/arch/mips/Makefile
|
||||
+++ b/arch/mips/Makefile
|
||||
@@ -83,7 +83,7 @@ all-$(CONFIG_BOOT_ELF64) := $(vmlinux-64
|
||||
cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
|
||||
cflags-y += -msoft-float
|
||||
LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
|
||||
|
@ -10,10 +9,9 @@ diff -urN linux-2.6.30.7/arch/mips/Makefile linux-2.6.30.7.new/arch/mips/Makefil
|
|||
|
||||
cflags-y += -ffreestanding
|
||||
|
||||
diff -urN linux-2.6.30.7/arch/mips/include/asm/module.h linux-2.6.30.7.new/arch/mips/include/asm/module.h
|
||||
--- linux-2.6.30.7/arch/mips/include/asm/module.h 2009-09-27 13:17:16.000000000 +0200
|
||||
+++ linux-2.6.30.7.new/arch/mips/include/asm/module.h 2009-09-15 19:46:05.000000000 +0200
|
||||
@@ -9,11 +9,6 @@
|
||||
--- a/arch/mips/include/asm/module.h
|
||||
+++ b/arch/mips/include/asm/module.h
|
||||
@@ -9,11 +9,6 @@ struct mod_arch_specific {
|
||||
struct list_head dbe_list;
|
||||
const struct exception_table_entry *dbe_start;
|
||||
const struct exception_table_entry *dbe_end;
|
||||
|
@ -25,10 +23,9 @@ diff -urN linux-2.6.30.7/arch/mips/include/asm/module.h linux-2.6.30.7.new/arch/
|
|||
};
|
||||
|
||||
typedef uint8_t Elf64_Byte; /* Type for a 8-bit quantity. */
|
||||
diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/kernel/module.c
|
||||
--- linux-2.6.30.7/arch/mips/kernel/module.c 2009-09-27 13:17:16.000000000 +0200
|
||||
+++ linux-2.6.30.7.new/arch/mips/kernel/module.c 2009-09-15 19:46:05.000000000 +0200
|
||||
@@ -43,116 +43,6 @@
|
||||
--- a/arch/mips/kernel/module.c
|
||||
+++ b/arch/mips/kernel/module.c
|
||||
@@ -43,116 +43,6 @@ static struct mips_hi16 *mips_hi16_list;
|
||||
static LIST_HEAD(dbe_list);
|
||||
static DEFINE_SPINLOCK(dbe_lock);
|
||||
|
||||
|
@ -145,7 +142,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
|
|||
void *module_alloc(unsigned long size)
|
||||
{
|
||||
#ifdef MODULE_START
|
||||
@@ -168,45 +58,16 @@
|
||||
@@ -168,45 +58,16 @@ void *module_alloc(unsigned long size)
|
||||
|
||||
return __vmalloc_area(area, GFP_KERNEL, PAGE_KERNEL);
|
||||
#else
|
||||
|
@ -193,7 +190,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
|
|||
/* FIXME: If module_region == mod->init_region, trim exception
|
||||
table entries. */
|
||||
}
|
||||
@@ -214,24 +75,6 @@
|
||||
@@ -214,24 +75,6 @@ void module_free(struct module *mod, voi
|
||||
int module_frob_arch_sections(Elf_Ehdr *hdr, Elf_Shdr *sechdrs,
|
||||
char *secstrings, struct module *mod)
|
||||
{
|
||||
|
@ -218,7 +215,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
|
|||
return 0;
|
||||
}
|
||||
|
||||
@@ -254,41 +97,27 @@
|
||||
@@ -254,41 +97,27 @@ static int apply_r_mips_32_rela(struct m
|
||||
return 0;
|
||||
}
|
||||
|
||||
|
@ -274,7 +271,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
|
|||
{
|
||||
if (v % 4) {
|
||||
printk(KERN_ERR "module %s: dangerous relocation\n", me->name);
|
||||
@@ -296,31 +125,17 @@
|
||||
@@ -296,31 +125,17 @@ static int set_r_mips_26(struct module *
|
||||
}
|
||||
|
||||
if ((v & 0xf0000000) != (((unsigned long)location + 4) & 0xf0000000)) {
|
||||
|
@ -309,7 +306,7 @@ diff -urN linux-2.6.30.7/arch/mips/kernel/module.c linux-2.6.30.7.new/arch/mips/
|
|||
static int apply_r_mips_hi16_rel(struct module *me, u32 *location, Elf_Addr v)
|
||||
{
|
||||
struct mips_hi16 *n;
|
||||
@@ -585,23 +400,11 @@
|
||||
@@ -585,23 +400,11 @@ int module_finalize(const Elf_Ehdr *hdr,
|
||||
list_add(&me->arch.dbe_list, &dbe_list);
|
||||
spin_unlock_irq(&dbe_lock);
|
||||
}
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cirrus Logic EP93xx SoC
|
|||
FEATURES:=squashfs jffs2 ext2 tgz usb
|
||||
CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -10,7 +10,7 @@ ARCH:=cris
|
|||
BOARD:=etrax
|
||||
BOARDNAME:=Foxboard (ETRAX 100LX)
|
||||
FEATURES:=squashfs jffs2
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
DEVICE_TYPE=
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cortina Systems CS351x
|
|||
FEATURES:=squashfs
|
||||
CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -16,8 +16,6 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
|||
arch/arm/mm/proc-syms.c | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/mm/proc-syms.c b/arch/arm/mm/proc-syms.c
|
||||
index 195e48e..ac5c800 100644
|
||||
--- a/arch/arm/mm/proc-syms.c
|
||||
+++ b/arch/arm/mm/proc-syms.c
|
||||
@@ -27,6 +27,7 @@ EXPORT_SYMBOL(__cpuc_flush_kern_all);
|
||||
|
@ -28,6 +26,3 @@ index 195e48e..ac5c800 100644
|
|||
EXPORT_SYMBOL(dmac_inv_range); /* because of flush_ioremap_region() */
|
||||
#else
|
||||
EXPORT_SYMBOL(cpu_cache);
|
||||
--
|
||||
1.6.5.1
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Goldfish (Android Emulator)
|
|||
FEATURES:=
|
||||
CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
DEVICE_TYPE=phone
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=ifxmips
|
|||
BOARDNAME:=Infineon Mips
|
||||
FEATURES:=squashfs jffs2 atm
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=iop32x
|
|||
BOARDNAME:=Intel IOP32x
|
||||
FEATURES:=squashfs jffs2
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=kirkwood
|
|||
BOARDNAME:=Marvell Kirkwood
|
||||
FEATURES:=tgz usb
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=mpc52xx
|
|||
BOARDNAME:=Freescale MPC52xx
|
||||
FEATURES:=tgz ext2
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
LINUX_KARCH:=powerpc
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=mpc83xx
|
|||
BOARDNAME:=Freescale MPC83xx
|
||||
FEATURES:=tgz broken
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
LINUX_KARCH:=powerpc
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Octeon
|
|||
FEATURES:=squashfs jffs2 pci usb
|
||||
CFLAGS:=-Os -pipe -mtune=octeon -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=olpc
|
|||
BOARDNAME:=OLPC XO-1
|
||||
FEATURES:=squashfs ext2
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci kmod-libertas
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Marvell Orion
|
|||
FEATURES:=squashfs
|
||||
SUBTARGETS=generic harddisk
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC40x
|
|||
FEATURES:=squashfs
|
||||
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
LINUX_KARCH:=powerpc
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC44x
|
|||
FEATURES:=squashfs
|
||||
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
LINUX_KARCH:=powerpc
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
|
|
@ -13,7 +13,7 @@ MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
|
|||
SUBTARGETS=petitboot
|
||||
FEATURES+=powerpc64
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
KERNEL_CC:=
|
||||
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=pxcab
|
|||
BOARDNAME:=PowerXCell Accelerator Board
|
||||
FEATURES+=powerpc64 fpu ramdisk
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
KERNEL_CC:=
|
||||
|
||||
|
|
|
@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x
|
|||
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
|
||||
FEATURES:=squashfs broken
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES+=kmod-leds-gpio
|
||||
|
|
|
@ -11,7 +11,7 @@ BOARD:=rb532
|
|||
BOARDNAME:=Mikrotik RouterBoard 532
|
||||
FEATURES:=jffs2 pci tgz
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
DEFAULT_PACKAGES += hostapd-mini kmod-madwifi kmod-input-rb532
|
||||
|
|
|
@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 pci usb pcmcia
|
|||
CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
|
||||
SUBTARGETS:=amit ar525w r8610 dir-450 sitecom
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Samsung S3C24xx
|
|||
FEATURES:=jffs2
|
||||
CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
DEVICE_TYPE=phone
|
||||
|
||||
|
|
|
@ -12,7 +12,7 @@ BOARDNAME:=Broadcom/SiByte SB-1
|
|||
FEATURES:=fpu
|
||||
CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
|
@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
|
|||
FEATURES:=ext2
|
||||
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
|
||||
|
||||
LINUX_VERSION:=2.6.30.9
|
||||
LINUX_VERSION:=2.6.30.10
|
||||
|
||||
include $(INCLUDE_DIR)/target.mk
|
||||
|
||||
|
|
Loading…
Reference in a new issue