iproute2: update to 2.6.39
Signed-off-by: Daniel Mierswa <impulze@impulze.org> SVN-Revision: 28378
This commit is contained in:
parent
ce5e1abbb7
commit
a3284cb0e1
5 changed files with 8 additions and 17 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=2.6.35
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=2.6.39
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
|
||||
PKG_MD5SUM:=b0f281b3124bf04669e18f5fe16d4934
|
||||
PKG_MD5SUM:=8a3b6bc77c2ecf752284aa4a6fc630a6
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
|
||||
|
|
|
@ -654,9 +654,9 @@
|
|||
TCMODULES += q_multiq.o
|
||||
TCMODULES += q_netem.o
|
||||
+TCMODULES += q_wrr.o
|
||||
TCMODULES += q_choke.o
|
||||
TCMODULES += f_rsvp.o
|
||||
TCMODULES += f_u32.o
|
||||
TCMODULES += f_route.o
|
||||
--- a/tc/q_htb.c
|
||||
+++ b/tc/q_htb.c
|
||||
@@ -1,3 +1,311 @@
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- a/ip/iproute.c
|
||||
+++ b/ip/iproute.c
|
||||
@@ -1286,6 +1286,7 @@ int iproute_get(int argc, char **argv)
|
||||
memset(&req, 0, sizeof(req));
|
||||
|
||||
iproute_reset_filter();
|
||||
+ filter.cloned = 2;
|
||||
|
||||
req.n.nlmsg_len = NLMSG_LENGTH(sizeof(struct rtmsg));
|
||||
req.n.nlmsg_flags = NLM_F_REQUEST;
|
|
@ -4,12 +4,13 @@
|
|||
|
||||
--- a/include/linux/netfilter_ipv4/ip_tables.h
|
||||
+++ b/include/linux/netfilter_ipv4/ip_tables.h
|
||||
@@ -113,7 +113,10 @@ struct ipt_entry {
|
||||
@@ -113,8 +113,11 @@ struct ipt_entry {
|
||||
#define IPT_CONTINUE XT_CONTINUE
|
||||
#define IPT_RETURN XT_RETURN
|
||||
|
||||
+#include <linux/version.h>
|
||||
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
|
||||
/* This group is older than old (iptables < v1.4.0-rc1~89) */
|
||||
#include <linux/netfilter/xt_tcpudp.h>
|
||||
+#endif
|
||||
#define ipt_udp xt_udp
|
||||
|
|
|
@ -5,9 +5,9 @@
|
|||
TCMODULES += m_pedit.o
|
||||
TCMODULES += m_skbedit.o
|
||||
+TCMODULES += m_connmark.o
|
||||
TCMODULES += m_csum.o
|
||||
TCMODULES += p_ip.o
|
||||
TCMODULES += p_icmp.o
|
||||
TCMODULES += p_tcp.o
|
||||
--- /dev/null
|
||||
+++ b/tc/m_connmark.c
|
||||
@@ -0,0 +1,71 @@
|
||||
|
|
Loading…
Reference in a new issue