gdb: bump to 8.1.1
GDB 8.1.1 brings the following fixes and enhancements over GDB 8.1: * PR gdb/22824 (misleading description of new rbreak Python function in GDB 8.1 NEWS file) * PR gdb/22849 (ctrl-c doesn't work in extended-remote) * PR gdb/22907 ([Regression] gdbserver doesn't work with filename-only binaries) * PR gdb/23028 (inconsistent disassemble of vcvtpd2dq) * PR gdb/23053 (Fix -D_GLIBCXX_DEBUG gdb-add-index regression) * PR gdb/23127 ([AArch64] GDB cannot be used for debugging software that uses high Virtual Addresses) * PR server/23158 (gdbserver no longer functional on Windows) * PR breakpoints/23210 ([8.1/8.2 Regression] Bogus Breakpoint address adjusted from 0xf7fe7dd3 to 0xfffffffff7fe7dd3) Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
This commit is contained in:
parent
3df400c87e
commit
a2a225517d
3 changed files with 9 additions and 9 deletions
|
@ -8,12 +8,12 @@
|
|||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gdb
|
||||
PKG_VERSION:=8.1
|
||||
PKG_VERSION:=8.1.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@GNU/gdb
|
||||
PKG_HASH:=af61a0263858e69c5dce51eab26662ff3d2ad9aa68da9583e8143b5426be4b34
|
||||
PKG_HASH:=97dcc3169bd430270fc29adb65145846a58c1b55cdbb73382a4a89307bdad03c
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_INSTALL:=1
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1300,13 +1300,13 @@ if test -z "$LD"; then
|
||||
@@ -1293,13 +1293,13 @@ if test -z "$LD"; then
|
||||
fi
|
||||
fi
|
||||
|
||||
|
@ -17,7 +17,7 @@
|
|||
AC_LANG_PUSH(C++)
|
||||
AC_LINK_IFELSE([
|
||||
#if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
|
||||
@@ -1632,7 +1632,7 @@ AC_ARG_WITH(stage1-ldflags,
|
||||
@@ -1625,7 +1625,7 @@ AC_ARG_WITH(stage1-ldflags,
|
||||
# if supported. But if the user explicitly specified the libraries to use,
|
||||
# trust that they are doing what they want.
|
||||
if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
|
||||
|
@ -26,7 +26,7 @@
|
|||
fi])
|
||||
AC_SUBST(stage1_ldflags)
|
||||
|
||||
@@ -1661,7 +1661,7 @@ AC_ARG_WITH(boot-ldflags,
|
||||
@@ -1654,7 +1654,7 @@ AC_ARG_WITH(boot-ldflags,
|
||||
# statically. But if the user explicitly specified the libraries to
|
||||
# use, trust that they are doing what they want.
|
||||
if test "$poststage1_libs" = ""; then
|
||||
|
@ -37,7 +37,7 @@
|
|||
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -5005,14 +5005,14 @@ if test -z "$LD"; then
|
||||
@@ -4998,14 +4998,14 @@ if test -z "$LD"; then
|
||||
fi
|
||||
fi
|
||||
|
||||
|
@ -56,7 +56,7 @@
|
|||
ac_ext=cpp
|
||||
ac_cpp='$CXXCPP $CPPFLAGS'
|
||||
ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
|
||||
@@ -5795,7 +5795,7 @@ else
|
||||
@@ -5788,7 +5788,7 @@ else
|
||||
# if supported. But if the user explicitly specified the libraries to use,
|
||||
# trust that they are doing what they want.
|
||||
if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
|
||||
|
@ -65,7 +65,7 @@
|
|||
fi
|
||||
fi
|
||||
|
||||
@@ -5831,7 +5831,7 @@ else
|
||||
@@ -5824,7 +5824,7 @@ else
|
||||
# statically. But if the user explicitly specified the libraries to
|
||||
# use, trust that they are doing what they want.
|
||||
if test "$poststage1_libs" = ""; then
|
||||
|
|
|
@ -27,7 +27,7 @@ gdb/ChangeLog:
|
|||
|
||||
--- a/gdb/common/signals-state-save-restore.c
|
||||
+++ b/gdb/common/signals-state-save-restore.c
|
||||
@@ -41,7 +41,7 @@ save_original_signals_state (void)
|
||||
@@ -41,7 +41,7 @@ save_original_signals_state (bool quiet)
|
||||
int i;
|
||||
int res;
|
||||
|
||||
|
|
Loading…
Reference in a new issue