move fuse from target/linux/package/ to package/, update to v2.5.3, add userland lib, util and dev stuff from trunk.
SVN-Revision: 3966
This commit is contained in:
parent
5b24439170
commit
a23d25253f
8 changed files with 160 additions and 103 deletions
117
openwrt/package/fuse/Makefile
Normal file
117
openwrt/package/fuse/Makefile
Normal file
|
@ -0,0 +1,117 @@
|
|||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
include $(TOPDIR)/package/kernel.mk
|
||||
|
||||
PKG_NAME:=fuse
|
||||
PKG_VERSION:=2.5.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=9c7e8b6606b9f158ae20b8521ba2867c
|
||||
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
define Package/kmod-fuse
|
||||
SECTION:=drivers
|
||||
CATEGORY:=Drivers
|
||||
DEPENDS:=
|
||||
TITLE:=FUSE (Filesystem in UserSpacE)
|
||||
DESCRIPTION:=FUSE (Filesystem in UserSpacE)
|
||||
URL:=http://fuse.sourceforge.net/
|
||||
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
rm -rf config.{cache,status} ; \
|
||||
touch configure.in ; \
|
||||
touch aclocal.m4 ; \
|
||||
touch Makefile.in ; \
|
||||
touch include/config.h.in ; \
|
||||
touch configure ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--enable-kernel-module \
|
||||
--enable-lib \
|
||||
--enable-util \
|
||||
--disable-example \
|
||||
--disable-auto-modprobe \
|
||||
--with-kernel=$(LINUX_DIR) \
|
||||
--disable-mtab \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
ARCH="$(LINUX_KARCH)" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
PATH="$(TARGET_PATH)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/kmod-fuse/install
|
||||
install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
|
||||
$(CP) $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX) \
|
||||
$(1)/lib/modules/$(LINUX_VERSION)/
|
||||
install -d -m0755 $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfuse.so.* $(1)/usr/lib/
|
||||
install -d -m0755 $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/fusermount $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/fuse $(STAGING_DIR)/usr/include/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/fuse.h $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfuse.a $(STAGING_DIR)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfuse.so* $(STAGING_DIR)/usr/lib/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/fuse.pc $(STAGING_DIR)/usr/lib/pkgconfig/
|
||||
$(SED) 's,-I$${includedir}/fuse,,g' $(STAGING_DIR)/usr/lib/pkgconfig/fuse.pc
|
||||
$(SED) 's,-L$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/fuse.pc
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/include/fuse \
|
||||
$(STAGING_DIR)/usr/include/fuse.h \
|
||||
$(STAGING_DIR)/usr/lib/libfuse.a \
|
||||
$(STAGING_DIR)/usr/lib/libfuse.so* \
|
||||
$(STAGING_DIR)/usr/lib/pkgconfig/fuse.pc
|
||||
endef
|
||||
|
||||
|
||||
$(eval $(call BuildPackage,kmod-fuse))
|
15
openwrt/package/fuse/patches/102-no_depmod.patch
Normal file
15
openwrt/package/fuse/patches/102-no_depmod.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
diff -ruN fuse-2.5.3-old/kernel/Makefile.in fuse-2.5.3-new/kernel/Makefile.in
|
||||
--- fuse-2.5.3-old/kernel/Makefile.in 2006-06-17 00:04:06.000000000 +0200
|
||||
+++ fuse-2.5.3-new/kernel/Makefile.in 2006-06-17 00:08:44.000000000 +0200
|
||||
@@ -31,11 +31,9 @@
|
||||
install-y: all
|
||||
$(mkdir_p) $(DESTDIR)$(fusemoduledir)
|
||||
$(INSTALL) -m 644 $(fusemodule) $(DESTDIR)$(fusemoduledir)/$(fusemodule)
|
||||
- -/sbin/depmod -a
|
||||
|
||||
uninstall-y:
|
||||
rm -f $(DESTDIR)$(fusemoduledir)/$(fusemodule)
|
||||
- -/sbin/depmod -a
|
||||
|
||||
clean:
|
||||
-rm -f $(fusemodule) *.o .*.cmd *.mod.c *.ko *.s */*.o
|
16
openwrt/package/fuse/patches/111-uclibc_changes.patch
Normal file
16
openwrt/package/fuse/patches/111-uclibc_changes.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
diff -ruw fuse-2.4.0/util/fusermount.c.org fuse-2.4.0/util/fusermount.c
|
||||
--- fuse-2.4.0/util/fusermount.c.org 2005-10-14 11:34:06.000000000 +0200
|
||||
+++ fuse-2.4.0/util/fusermount.c 2005-10-14 11:56:26.000000000 +0200
|
||||
@@ -42,7 +42,12 @@
|
||||
#define FUSE_COMMFD_ENV "_FUSE_COMMFD"
|
||||
|
||||
#define FUSE_DEV_OLD "/proc/fs/fuse/dev"
|
||||
+#ifdef __UCLIBC__
|
||||
+/* /dev is mounted as devfs in OpenWRT, and device is created here */
|
||||
+#define FUSE_DEV_NEW "/dev/misc/fuse"
|
||||
+#else
|
||||
#define FUSE_DEV_NEW "/dev/fuse"
|
||||
+#endif
|
||||
#define FUSE_VERSION_FILE_OLD "/proc/fs/fuse/version"
|
||||
#define FUSE_CONF "/etc/fuse.conf"
|
||||
|
12
openwrt/package/fuse/patches/112-no_break_on_mknod.patch
Normal file
12
openwrt/package/fuse/patches/112-no_break_on_mknod.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -ruN fuse-2.4.1-old/util/Makefile.in fuse-2.4.1-new/util/Makefile.in
|
||||
--- fuse-2.4.1-old/util/Makefile.in 2005-10-17 12:29:20.000000000 +0200
|
||||
+++ fuse-2.4.1-new/util/Makefile.in 2005-10-19 17:11:13.000000000 +0200
|
||||
@@ -445,7 +445,7 @@
|
||||
install-exec-hook:
|
||||
-chown root $(DESTDIR)$(bindir)/fusermount
|
||||
-chmod u+s $(DESTDIR)$(bindir)/fusermount
|
||||
- @if test ! -e $(DESTDIR)/dev/fuse; then \
|
||||
+ -@if test ! -e $(DESTDIR)/dev/fuse; then \
|
||||
$(mkdir_p) $(DESTDIR)/dev; \
|
||||
echo "mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229"; \
|
||||
mknod $(DESTDIR)/dev/fuse -m 0666 c 10 229; \
|
|
@ -1,19 +0,0 @@
|
|||
config PACKAGE_KMOD_FUSE
|
||||
prompt "kmod-fuse......................... FUSE kernel module"
|
||||
tristate
|
||||
default m if DEVEL
|
||||
help
|
||||
With FUSE it is possible to implement a fully functional
|
||||
filesystem in a userspace program.
|
||||
|
||||
Features include:
|
||||
|
||||
* Simple library API
|
||||
* Simple installation (no need to patch or recompile the kernel)
|
||||
* Secure implementation
|
||||
* Userspace - kernel interface is very efficient
|
||||
* Usable by non privileged users
|
||||
* Runs on Linux kernels 2.4.X and 2.6.X
|
||||
* Has proven very stable over time
|
||||
|
||||
http://fuse.sourceforge.net/
|
|
@ -1,80 +0,0 @@
|
|||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
include ../../rules.mk
|
||||
|
||||
PKG_NAME:=fuse
|
||||
PKG_VERSION:=2.5.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=ea565debe6c7486963bef05c45c50361
|
||||
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(TOPDIR)/package/rules.mk
|
||||
|
||||
$(eval $(call PKG_template,KMOD_FUSE,kmod-fuse,$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
|
||||
|
||||
$(PKG_BUILD_DIR)/.configured:
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
rm -rf config.{cache,status} ; \
|
||||
touch configure.in ; \
|
||||
touch aclocal.m4 ; \
|
||||
touch Makefile.in ; \
|
||||
touch include/config.h.in ; \
|
||||
touch configure ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--enable-kernel-module \
|
||||
--disable-lib \
|
||||
--disable-util \
|
||||
--disable-example \
|
||||
--disable-auto-modprobe \
|
||||
--with-kernel=$(LINUX_DIR) \
|
||||
--disable-mtab \
|
||||
);
|
||||
touch $@
|
||||
|
||||
$(PKG_BUILD_DIR)/.built:
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
ARCH="$(LINUX_KARCH)" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
PATH="$(TARGET_PATH)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
SUBDIRS="kernel" \
|
||||
all install
|
||||
touch $@
|
||||
|
||||
$(IPKG_KMOD_FUSE):
|
||||
mkdir -p $(IDIR_KMOD_FUSE)/lib/modules/$(LINUX_VERSION)
|
||||
$(CP) $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX) \
|
||||
$(IDIR_KMOD_FUSE)/lib/modules/$(LINUX_VERSION)/
|
||||
$(IPKG_BUILD) $(IDIR_KMOD_FUSE) $(PACKAGE_DIR)
|
||||
|
|
@ -1,4 +0,0 @@
|
|||
Package: kmod-fuse
|
||||
Priority: optional
|
||||
Section: sys
|
||||
Description: Filesystem in Userspace (kernel module)
|
Loading…
Reference in a new issue